QT UI Inactive button while (re-) connecting in progress

Bug #878867 reported by Lisette Slegers
20
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Ubuntu One Control Panel
Status tracked in Trunk
Stable-3-0
Undecided
Unassigned
Trunk
Medium
Diego Sarmentero

Bug Description

When Ubuntu One for Windows is disconnected, and a user presses 'Connect', the button becomes inactive. This is good, because pressing it over and over again does not speed up the process, but we should show more clearly that connecting is in progress and something is happening.

Please see attached a screenshot of my proposal. We could display a grey arrow icon, a message that says "Connecting..." and make the button look more inactive. In the mock up, I have set "Please wait" to be the button label, but this is TBD.

Related branches

Revision history for this message
Lisette Slegers (lisette-slegers) wrote :
security vulnerability: yes → no
Revision history for this message
Natalia Bidart (nataliabidart) wrote :

Diego,

I'm assigning this bug to you, but you should not work on it until the working and design are signed off.

Thanks!

Changed in ubuntuone-control-panel:
status: New → Confirmed
assignee: nobody → Diego Sarmentero (diegosarmentero)
importance: Undecided → Medium
visibility: private → public
Changed in ubuntuone-control-panel:
status: Confirmed → In Progress
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers