alter speed limit layout

Bug #715812 reported by Daniel Fore on 2011-02-09
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Ubuntu One Control Panel
Medium
Natalia Bidart
ubuntuone-control-panel (Ubuntu)
Medium
Natalia Bidart

Bug Description

The following is a list of small improvements to the speed limits portion of the Devices page:

* The labels for "max upload speed" and "max download speed" should be left aligned with the label "limit bandwidth usage"

* The above should be done without mis-aligned the two spinbuttons associated with each label. These should also be left-aligned to each other as they are now.

* The units associated with the spin button should appear after it. As in "2048 kbps" as opposed to "(kbps) 2048"

* The labels for the spin buttons should end with a ":" as in "Max upload speed: [ 2048 ] kbps"

* If the checkbox "Limit bandwidth usage" is unchecked, the labels and spinbuttons below it should become insensitive as they don't actually affect anything.

Related branches

Daniel Fore (danrabbit) wrote :
Daniel Fore (danrabbit) wrote :

After further review of GNOME HIG, units should also be displayed *after* the spinbutton.

http://library.gnome.org/devel/hig-book/nightly/controls-spin-boxes.html.en

Natalia Bidart (nataliabidart) wrote :

Daniel,

thanks a lot for looking into this. We can't enable/disable limits separately (syncdaemon will not allow that), either we limit both or we limit none. So we still need the general 'limit bandwidth' checkbutton.

I'm closing this as Invalid, but please, if you think we can make improvements by re-arranging stuff or adding padding or similar, please re-open stating what changes we can do (as long as we maintain the single limit bandwidth option).

Thanks!

Changed in ubuntuone-control-panel:
status: New → Invalid
Daniel Fore (danrabbit) wrote :

These could easily be worked around with a little bit of hackery. Instead of making the user set a bandwidth limit, simply set it to a huge number like 9999999999 kbps.

But this bug covers much more than just having separate checkboxes for speed limits. It also covers language, alignment, sensitivity, etc.

re-opening at least for those points ;)

Changed in ubuntuone-control-panel:
status: Invalid → Confirmed
Natalia Bidart (nataliabidart) wrote :

Daniel,

Performing such as hack can have undesired consequences about bandwidth throttling. For example, no matter how big the throttling limit is, a user can always have a faster connection. Also, if bandwidth throttling is enabled, syncdaemon works differently in the sense that it performs extra tasks that can be avoided if the throttling is disabled.

Regarding the rest of the points I don't have a clear idea of what's left other than left-aligning the labels for the spinners. Can you please explicitly list what other improvements you would like us to make?

Thanks!

Changed in ubuntuone-control-panel:
status: Confirmed → Triaged
importance: Undecided → Low
assignee: nobody → Naty Bidart (nataliabidart)
Daniel Fore (danrabbit) wrote :

Ah, okay good counterpoint.

I've updated the bug report to reflect more specifically the design changes :)

description: updated
Natalia Bidart (nataliabidart) wrote :

Thanks, is much clearer now.

Changed in ubuntuone-control-panel:
importance: Low → Medium
Changed in ubuntuone-control-panel:
status: Triaged → Fix Committed
Natalia Bidart (nataliabidart) wrote :

Disabling the spin buttons is still pending.

Changed in ubuntuone-control-panel:
status: Fix Committed → Triaged
Daniel Fore (danrabbit) wrote :

Hey Naty, it's looking really good. The two things I still noticed are:

* (like you already said) insensitivity

* Labels for "Max upload speed" and "Max download speed" are aligned with the checkbox above. Instead they should be aligned with the label "Limit bandwidth usage". This is important since "Limit Bandwidth usage" is actually the header for these items :)

tags: added: desktop+ u1-natty u1cp-gui
Changed in ubuntuone-control-panel (Ubuntu):
assignee: nobody → Naty Bidart (nataliabidart)
importance: Undecided → Medium
status: New → Triaged
tags: added: u1-gui
removed: u1cp-gui
tags: removed: desktop+ u1-gui u1-natty
tags: added: desktop+ u1-gui u1-natty
Changed in ubuntuone-control-panel:
status: Triaged → In Progress
Changed in ubuntuone-control-panel:
status: In Progress → Fix Committed
Changed in ubuntuone-control-panel (Ubuntu):
milestone: none → ubuntu-11.04-beta-1
tags: added: u1-natty-beta
dobey (dobey) on 2011-03-10
Changed in ubuntuone-control-panel:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntuone-control-panel - 0.9.1-0ubuntu1

---------------
ubuntuone-control-panel (0.9.1-0ubuntu1) natty; urgency=low

  * New upstream release.
    - Display notice when merging volumes (LP: #674462)
    - Show visible message when out of space (LP: #701729)
    - Move 'get support' button (LP: #706661)
    - Purchased Music folder not clearly shown (LP: #720650)
    - More UI tweaks (LP: #728663)
    - Redesign Services tab (LP: #729361)
    - Better icon for folder owner (LP: #706034)
    - Center status messages on toolbar (LP: #715715)
    - Alter bandwidth throttling layout (LP: #715812)
    - Tooltip for 'Edit' is unhelpful (LP: #715822)
    - Tooltip for 'Buy more storage' not helpful (LP: #715875)
    - Improve off-line experience (LP: #720990)
    - Make link buttons in Account tab regular buttons (LP: #725143)
    - Typo: 'accress' (LP: #725802)
    - Show local device first in devices list (LP: #727996)
    - Misc. improvements to GTK+ UI (LP: #727998)
    - Service names should use title format (LP: #728027)
  * Require new version of ubuntuone-client
 -- Rodney Dawes <email address hidden> Wed, 09 Mar 2011 21:59:45 -0500

Changed in ubuntuone-control-panel (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers