Can't publish files in Ubuntu One

Bug #1193274 reported by Nicholas Shatokhin on 2013-06-21
136
This bug affects 26 people
Affects Status Importance Assigned to Milestone
Ubuntu One Client
Undecided
Unassigned
Stable-3-0
Medium
Unassigned
ubuntuone-client (Ubuntu)
Critical
Unassigned
Precise
Critical
dobey

Bug Description

[Impact]
Choosing to publish a file on Ubuntu One from within the file manager, results in the "Publish" menu item being disabled, a notification of "A file is no longer published," and a couple of errors in the logs. Also, when attempting to use the "Publish" action on a file which is already made public on the server, the file will no longer be published.

[Fix]
The fix entails removing the zeitgeist logging integration, to remove any possibility of errors in the zeitgeist logging code. The feature has never been utilized as it was intended, and removing it reduces potential for errors, performance losses, and maintenance costs. The second part of the fix is to ensure the Content-Type header is
being set correctly in the POST request to the REST API. And update on the server has introduced increased strictness, and causes this error.

[Test Case]
On an Ubuntu 12.04 machine with a connected Ubuntu One account, attempt to publish a file by going into the ~/Ubuntu One/ sub-directory in the Nautilus file manager, selecting a file, and choosing "Publish" from the "Ubuntu One" sub-menu in the right-click menu. With the updates in precise, the file will not be published, or if already published, will no longer be published. This can also be verified by looking at the account at https://one.ubuntu.com/files/ as well.

After installing the ubuntuone-client 3.0.2-0ubuntu2 package from the proposed repository, the errors in the log will no longer occur, and the Publish action will
work correctly as expected.

[Regression Potential]
No regressions should occur as a result of this change.

Nicholas Shatokhin (robotex) wrote :
John Pugh (jpugh) wrote :

Confirming the exact same thing happens to me even after a reboot. Looking at u1 through a browser, I see that the file is indeed published, but the details of the "publish" are not sync'd to the client.

Changed in ubuntuone-client (Ubuntu):
status: New → Confirmed
John Pugh (jpugh) wrote :

I have now removed ALL shared file links, nothing shows public through magicicada or through the one.ubuntu.com. I STILL cannot publish any files through nautilus. The only method for making a file public is through one.ubuntu.com

Andrew Montalenti (andrewm-l) wrote :

Yep, this affects me, too. I used to use Ubuntu One publishing all the time via integration with Shutter screenshot tool. But now it just stopped working, as did all file sharing / publishing functionality with this "A file is no longer published" message. Seems like it must be a bug in ubuntuone-client -- any update from Ubuntu team?

Dave Morley (davmor2) on 2013-07-22
Changed in ubuntuone-client (Ubuntu):
importance: Undecided → Critical
importance: Critical → High
assignee: nobody → Ubuntu One Client Engineering team (ubuntuone-client-engineering)
tags: added: u1-by-user u1-files u1-on-production
FairMiles (fermilesi) wrote :

Same thing here, but with Ubuntu 12.04 LTS 32 bits
[in addition, I can't get the links or buttons in Firefox to publish through the web so, basically, I cannot publish...)

John Pugh (jpugh) wrote :

This affects a number of people, has multiple duplicates, and is 100% re-creatable making the U1 service unusable from within Ubuntu desktop.

Changed in ubuntuone-client (Ubuntu):
importance: High → Critical
Leo Arias (elopio) wrote :

We are also getting a lot of support requests because of this. So, lets give it priority critical + 1 :)

Valen (valentinconesa) wrote :

Same problem here, in Ubuntu 12.04 64bits on two different computers.

Roberto Alsina (ralsina) on 2013-08-26
Changed in ubuntuone-client (Ubuntu):
assignee: Ubuntu One Client Engineering team (ubuntuone-client-engineering) → Rodney Dawes (dobey)
dobey (dobey) on 2013-08-26
Changed in ubuntuone-client (Ubuntu Precise):
assignee: nobody → Rodney Dawes (dobey)
status: New → Confirmed
Changed in ubuntuone-client (Ubuntu):
status: Confirmed → Fix Released
assignee: Rodney Dawes (dobey) → nobody
Changed in ubuntuone-client (Ubuntu Precise):
importance: Undecided → Critical
dobey (dobey) on 2013-08-30
Changed in ubuntuone-client:
status: New → Fix Released
dobey (dobey) on 2013-09-10
description: updated
Changed in ubuntuone-client (Ubuntu Precise):
status: Confirmed → In Progress
dobey (dobey) on 2013-09-11
description: updated

Hello Nicholas, or anyone else affected,

Accepted ubuntuone-client into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/ubuntuone-client/3.0.2-0ubuntu2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in ubuntuone-client (Ubuntu Precise):
status: In Progress → Fix Committed
tags: added: verification-needed
taka k. (scar) wrote :

updated to 3.0.2-0ubuntu2 and i can confirm that the client now works as expected

tags: added: verification-done
removed: verification-needed
orthops (gilles-sanmartin) wrote :

Did not work for me :-(

tags: added: verification-failed
dobey (dobey) wrote :

@orthops Can you please be more specific about what isn't working for you and specifically what version you are using where it failed?

John Pugh (jpugh) wrote :

Ah yea...it's fixed now. This works for me as designed. I had to kill ubuntuone-syncdaemon, but it worked after it was restarted.

orthops (gilles-sanmartin) wrote :

Sorry.
I'm on Ubuntu 12.04 64bits.
The bug is exactly as in the description : in the ubuntu one directory when I right-clic and choose "publish" I receive a message that the file will no more be published.

I tried to install the ubuntu one client from the proposed repository but now I realise that I have probably not installed the right one.
I followed the instructions from the wiki to enable the proposed repository and avoid the upgrade of all packages (file file /etc/apt/preferences)
I then tried : sudo apt-get install packagename/precise-proposed as recommended but I was not able to find the right package name.
So I went to the apt graphical interface and installed the following package seemingly from the proposed repository :
ubuntuone-client (3.0.2-0ubuntu1)

But I realise now that I would need ubuntuone-client (3.0.2-0ubuntu2) instead.
I tried :
sudo apt-get install ubuntuone-client_3.0.2-0ubuntu2/precise-proposed
sudo apt-get install "ubuntuone-client (3.0.2-0ubuntu2)"/precise-proposed
But I can't find it.

I installed aptitude and used the command from the wiki to obtain the list of available packages :
sudo aptitude -t precise-proposed
But it does not work.

dobey (dobey) wrote :

@orthops OK. Then you are using the old version still. You need to install ubuntuone-client from precise-proposed. The way to install a specific version with apt-get is to use package=version, so ubuntuone-client=3.0.2-0ubuntu2.

As John mentioned, ubuntuone-syncdaemon will have to be restarted after upgrading the ubuntuone-client packages (most importantly for this fix, being python-ubuntuone-client).

tags: removed: verification-failed
Oleg (oleg-secondary) wrote :

it works, files can be published now

but when I restart computer ubuntuone "forgets" about files published earlier, and if I want to copy link, I have to choose "Publish" once again

dobey (dobey) wrote :

@Oleg yes, the state of being public is not cached locally, as it is done via REST API, and not via the persistent connection for sync. It's unrelated to this issue or its fix, and there are open bugs on it.

Karl (karl-z) wrote :

I can confirm this fix also works for me. Thanks.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntuone-client - 3.0.2-0ubuntu2

---------------
ubuntuone-client (3.0.2-0ubuntu2) precise-proposed; urgency=low

  * debian/control:
  * debian/python-ubuntuone-client.install:
  * debian/patches/01_bzr1384_remove_zg.patch,
    debian/patches/02_bzr-ensure-content-type.patch:
    - Backport removal of zeitgeist usage,
    - Set the Content-Type header for the POST request.
    - Set public_url to '' when it is None. (LP: #1193274)
 -- Rodney Dawes <email address hidden> Fri, 30 Aug 2013 16:46:51 -0400

Changed in ubuntuone-client (Ubuntu Precise):
status: Fix Committed → Fix Released

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers