ubuntuone-syncdaemon crashed with AttributeError in _server_callback(): 'module' object has no attribute 'spawn_command_line_async'

Bug #1065272 reported by David Britton on 2012-10-10
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu One Client
Status tracked in Trunk
Stable-3-0
Undecided
Unassigned
Stable-4-0
Undecided
Unassigned
Stable-4-2
Undecided
Unassigned
Trunk
Medium
Manuel de la Peña
ubuntuone-client (Ubuntu)
Medium
Unassigned
Precise
Undecided
Unassigned
Quantal
Undecided
Unassigned
Raring
Medium
Unassigned

Bug Description

Just uploading a small PDF to publish it, nothing special was being done.

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: ubuntuone-client 3.0.2-0ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-31.50-generic 3.2.28
Uname: Linux 3.2.0-31-generic x86_64
NonfreeKernelModules: fglrx
ApportVersion: 2.0.1-0ubuntu13
Architecture: amd64
CrashDB: ubuntuone
Date: Wed Oct 10 15:49:25 2012
ExecutablePath: /usr/lib/ubuntuone-client/ubuntuone-syncdaemon
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha amd64 (20120109)
InterpreterPath: /usr/bin/python2.7
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/lib/ubuntuone-client/ubuntuone-syncdaemon
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, user)
 LANG=en_US.UTF-8
PythonArgs: ['/usr/lib/ubuntuone-client/ubuntuone-syncdaemon']
SourcePackage: ubuntuone-client
ThirdParty: True
Title: ubuntuone-syncdaemon crashed with AttributeError in _server_callback(): 'module' object has no attribute 'spawn_command_line_async'
Traceback:
 Traceback (most recent call last):
   File "/usr/lib/python2.7/dist-packages/ubuntuone-client/ubuntuone/platform/linux/messaging.py", line 72, in _server_callback
     glib.spawn_command_line_async('ubuntuone-installer')
 AttributeError: 'module' object has no attribute 'spawn_command_line_async'
UbuntuOneSyncdaemonExceptionsLog:

UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip libvirtd lpadmin plugdev sambashare sudo

Related branches

David Britton (davidpbritton) wrote :
Leo Arias (elopio) wrote :

I'm sorry to hear Ubuntu One is not working properly for you. Can you do the following in order to provide us with important details that will help us determine the root cause of this issue?

    Open Applications->Accessories->Terminal and run: echo -e "[logging]\nlevel = DEBUG" > ~/.config/ubuntuone/logging.conf; u1sdtool -q; u1sdtool -c
    Try to reproduce the problem.
    Attach ~/.cache/ubuntuone/log/syncdaemon.log and ~/.cache/ubuntuone/log/syncdaemon-exception.log to this bug report

Note that attaching syncdaemon.log will show filenames you are attempting to sync with Ubuntu One. If you do not want this to be public, please mark the bug as private and this bug report will only be available to you and the Ubuntu One team.

Thank you,

tags: added: desktop+
Changed in ubuntuone-client:
assignee: nobody → Ubuntu One Desktop+ team (ubuntuone-desktop+)
status: New → Incomplete
Manuel de la Peña (mandel) wrote :

I can confirm that this bug happens, the reason is that the system that has the failure is not using the GLib from gi.repository but the glib python module which does not have the function spawn_command_line_async.

Changed in ubuntuone-client:
importance: Undecided → Medium
status: Incomplete → Confirmed
assignee: Ubuntu One Desktop+ team (ubuntuone-desktop+) → Manuel de la Peña (mandel)
Changed in ubuntuone-client:
status: Confirmed → Fix Committed
tags: removed: need-duplicate-check
Changed in ubuntuone-client (Ubuntu):
importance: Undecided → Medium
dobey (dobey) on 2012-12-11
Changed in ubuntuone-client (Ubuntu Raring):
status: New → Triaged
Changed in ubuntuone-client (Ubuntu Quantal):
status: New → Triaged
Changed in ubuntuone-client (Ubuntu Precise):
status: New → Triaged
information type: Private → Public
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntuone-client - 4.1.0-0ubuntu1

---------------
ubuntuone-client (4.1.0-0ubuntu1) raring; urgency=low

  * New upstream release.
    - Trap DBusException on ubuntuone-login startup. (LP: #711324)
    - Remove messaging menu integration. (LP: #820345)
    - Avoid KeyError during an Upload. (LP: #988534)
    - Ignore .lock files from synchronization. (LP: #1042268)
    - Avoid duplicate state tracking for sync menu. (LP: #1053631)
    - Add a separator between recent and current transfers. (LP: #1054259)
    - Search and filtering API for shares tab in control panel. (LP: #1056197)
    - Ensure Upload/Download objects have path attribute. (LP: #1061490)
    - Use correct file size for percentages in sync menu. (LP: #1062729)
    - Open shares tab from sync menu. (LP: #1063786)
    - Open the Ubuntu One folder from sync menu. (LP: #1063788)
    - Use correct glib method to launch control panel. (LP: #1065272)
    - Always use GI bindings in launch and login scripts. (LP: #1066943)
    - Show active downloads in transfers menu as well. (LP: #1067806)
    - Avoid duplicates in transfers menu. (LP: #1069953)
    - Do case-insenstive fuzzy filename matching. (LP: #1073664)
  * debian/watch:
    - Update to use stable-4-2 series for Ubuntu 13.04 releases.
 -- Rodney Dawes <email address hidden> Tue, 11 Dec 2012 17:05:43 -0500

Changed in ubuntuone-client (Ubuntu Raring):
status: Triaged → Fix Released
Rolf Leggewie (r0lf) wrote :

quantal has seen the end of its life and is no longer receiving any updates. Marking the quantal task for this ticket as "Won't Fix".

Changed in ubuntuone-client (Ubuntu Quantal):
status: Triaged → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers