[precise] u1sdtool --info fails

Bug #917222 reported by Roman Yepishev
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Ubuntu One Client
Status tracked in Trunk
Stable-3-0
Undecided
Unassigned
Trunk
High
Diego Sarmentero
ubuntuone-client (Ubuntu)
Undecided
dobey
Precise
Undecided
dobey

Bug Description

STR:
1. $ u1sdtool --info ~/Ubuntu\ One

Expected results:
Some output about the folder

Actual result:
Oops, an error ocurred:

verterok added some debug to trunk version and found this:

guillermo@naug:~/canonical/ubuntuone-client/trunk$ PYTHONPATH=. bin/u1sdtool --info "/home/guillermo/Ubuntu One/filename.pdf"
Traceback (most recent call last):
  File "bin/u1sdtool", line 81, in main
    yield run(options, sync_daemon_tool, out)
  File "/usr/lib/python2.7/dist-packages/twisted/internet/defer.py", line 545, in _runCallbacks
    current.result = callback(current.result, *args, **kw)
  File "bin/u1sdtool", line 160, in <lambda>
    d.addCallback(lambda r: show_path_info(r, path, out))
  File "/home/guillermo/canonical/ubuntuone-client/trunk/ubuntuone/platform/tools/__init__.py", line 738, in show_path_info
    assert isinstance(path, unicode)
AssertionError

Oops, an error ocurred:

Related branches

Roman Yepishev (rye)
Changed in ubuntuone-client:
assignee: nobody → Ubuntu One Desktop+ team (ubuntuone-desktop+)
Changed in ubuntuone-client:
status: New → Triaged
importance: Undecided → Medium
assignee: Ubuntu One Desktop+ team (ubuntuone-desktop+) → Diego Sarmentero (diegosarmentero)
summary: - [precise] u1sdtool --info fails with unicode assert (empty Oops, an
- error ocurred:)
+ [precise] u1sdtool --info fails
John Lenton (chipaca)
Changed in ubuntuone-client:
importance: Medium → High
Revision history for this message
Natalia Bidart (nataliabidart) wrote :

This is still an issue, running 3.1+r1215-57~precise1.

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntuone-client (Ubuntu):
status: New → Confirmed
Roman Yepishev (rye)
description: updated
dobey (dobey)
Changed in ubuntuone-client (Ubuntu):
assignee: nobody → Rodney Dawes (dobey)
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntuone-client - 2.99.92-0ubuntu1

---------------
ubuntuone-client (2.99.92-0ubuntu1) precise; urgency=low

  * New upstream release.
    - Use set_int32 for transient hint. (LP: #961342)
    - Notify clients when volumes info form server is ready. (LP: #851810)
    - Fix an error on u1sdtool --info. (LP: #917222)
    - Exit proxy tunnel process with u1sdtool -q. (LP: #963485)
    - Unbreak and test the validate_path call. (LP: #968637)
  * debian/patches:
    - Remove patches included in upstream release.
  * debian/watch:
    - Update watch file for new release.
 -- Rodney Dawes <email address hidden> Wed, 04 Apr 2012 10:42:09 -0400

Changed in ubuntuone-client (Ubuntu Precise):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers