Files in new UDFs are not uploaded due to filtering

Bug #869920 reported by Roman Yepishev on 2011-10-07
96
This bug affects 21 people
Affects Status Importance Assigned to Milestone
Ubuntu One Client
Status tracked in Trunk
Stable-2-0
Critical
Guillermo Gonzalez
Stable-3-0
Critical
Guillermo Gonzalez
Trunk
Critical
Guillermo Gonzalez
ubuntuone-client (Ubuntu)
High
dobey
Oneiric
High
Unassigned
Precise
High
dobey

Bug Description

TEST CASE:

1. Create new folder in home directory
2. Put some files there
3. u1sdtool --create-folder=path_to_folder
4. Check on the web ui that the files started to upload

Actual results:
No files are uploaded, a restart is required for SD to pick up files

Expected results:
Files are uploaded immediately

<facundobatista> we're filtering out the events on a freshly created UDF

The log contains:
2011-10-07 14:21:00,813 - ubuntuone.SyncDaemon.sync - DEBUG - -:-:- - ['-'::'-'] ''/home/rtg/UDFTesting/gnome-settings-daemon-dev_3.2.0-0ubuntu4_amd64.deb'' | FS_FILE_CLOSE_WRITE on path '/home/rtg/UDFTesting/gnome-settings-daemon-dev_3.2.0-0ubuntu4_amd64.deb' discarded because of volume not subscribed

Observed on Oneiric (2.0.0-0ubuntu1) and Windows client 2.0.1

Related branches

Revision history for this message
Facundo Batista (facundo) wrote :

The problem is that the UDF is unsubscribed during LR, and that triggers the filter to avoid events from unsubscribed volumes in Sync.

Revision history for this message
Roman Yepishev (rye) wrote :

This breaks our story for adding the folders during installation of u1 on windows.

Changed in ubuntuone-client:
importance: Undecided → High
tags: added: chicharra u1-oneiric-sru
Changed in ubuntuone-client (Ubuntu):
importance: Undecided → High
milestone: none → oneiric-updates
Changed in ubuntuone-client:
status: New → Confirmed
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntuone-client (Ubuntu):
status: New → Confirmed
tags: added: support u1-sru
Changed in ubuntuone-client:
assignee: nobody → Ubuntu One Foundations+ team (ubuntuone-foundations+)
importance: High → Critical
Revision history for this message
Joshua Hoover (joshuahoover) wrote :

Changed to Critical for U1 even though there is a workaround (restart syncdaemon). Users get the impression that file sync is broken with this bug thus the change to Critical for U1.

description: updated
Changed in ubuntuone-client:
assignee: Ubuntu One Foundations+ team (ubuntuone-foundations+) → Guillermo Gonzalez (verterok)
status: Confirmed → In Progress
dobey (dobey) on 2011-12-21
Changed in ubuntuone-client (Ubuntu Oneiric):
milestone: none → oneiric-updates
Changed in ubuntuone-client (Ubuntu):
milestone: oneiric-updates → precise-alpha-2
dobey (dobey) on 2011-12-21
Changed in ubuntuone-client (Ubuntu Oneiric):
importance: Undecided → High
status: New → Confirmed
Changed in ubuntuone-client (Ubuntu Precise):
assignee: nobody → Rodney Dawes (dobey)
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntuone-client - 2.99.0-0ubuntu1

---------------
ubuntuone-client (2.99.0-0ubuntu1) precise; urgency=low

  * New upstream release.
    - Verify timestamp to avoid invalid auth failures (LP: #692597)
    - Files in new UDFs not uploaded due to filtering (LP: #869920)
  * debian/patches:
    - Remove upstreamed patches
 -- Rodney Dawes <email address hidden> Wed, 21 Dec 2011 15:46:25 -0500

Changed in ubuntuone-client (Ubuntu Precise):
status: Confirmed → Fix Released
tags: removed: u1-oneiric-sru
tags: added: u1-oneiric-sru
Revision history for this message
Martin Pitt (pitti) wrote : Please test proposed package

Hello Roman, or anyone else affected,

Accepted ubuntuone-client into oneiric-proposed. The package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in ubuntuone-client (Ubuntu Oneiric):
status: Confirmed → Fix Committed
tags: added: verification-needed
Revision history for this message
jhfhlkjlj (fdsuufijjejejejej-deactivatedaccount) wrote :

Works here.

tags: added: verification-done
removed: verification-needed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntuone-client - 2.0.1-0ubuntu1

---------------
ubuntuone-client (2.0.1-0ubuntu1) oneiric-proposed; urgency=low

  * New upstream release.
    - Avoid connection failure when timestamp invalid. (LP: #692597)
    - Files in new folders not uploaded due to filtering. (LP: #869920)
    - Sync daemon not running (mmap ValueError). (LP: #825366)
    - Typo in man page for "paths." (LP: #682954)
    - Apport recipe attaches old and useless logs. (LP: #956407)
  * debian/control:
    - Require the new ubuntuone-storage-protocol for #692597.
  * debian/patches:
    - Remove patches which have been included in upstream.
  * debian/watch:
    - Update to use the stable branch.
 -- Rodney Dawes <email address hidden> Wed, 18 Apr 2012 16:37:15 -0400

Changed in ubuntuone-client (Ubuntu Oneiric):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions