Filename in notification does not reset.

Bug #807005 reported by Eric Casteleijn on 2011-07-07
52
This bug affects 12 people
Affects Status Importance Assigned to Milestone
Ubuntu One Client
Status tracked in Trunk
Stable-2-0
Medium
Eric Casteleijn
Stable-3-0
Medium
Eric Casteleijn
Trunk
Medium
Eric Casteleijn
ubuntuone-client (Ubuntu)
Undecided
Unassigned
Natty
Undecided
Unassigned
Oneiric
Undecided
Unassigned
Precise
Undecided
Unassigned

Bug Description

When uploading a file Ubuntu One (sometimes) shows a filename in the notification bubbles of a file that was uploaded much earlier.

Related branches

Changed in ubuntuone-client:
importance: Undecided → Medium
assignee: nobody → Eric Casteleijn (thisfred)
status: New → Confirmed
Changed in ubuntuone-client:
assignee: Eric Casteleijn (thisfred) → Ubuntu One Desktop+ team (ubuntuone-desktop+)
Facundo Batista (facundo) wrote :

I still have the problem with the proposed branch lp:~thisfred/ubuntuone-client/reset-filenames

See attached logs, around 9:30, that a file "blog.txt" was upload, and other was notified.

Rafael P. (rafael-p) wrote :

Confirmed. I've been experiencing this bug on various ubuntu installations. at least natty and oneiric releases are affected

Roman Yepishev (rye) on 2011-12-06
tags: added: u1-sru
Changed in ubuntuone-client:
assignee: Ubuntu One Desktop+ team (ubuntuone-desktop+) → Eric Casteleijn (thisfred)
Changed in ubuntuone-client (Ubuntu):
assignee: nobody → Ken VanDine (ken-vandine)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntuone-client - 2.0.0-0ubuntu4

---------------
ubuntuone-client (2.0.0-0ubuntu4) precise; urgency=low

  * debian/patches/03_reset_notify_name.patch
    - use basename to get filenames, this ensures the filename displayed
      in notifications gets reset (LP: #807005)
 -- Ken VanDine <email address hidden> Wed, 14 Dec 2011 15:12:06 -0500

Changed in ubuntuone-client (Ubuntu Precise):
status: New → Fix Released
Changed in ubuntuone-client (Ubuntu Precise):
assignee: Ken VanDine (ken-vandine) → nobody

Hello Eric, or anyone else affected,

Accepted ubuntuone-client into oneiric-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in ubuntuone-client (Ubuntu Oneiric):
status: New → Fix Committed
tags: added: verification-needed
Roman Yepishev (rye) wrote :

Uploaded a filename1.txt and got a notification about this. Waited for 10 minutes and uploaded filename2.txt. The notification said filename2.txt.

Confirmed on: 2.0.0-0ubuntu2.3 from oneiric-proposed/main

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntuone-client (Ubuntu Natty):
status: New → Confirmed
Filippo Mazza (filippo-mazza) wrote :

Confirmend filename reset successful with 2.0.0-0ubuntu2.3 from oneiric-proposed/main.
Ubuntu one had to be restarted with u1sdtool for changes to take effect.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntuone-client - 2.0.0-0ubuntu2.3

---------------
ubuntuone-client (2.0.0-0ubuntu2.3) oneiric-proposed; urgency=low

  * debian/patches/03_reset_notify_name.patch
    - use basename to get filenames, this ensures the filename displayed
      in notifications gets reset (LP: #807005)
 -- Ken VanDine <email address hidden> Wed, 14 Dec 2011 16:03:47 -0500

Changed in ubuntuone-client (Ubuntu Oneiric):
status: Fix Committed → Fix Released
Rolf Leggewie (r0lf) wrote :

natty has seen the end of its life and is no longer receiving any updates. Marking the natty task for this ticket as "Won't Fix".

Changed in ubuntuone-client (Ubuntu Natty):
status: Confirmed → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers