music store widget dies with «TypeError: find_credentials() takes exactly 3 arguments (2 given)»

Bug #764646 reported by John Lenton on 2011-04-18
28
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Ubuntu One Client
Status tracked in Trunk
Stable-1-6
Critical
Alejandro J. Cura
Trunk
Critical
Alejandro J. Cura
ubuntuone-client (Ubuntu)
Critical
dobey
Natty
Critical
dobey

Bug Description

STR: start banshee from a terminal. You'll see

** (Banshee:3109): WARNING **: Could not get credentials for 'Ubuntu One': Traceback (most recent call last):
  File "/usr/lib/pymodules/python2.7/dbus/service.py", line 702, in _message_cb
    retval = candidate_method(self, *args, **keywords)
TypeError: find_credentials() takes exactly 3 arguments (2 given)

The store will appear to load, but the 'my downloads' page doesn't work, thus making the store unusable for users purchasing music.

Related branches

Changed in libubuntuone:
assignee: nobody → Alejandro J. Cura (alecu)
importance: Undecided → Critical
status: New → In Progress
Changed in ubuntuone-client (Ubuntu):
importance: Undecided → Critical
milestone: none → ubuntu-11.04
assignee: nobody → Rodney Dawes (dobey)
status: New → Triaged
dobey (dobey) on 2011-04-18
affects: libubuntuone → ubuntuone-client
Alejandro J. Cura (alecu) wrote :

We need to revert the changes that landed as revno 956 in ubuntuone-client trunk, because they are the cause of this problem.

Changed in ubuntuone-client:
status: In Progress → Fix Committed
Changed in ubuntuone-client (Ubuntu Natty):
status: Triaged → New
description: updated
Changed in ubuntuone-client (Ubuntu Natty):
status: New → Triaged
tags: added: u1-natty-final
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntuone-client - 1.6.1-0ubuntu2

---------------
ubuntuone-client (1.6.1-0ubuntu2) natty; urgency=low

  * 01_broken-sso-dbus-api.patch:
    - Fix the broken usage of SSO D-Bus API (LP: #764646, #759197)
  * 02_check-enabled-before-dbus.patch:
    - Check that file sync is enabled before D-Bus connection (LP: #759714)
 -- Rodney Dawes <email address hidden> Wed, 20 Apr 2011 10:16:38 -0400

Changed in ubuntuone-client (Ubuntu Natty):
status: Triaged → Fix Released

I have report this a week ago, but it was assumed to be a duplicated
 for the 764646 bug. I applied the fix, so the "music store widget
 dies with «TypeError: find_credentials() takes exactly 3 arguments (2
 given)" error is fix, no longer appears. But I still have the problem.

 Starting Banshee from a terminal:
 mariano@mariano-dell:~$ banshee
 [Info 09:06:46.600] Running Banshee 2.0.0: [Ubuntu Natty (development branch) (linux-gnu, i686) @ 2011-04-18 16:21:33 UTC]
 [Info 09:06:48.402] Updating web proxy from GConf
 [Info 09:06:48.443] All services are started 0,924566
 ** (Banshee:5557): DEBUG: SyncDaemon already running, initializing SyncdaemonDaemon object

 (Banshee:5557): libsoup-WARNING **: No feature manager for feature of
 type 'U1RequestChrome'

 ** (Banshee:5557): WARNING **: Error calling get_info: Traceback (most recent call last):
   File "/usr/lib/pymodules/python2.7/dbus/service.py", line 702, in _message_cb
     retval = candidate_method(self, *args, **keywords)
   File "/usr/lib/pymodules/python2.7/ubuntuone-client/ubuntuone/platform/linux/dbus_interface.py", line 992, in get_info
     return self.syncdaemon_folders.get_info(path)
   File "/usr/lib/pymodules/python2.7/ubuntuone-client/ubuntuone/syncdaemon/interaction_interfaces.py", line 634, in get_info
     mdobj = self.fs.get_by_path(path.encode('utf-8'))
   File "/usr/lib/pymodules/python2.7/ubuntuone-client/ubuntuone/syncdaemon/filesystem_manager.py", line 773, in get_by_path
     mdid = self._idx_path[path]
 KeyError: '/home/mariano/.ubuntuone/Purchased from Ubuntu One'

 ** (Banshee:5557): CRITICAL **: syncdaemon_folder_info_get_subscribed: assertion `SYNCDAEMON_IS_FOLDER_INFO (finfo)' failed

 ** (Banshee:5557): WARNING **: Error rescanning Purchased Music: No existe el fichero o el directorio
 ** (Banshee:5557): DEBUG: Loading the real store page
 [Info 09:06:50.896] nereid Client Started
 [Info 09:06:50.977] GStreamer version 0.10.32.0, gapless: True, replaygain: False
 [Info 09:06:51.025] AppleDeviceSource is ignoring unmounted volume OS

 One more thing, I do no have a .ubuntuone folder in my home, so I
 added it, even with the Purchased subfolder, but nothing happened.

 Regards.

dobey (dobey) wrote :

@Mariano, can you please file a new but describing what exactly your problem is, with the same pasted message?

I'm not quite understanding what exactly your problem is, but it is not *this* bug. Thanks.

Thanks Rodney, I post it here because:

Chow Loong Jin

*** This bug is a duplicate of bug 764646 ***
   https://bugs.launchpad.net/bugs/764646

The stack trace is identical to the bug #764646. If you're still seeing the
issue, it means either that you did not apply the fix properly, or that the fix
is inadequate/incomplete. Please post a follow up comment on the original bug
with Banshee's output.

 duplicate 764646

--
Kind regards,
Loong Jin
** This bug has been marked a duplicate of bug 764646
  music store widget dies with «TypeError: find_credentials() takes exactly 3 arguments (2 given)»

I originally report it as Bug #768948 .

Thanks again.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers