SyncDaemon is respawned consuming the CPU if it is disabled and application uses NameOwnerChanged

Bug #759714 reported by Roman Yepishev on 2011-04-13
40
This bug affects 7 people
Affects Status Importance Assigned to Milestone
Ubuntu One Client
Status tracked in Trunk
Stable-1-6
High
Roman Yepishev
Trunk
High
Roman Yepishev
ubuntuone-client (Ubuntu)
High
Ubuntu One Client Engineering team
Natty
High
Ubuntu One Client Engineering team
Oneiric
High
Ubuntu One Client Engineering team

Bug Description

ubuntuone-client:
  Installed: 1.6.0-0ubuntu1

STR:
1. Start ubuntuone-control-panel-gtk, select services, disable File sync.
2. Verify that no syncdaemon is running
3. Run u1sdtool --status in the terminal (or any other SD DBus method)

Actual results:
Syncdaemon starts respawning consuming up to 50% CPU (on my machine)

Expected results:
Syncdaemon should not be consuming the CPU if it is disabled.

Related branches

Roman Yepishev (rye) wrote :

Now STR does not work but I was getting pretty much the same output the user @ https://bugs.launchpad.net/ubuntu/+source/ubuntuone-client/+bug/407762/comments/22 had.

Changed in ubuntuone-client:
assignee: nobody → Roman Yepishev (rye)
Roman Yepishev (rye) wrote :

STR:

1. Disable Ubuntu One File Sync service
2. Log out, log in to your session
3. Start rhythmbox with Ubuntu One music store plugin enabled.

Actual results:
ubuntuone-nautilus notices syncdaemon has acquired DBus name and starts poking it with the requests

Expeccted results:
ubuntuone-syncdaemon shuts down before acquiring the DBus name.

Changed in ubuntuone-client:
assignee: Roman Yepishev (rye) → Ubuntu One Foundations+ team (ubuntuone-foundations+)
status: New → Confirmed
importance: Undecided → High
summary: - SyncDaemon respawns and dies at a high rate using a lot of CPU if file
- sync is disabled and sd dbus method was called
+ SyncDaemon is respawned consuming the CPU if it is disabled and
+ application checks NameOwnerChanged
summary: SyncDaemon is respawned consuming the CPU if it is disabled and
- application checks NameOwnerChanged
+ application uses NameOwnerChanged
Changed in ubuntuone-client:
status: Confirmed → In Progress
assignee: Ubuntu One Foundations+ team (ubuntuone-foundations+) → Roman Yepishev (rye)
Changed in ubuntuone-client (Ubuntu):
status: New → Triaged
importance: Undecided → High
assignee: nobody → Ubuntu One Desktop+ team (ubuntuone-desktop+)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntuone-client - 1.6.1-0ubuntu2

---------------
ubuntuone-client (1.6.1-0ubuntu2) natty; urgency=low

  * 01_broken-sso-dbus-api.patch:
    - Fix the broken usage of SSO D-Bus API (LP: #764646, #759197)
  * 02_check-enabled-before-dbus.patch:
    - Check that file sync is enabled before D-Bus connection (LP: #759714)
 -- Rodney Dawes <email address hidden> Wed, 20 Apr 2011 10:16:38 -0400

Changed in ubuntuone-client (Ubuntu Natty):
status: Triaged → Fix Released
anabelli (anabelli) wrote :

I had
Version: 1.6.2-0ubuntu1
and still I had to REMOVE ubuntuone-client because
1. ubuntuone-syncd was eating 117% of cpu power
2. if I unchecked its entry in the startup application lists at next start it'll be checked again

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers