[natty] Ubuntu One Folder bookmark is not created

Bug #759197 reported by Roman Yepishev on 2011-04-12
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu One Client
Status tracked in Trunk
Stable-1-6
High
Alejandro J. Cura
Trunk
High
Alejandro J. Cura
ubuntuone-client (Ubuntu)
High
dobey
Natty
High
dobey

Bug Description

ubuntuone-client:
  Installed: 1.6.0-0ubuntu1

At the moment the gtk bookmark for Ubuntu One folder is not created.

Adding debug statements show that the credentials_found signal that fires all the machinery is never called.

The last function to run is delayed_syncdaemon_start

Related branches

Roman Yepishev (rye) on 2011-04-12
Changed in ubuntuone-client:
assignee: nobody → Alejandro J. Cura (alecu)
Alejandro J. Cura (alecu) wrote :

Found the problem: Syncdaemon was changed to use the new com.ubuntu.sso.CredentialsManagement DBus interface, but the gnome-settings-daemon plugin still uses the deprecated com.ubuntu.sso.ApplicationCredentials interface.

So, when Syncdaemon requests the credentials using find_credentials in the first interface, the CredentialsFound signal is only thrown from that same interface, and not from the deprecated one (and viceversa).

And this is why the gsd-plugin does not catch that signal and stores the bookmark.

I'm working on a gsd-plugin branch to fix this.

Changed in ubuntuone-client:
status: New → Fix Committed
Changed in ubuntuone-client:
importance: Undecided → High
Changed in ubuntuone-client (Ubuntu):
importance: Undecided → High
dobey (dobey) on 2011-04-15
Changed in ubuntuone-client:
milestone: none → 1.6.1
Changed in ubuntuone-client (Ubuntu):
milestone: none → ubuntu-11.04
status: New → In Progress
assignee: nobody → Rodney Dawes (dobey)
Changed in ubuntuone-client:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntuone-client - 1.6.1-0ubuntu1

---------------
ubuntuone-client (1.6.1-0ubuntu1) natty; urgency=low

  * New upstream release.
    - ZipQueue does not trigger deferred when cancelled (LP: #757864)
    - AssertionError in aggregator (LP: #759084)
    - Ubuntu One folder bookmark not created (LP: #759197)
 -- Rodney Dawes <email address hidden> Fri, 15 Apr 2011 17:11:55 -0400

Changed in ubuntuone-client (Ubuntu Natty):
status: In Progress → Fix Released
Alejandro J. Cura (alecu) wrote :

We are reverting the initial branch to fix this bug, because it causes a lot more problems (as described in bug #764646).

I'll be pushing another branch with a less intrusive change to fix this one.

Changed in ubuntuone-client:
status: Fix Released → Confirmed
Changed in ubuntuone-client (Ubuntu Natty):
status: Fix Released → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntuone-client - 1.6.1-0ubuntu2

---------------
ubuntuone-client (1.6.1-0ubuntu2) natty; urgency=low

  * 01_broken-sso-dbus-api.patch:
    - Fix the broken usage of SSO D-Bus API (LP: #764646, #759197)
  * 02_check-enabled-before-dbus.patch:
    - Check that file sync is enabled before D-Bus connection (LP: #759714)
 -- Rodney Dawes <email address hidden> Wed, 20 Apr 2011 10:16:38 -0400

Changed in ubuntuone-client (Ubuntu Natty):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers