SD creates new notifications instead of updating one

Bug #723227 reported by Roman Yepishev on 2011-02-22
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu One Client
High
Eric Casteleijn
ubuntuone-client (Ubuntu)
Medium
Eric Casteleijn
Natty
Medium
Eric Casteleijn

Bug Description

<rye> alecu, do we do .update() on pynotify messages or just show() or something like that?
<alecu> rye, we only update the message when new files are found while showing the new files notification.
<rye> alecu, i think you should use notification.update(); notification.show() all the time... in this case there may be possibility of showing some info for too small amount of time but on other hand making a backlog of notifications is not that great
<dobey> alecu: yeah what rye said, you have to update, then .show
<dobey> you never just do .update
<dobey> if you're just doing .update somewhere without a .show after, it's a bug

The notification code uses creates new notification for various conditions and sometimes updates old one. Sometimes it can create a backlog of notifications (since notifiy-osd is showing one at a time). Notification code should create one notification and then update() that and show().

Related branches

Roman Yepishev (rye) on 2011-02-22
Changed in ubuntuone-client:
status: New → Confirmed
importance: Undecided → Medium
assignee: nobody → Eric Casteleijn (thisfred)
tags: added: desktop+ notifications
tags: added: u1-unity
Changed in ubuntuone-client:
importance: Medium → High
status: Confirmed → In Progress
tags: added: u1-natty
Changed in ubuntuone-client (Ubuntu):
status: New → In Progress
importance: Undecided → Medium
assignee: nobody → Eric Casteleijn (thisfred)
milestone: none → ubuntu-11.04-beta-1
Changed in ubuntuone-client:
status: In Progress → Fix Committed
tags: added: u1-natty-beta
dobey (dobey) on 2011-03-10
Changed in ubuntuone-client:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntuone-client - 1.5.6-0ubuntu1

---------------
ubuntuone-client (1.5.6-0ubuntu1) natty; urgency=low

  * New upstream release.
    - Remove already upstreamed patch
    - Release pathlock when command cancelled (LP: #729158)
    - syncdaemon continuously hashing (LP: #580855)
    - Self conflict when saving the same file a lot (LP: #718924)
    - SYS_QUOTA_EXCEEDED not being sent (LP: #720797)
    - The check_condition call may be too heavy (LP: #720844)
    - AQ_DOWNLOAD_CANCELLED is no more (LP: #721479)
    - SD should update a single notification (LP: #723227)
    - Two entries in Messaging menu (LP: #721525)
    - Singular form incorrect for notification (LP: #723327)
    - File names should be shown on notifications (LP: #729055)
  * Moved icon files to ubuntuone-client package (LP: #727195)
 -- Rodney Dawes <email address hidden> Wed, 09 Mar 2011 21:11:44 -0500

Changed in ubuntuone-client (Ubuntu Natty):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers