[UIFE] Syncdaemon needs to open the control-panel to volumes when a folder shared to the user exceeds the owning user's quota

Bug #702176 reported by Eric Casteleijn on 2011-01-12
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu One Client
Medium
Eric Casteleijn
Ubuntu One Control Panel
Medium
Natalia Bidart
ubuntuone-client (Ubuntu)
Medium
Eric Casteleijn
Natty
Medium
Eric Casteleijn
ubuntuone-control-panel (Ubuntu)
Medium
Natalia Bidart
Natty
Medium
Natalia Bidart

Bug Description

When a folder shared to the user exceeds the quota of the user that owns that folder, syncdaemon needs to open the control panel to the volumes tab, and attempt to raise the window (which will make the launcher in unity bounce)

Related branches

Changed in ubuntuone-client:
status: New → Triaged
Changed in ubuntuone-client (Ubuntu):
status: New → Triaged
importance: Undecided → Medium
Changed in ubuntuone-client:
importance: Undecided → Medium
assignee: nobody → Eric Casteleijn (thisfred)
tags: added: u1-unity
Changed in ubuntuone-client (Ubuntu):
assignee: nobody → Eric Casteleijn (thisfred)
Changed in ubuntuone-client:
status: Triaged → Fix Committed
Changed in ubuntuone-client (Ubuntu):
status: Triaged → In Progress
Changed in ubuntuone-client:
status: Fix Committed → In Progress

Changed this from using messaging, to a direct popunder of the control panel.

summary: - Syncdaemon needs to add an entry to the messaging menu when a folder
+ Syncdaemon needs to open the control-panel to volumes when a folder
shared to the user exceeds the owning user's quota
description: updated
tags: added: u1-natty
Changed in ubuntuone-client (Ubuntu):
milestone: none → ubuntu-11.04-beta-1
tags: added: u1-natty-beta
Eric Casteleijn (thisfred) wrote :

This is waiting on ubuntuone-control panel's new dbus service to provide the needed API.

Eric Casteleijn (thisfred) wrote :

depends on #742008 being fixed

Eric Casteleijn (thisfred) wrote :

depends on bug #742008 being fixed, that is

Joshua Hoover (joshuahoover) wrote :

Marking as invalid for Natty since it's a new feature and too late.

Changed in ubuntuone-client (Ubuntu Natty):
milestone: ubuntu-11.04-beta-1 → none
status: In Progress → Invalid
tags: added: u1-oneiric
removed: u1-natty u1-natty-beta
Eric Casteleijn (thisfred) wrote :

Waiting on bug #747677

Changed in ubuntuone-control-panel:
status: New → Triaged
importance: Undecided → Medium
assignee: nobody → Naty Bidart (nataliabidart)
Changed in ubuntuone-client:
status: In Progress → Fix Committed
Changed in ubuntuone-client:
status: Fix Committed → In Progress
Changed in ubuntuone-client:
status: In Progress → Fix Committed
Changed in ubuntuone-control-panel:
status: Triaged → In Progress
Natalia Bidart (nataliabidart) wrote :

Requesting UI freeze exception to be able to show in red the free space available for a share (when the free space is very low).
Please note that the free space is already being shown, so the only change is that it will be red when is less than 100K.

summary: - Syncdaemon needs to open the control-panel to volumes when a folder
- shared to the user exceeds the owning user's quota
+ [UIFE] Syncdaemon needs to open the control-panel to volumes when a
+ folder shared to the user exceeds the owning user's quota
Changed in ubuntuone-control-panel (Ubuntu Natty):
status: New → Triaged
assignee: nobody → Naty Bidart (nataliabidart)
importance: Undecided → Medium
milestone: none → ubuntu-11.04-beta-2
Natalia Bidart (nataliabidart) wrote :

Screenshot of UI change is located at http://ubuntuone.com/p/fMq/

Changed in ubuntuone-control-panel (Ubuntu Natty):
status: Triaged → New
Changed in ubuntuone-control-panel:
status: In Progress → Fix Committed
Martin Pitt (pitti) wrote :

Is the control-panel (Ubuntu) part here _only_ about showing the free space in red on low quota? ACK for that part. But that doesn't match the title (any more?)

Changed in ubuntuone-control-panel (Ubuntu Natty):
status: New → Confirmed
dobey (dobey) on 2011-04-11
Changed in ubuntuone-client:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntuone-client - 1.6.0-0ubuntu1

---------------
ubuntuone-client (1.6.0-0ubuntu1) natty; urgency=low

  * New upstream release.
    - Avoid conflict when same file already exists locally (LP: #711389)
    - Must move fils to trash on deletion (LP: #690673)
    - Support disconnection during initial connect attempt (LP: #711211)
    - Log version number on startup (LP: #715455)
    - Memory usage too high (LP: #721483)
    - Unsubscribed folders show as synced, if they exist (LP: #741835)
    - gnome-settings-daemon crash in g_str_hash (LP: #744383)
    - Should not re-queue uploads directly (LP: #744608)
    - No feedback when creating folder from symlink fails (LP: #747299)
    - [FFE] Use API to set urgency from background process (LP: #747677)
    - Open control panel to volumes when quota exceeded (LP: #702176)
    - Set the launcher to urgent when quota exceeded (LP: #702183)
    - nautilus crash in g_str_hash (LP: #724882)
    - Disable/enable file sync is buggy (LP: #744980)

  [Chris Coulson]
  * gnome-settings-daemon crash in g_return_fail_if_warning (LP: #744980)
 -- Rodney Dawes <email address hidden> Sun, 10 Apr 2011 21:24:30 -0400

Changed in ubuntuone-client (Ubuntu Natty):
status: Invalid → Fix Released
Natalia Bidart (nataliabidart) wrote :

Hi Martin,

yes, the part that requires the UI freeze exception is showing the used quota in red.

Thanks!

Changed in ubuntuone-control-panel (Ubuntu Natty):
status: Confirmed → Triaged
milestone: ubuntu-11.04-beta-2 → ubuntu-11.04
Changed in ubuntuone-control-panel:
status: Fix Committed → Fix Released
Changed in ubuntuone-control-panel (Ubuntu Natty):
status: Triaged → In Progress
Changed in ubuntuone-control-panel (Ubuntu Natty):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers