ZeitgeistListener tracebacks on AQ_UNLINK_OK

Bug #693545 reported by Facundo Batista on 2010-12-22
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Ubuntu One Client
High
Alejandro J. Cura

Bug Description

For example:

2010-12-22 10:33:55,752 - ubuntuone.SyncDaemon.EQ - ERROR - Error encountered while handling: AQ_UNLINK_OK in <ubuntuone.syncdaemon.event_logging.ZeitgeistListener object at 0x9b02dac>
Traceback (most recent call last):
  File "/usr/lib/pymodules/python2.6/ubuntuone/syncdaemon/event_queue.py", line 298, in _dispatch
    method(*args, **kwargs)
  File "/usr/lib/pymodules/python2.6/ubuntuone/syncdaemon/event_logging.py", line 403, in handle_AQ_UNLINK_OK
    mdo = self.fsm.get_by_node_id(share_id, node_id)
  File "/usr/lib/pymodules/python2.6/ubuntuone/syncdaemon/filesystem_manager.py", line 625, in get_by_node_id
    mdid = self._idx_node_id[(share_id, node_id)]
  File "/usr/lib/pymodules/python2.6/ubuntuone/syncdaemon/filesystem_manager.py", line 175, in __getitem__
    return dict.__getitem__(self, key)
KeyError: ('', '4ead892e-4443-4cb8-b941-d08ff74469e7')

The problem is in zg_listener.py, in handle_AQ_UNLINK_OK: it tries to:

            mdo = self.fsm.get_by_node_id(share_id, node_id)

and it can not get the node, it was deleted!

Related branches

tags: added: u1-ziggy
summary: - Event Listener tries to access a non-existant node
+ ZeitgeistListener tracebacks on AQ_UNLINK_OK
Changed in ubuntuone-client:
status: Confirmed → In Progress
Changed in ubuntuone-client:
status: In Progress → Fix Committed
dobey (dobey) on 2011-03-18
Changed in ubuntuone-client:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers