UploadFileProgress and DownloadFileProgress signals are not sent

Bug #675065 reported by Roman Yepishev on 2010-11-14
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu One Client
Status tracked in Trunk
Stable-4-0
Undecided
Unassigned
Trunk
Medium
Unassigned
Ubuntu One Indicator
New
Undecided
Unassigned
ubuntuone-client (Ubuntu)
Undecided
Unassigned
Quantal
Undecided
Unassigned

Bug Description

STR:

1. Set up dbus-monitor --session member=DownloadFileProgress
2. Upload a file larger than 64K to the web interface, but less than 63 MiB
3. Wait for it to sync to local storage
4. Check the monitor

Expected results:
Information about file download progress

Actual results:
Nothing

The same goes for UploadFileProgress.

Reason #1:
# progress threshold to emit a download/upload progress event: 64Kb
TRANSFER_PROGRESS_THRESHOLD = 64*1024*1024

This sets TRANSFER_PROGRESS_THRESHOLD to 64 MiB, which is a pretty high value for this purpose. It should get set to 64*1024.

Reason #2:
When #1 is fixed the following check is made in action_queue.py:
if n_bytes_read(4874086) - n_bytes_read_last(4873786) < TRANSFER_PROGRESS_THRESHOLD(65536)
  return
That checks previous reading for file handle and the difference most likely will never get more than threshold. The progress between two notification points should be tracked instead of two adjacent points.

More investigation is required for DownloadFileProgress since it turns out that music store plugin uses the old 1-second polling method to show file progress downloads.

Related branches

Roman Yepishev (rye) on 2010-11-14
Changed in ubuntuone-client:
status: New → Confirmed
importance: Undecided → Medium
assignee: nobody → Ubuntu One Foundations+ team (ubuntuone-foundations+)
Roman Yepishev (rye) on 2010-11-14
description: updated
Facundo Batista (facundo) wrote :

Fixed reason 1, the reason 2 was fixed already.

Changed in ubuntuone-client:
status: Confirmed → Fix Committed
dobey (dobey) on 2012-09-20
Changed in ubuntuone-client (Ubuntu Quantal):
status: New → Triaged
milestone: none → ubuntu-12.10-beta-2
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntuone-client - 3.99.92-0ubuntu1

---------------
ubuntuone-client (3.99.92-0ubuntu1) quantal; urgency=low

  * New upstream release.
    - Include a 256x256 size version of our app icon. (LP: #537075)
    - Merge in updated translations from Ubuntu to upstream source.
    - Fix sending of Upload and Download FileProgress signals. (LP: #675065)
    - Remove building of vapi file from gir.
  * debian/libsyncdaemon-1.0-dev:
    - Remove vapi related files.
 -- Rodney Dawes <email address hidden> Wed, 19 Sep 2012 22:39:40 -0400

Changed in ubuntuone-client (Ubuntu Quantal):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers