Volume and file system manager metadata out of sync

Reported by Roman Yepishev on 2010-09-07
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu One Client
High
Guillermo Gonzalez
ubuntuone-client (Ubuntu)
Medium
Unassigned

Bug Description

My netbook did not want to download the files from /home/rtg/Documents UDF:

rtg@buka:~/ubuntuone-client/contrib$ u1sdtool --list-folders
Folder list:
  id=a19bb966-a0e9-4f05-a927-f9fc81986258 subscribed=True path=/home/rtg/.ubuntuone/Purchased from Ubuntu One
  id=20b0b044-523f-462a-8938-7e2fa16030b0 subscribed=True path=/home/rtg/Public
  id=5577d808-6a3f-4873-8b27-1fd644bd7e20 subscribed=True path=/home/rtg/Documents

rtg@buka:~/ubuntuone-client/contrib$ u1sdtool --info /home/rtg/Documents/

Oops, an error ocurred:
Traceback (most recent call last):
Failure: dbus.exceptions.DBusException: org.freedesktop.DBus.Python.KeyError: Traceback (most recent call last):
  File "/usr/lib/pymodules/python2.6/dbus/service.py", line 702, in _message_cb
    retval = candidate_method(self, *args, **keywords)
  File "/usr/lib/pymodules/python2.6/ubuntuone/syncdaemon/dbus_interface.py", line 968, in get_metadata
    mdobj = self.fs_manager.get_by_path(path.encode('utf-8'))
  File "/usr/lib/pymodules/python2.6/ubuntuone/syncdaemon/filesystem_manager.py", line 587, in get_by_path
    mdid = self._idx_path[path]
KeyError: '/home/rtg/Documents'

When I tried unsubscribing/subscribing, the subscription failed with
rtg@buka:~/ubuntuone-client/contrib$ u1sdtool --subscribe=5577d808-6a3f-4873-8b27-1fd644bd7e20
FolderSubscribeError: METADATA_DOES_NOT_EXIST (id=5577d808-6a3f-4873-8b27-1fd644bd7e20)

Full discussion: http://irclogs.ubuntu.com/2010/09/07/%23ubuntuone.html#t15:24
<rye> verterok, thanks! Should I file bug about that? Unfortunately I have no idea about how that could have happened, though
<verterok> rye: my guess is corrupted/broken FSM metadata, but it's just a guess
 rye: yes, we should have a bug
 rye: the title might be something like: volume and filesystem manager metadata out of sync(?)
<verterok> facundobatista: ^ any ideas :)
* dendro-afk is now known as dendrobates
<facundobatista> verterok, yes, a bug, and the fix for it will be VM assuring it has the node in FSM
<verterok> facundobatista: yes, VM assumes the node is there since it was created when the UDF was created, I'll take a look at where we can check for the fsm node

WORKAROUND:
1) Shut down ubuntuone-syncdaemon
2) Delete an UDF node metadata in ~/.local/share/ubuntuone/syncdaemon/vm/udfs/ (in my case - 5/5/5577... file)
3) Start syncdaemon again

Related branches

lp:~verterok/ubuntuone-client/fix-632454
Merged into lp:ubuntuone-client at revision 697
John O'Brien (community): Approve on 2010-09-14
Facundo Batista: Approve on 2010-09-13
Changed in ubuntuone-client:
status: Confirmed → In Progress
assignee: Ubuntu One Foundations+ team (ubuntuone-foundations+) → Guillermo Gonzalez (verterok)
Changed in ubuntuone-client (Ubuntu):
status: New → Confirmed
importance: Undecided → Medium
assignee: nobody → Ubuntu One Ops+ team (ubuntuone-ops+)
tags: added: chicharra-maverick
Changed in ubuntuone-client:
importance: Medium → High
Rodney Dawes (dobey) on 2010-09-14
Changed in ubuntuone-client:
status: In Progress → Fix Committed
Colin Watson (cjwatson) wrote :

ubuntuone-client (1.4.1-0ubuntu1) maverick; urgency=low

  * New upstream release:
    - Fix VolumeManager.subscribe_udf method to handle the error cases properly
      (Guillermo Gonzalez) (LP: #632439)
    - Make ubuntuone-launch work with the new sso (John Lenton) (LP: #631822)
    - Wait for READY before asking for connection (John Lenton) (LP: #525743
      and LP: #518027)
    - Move operations live in limbo until confirmed (Facundo Batista)
    - Fix a few problems with emblems (Rodrigo Moya) (LP: #607247)
    - Load UDFs as soon as syncdaemon is ready (Rodrigo Moya) (LP: #612541)
    - Load public files as soon as syncdaemon is ready (Rodrigo Moya)
      (LP: #627339)
    - When VM receives an event on a volume it doesn't have, refresh them
      (Facundo Batista)
    - Made u1sync client work from the command line. No more "authorize" option,
      only --oauth (Natalia Bidart) (LP: #634337)
    - Marker chains are errbacked ok now (Facundo Batista)
    - Remove multiple returns in VolumeManager.subscribe_udf method (Guillermo
      Gonzalez)
    - Do calls to libproxy in a separate process (John Lenton) (LP: #633241)
    - OAuth consumer key and secret can be passed as parameter (Natalia Bidart)
      (LP: #637022)
    - Don't generate a new file if we're deleting or overwriting it
      (Facundo Batista)
    - Make sure that the u1 music path is present (Manuel de la Peña)
      (LP: #558762)
    - Make the "Current plan" label show the actual value returned from the
      server (John Lenton) (LP: #551138)
    - Add --with-sso option to configure, for building with uninstalled
      sso-client (Rodney Dawes)
    - Fix volume manager to create the fsm node on server rescan if the node
      isn't there (Guillermo Gonzalez) (LP: #632454)
    - Fix Local rescan to process read only shares and resume interrupted
      downloads (Guillermo Gonzalez) (LP: #598189)
    - Make sure we load list of shared folders in Nautilus plugin (Rodrigo Moya)
      (LP: #633013)
    - Dereference the possible markers in limbos (Facundo Batista)
    - Don't start syncdaemon from Nautilus plugin. Just wait for it to be
      available (Rodrigo Moya) (LP: #613219, LP: #635629 and LP: #628877)

 -- Rodrigo Moya <email address hidden> Wed, 15 Sep 2010 22:17:37 +0200

Changed in ubuntuone-client (Ubuntu):
status: Confirmed → Fix Released
Changed in ubuntuone-client:
status: Fix Committed → Fix Released
Curtis Hovey (sinzui) on 2014-01-21
Changed in ubuntuone-client (Ubuntu):
assignee: Registry Administrators (registry) → nobody
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers