Activity log for bug #627195

Date Who What changed Old value New value Message
2010-08-31 02:32:42 Omer Akram bug added bug
2010-08-31 02:32:42 Omer Akram attachment added out.ogv https://bugs.launchpad.net/bugs/627195/+attachment/1531083/+files/out.ogv
2010-08-31 02:32:42 Omer Akram attachment added Dependencies.txt https://bugs.launchpad.net/bugs/627195/+attachment/1531084/+files/Dependencies.txt
2010-08-31 02:32:42 Omer Akram attachment added indicator-applet-appmenu.log.txt https://bugs.launchpad.net/bugs/627195/+attachment/1531085/+files/indicator-applet-appmenu.log.txt
2010-08-31 02:32:42 Omer Akram attachment added indicator-applet-complete.log.txt https://bugs.launchpad.net/bugs/627195/+attachment/1531086/+files/indicator-applet-complete.log.txt
2010-08-31 02:32:42 Omer Akram attachment added indicator-applet-session.log.txt https://bugs.launchpad.net/bugs/627195/+attachment/1531087/+files/indicator-applet-session.log.txt
2010-08-31 02:32:42 Omer Akram attachment added indicator-applet.log.txt https://bugs.launchpad.net/bugs/627195/+attachment/1531088/+files/indicator-applet.log.txt
2010-08-31 02:33:13 Omer Akram bug task added ayatana-ubuntu
2010-08-31 03:39:24 Omer Akram attachment added out-2.ogv https://bugs.launchpad.net/bugs/627195/+attachment/1531125/+files/out-2.ogv
2010-09-20 07:15:19 Omer Akram summary applications that can come up quickly from the messaging menu or indicator applications can sometime not come up focused many apps are unfocused when they are raised from MessagingMenu or SoundMenu
2010-10-06 15:57:56 Sebastien Bacher affects indicator-applet libindicate
2011-01-31 22:04:29 Alex Launi libindicate: status New Confirmed
2011-07-04 14:34:11 Triqui bug added subscriber Triqui
2011-08-07 17:03:21 LittleHorror bug added subscriber LittleHorror
2011-08-23 00:50:36 Bartosz Brachaczek bug added subscriber Bartosz Brachaczek
2011-09-19 19:25:42 Omer Akram affects ayatana-ubuntu unity
2011-09-19 19:25:56 Omer Akram bug task added compiz (Ubuntu)
2011-09-19 19:26:29 Launchpad Janitor compiz (Ubuntu): status New Confirmed
2011-09-19 19:30:00 Omer Akram compiz (Ubuntu): importance Undecided High
2011-09-19 19:30:01 Omer Akram unity: importance Undecided High
2011-09-19 19:30:03 Omer Akram libindicate: importance Undecided High
2011-09-19 19:30:06 Omer Akram unity: status New Confirmed
2011-09-19 19:33:58 Omer Akram attachment removed out-2.ogv https://bugs.launchpad.net/ubuntu/+source/compiz/+bug/627195/+attachment/1531125/+files/out-2.ogv
2011-09-19 19:34:15 Omer Akram attachment removed out.ogv https://bugs.launchpad.net/ubuntu/+source/compiz/+bug/627195/+attachment/1531083/+files/out.ogv
2011-09-19 20:10:25 Omer Akram description its an annoying bug. It is triggered sometimes for rhythmbox, I can reproduce it with Liferea. it seems there comes a race condition for indicator applet which causes the app to not focus. see the video. there is already a bug related to rhythmbox and quite possibly other apps too but the actual problem is in indicator applet I think. This bug is 100% reproduce able for me. ProblemType: Bug DistroRelease: Ubuntu 10.04 Package: indicator-applet 0.4.3-0lucid1 ProcVersionSignature: Ubuntu 2.6.32-24.42-generic 2.6.32.15+drm33.5 Uname: Linux 2.6.32-24-generic x86_64 NonfreeKernelModules: nvidia Architecture: amd64 CrashDB: indicator_applet Date: Tue Aug 31 07:24:23 2010 InstallationMedia: Ubuntu 10.04.1 LTS "Lucid Lynx" - Release amd64 (20100816.1) ProcEnviron: LANG=en_US.utf8 SHELL=/bin/bash SourcePackage: indicator-applet ThirdParty: True Ubuntu 11.10 beta compiz 1:0.9.5.94+bzr2803-0ubuntu5 unity 4.16.0-0ubuntu1 1. open banshee, start a song in it and minimize 2. open another application lets say gnome-terminal 3. click on the sound menu and select banshee What happens banshee icon in the launcher wiggles and banshee main window is not shown What should happen banshee main window should come to focus This is a long standing bug which Ted Gould thinks should be fixed at window manager's level. ====Some other observations===== The problem wont happen 1. if every other app is minimized or 2. Banshee is the only opened app or 3. after opening gnome-terminal, banshee window is closed so that it hides to the SoundMenu and opened again
2011-09-19 20:10:38 Omer Akram affects libindicate ayatana-design
2011-09-19 20:11:57 Omer Akram description Ubuntu 11.10 beta compiz 1:0.9.5.94+bzr2803-0ubuntu5 unity 4.16.0-0ubuntu1 1. open banshee, start a song in it and minimize 2. open another application lets say gnome-terminal 3. click on the sound menu and select banshee What happens banshee icon in the launcher wiggles and banshee main window is not shown What should happen banshee main window should come to focus This is a long standing bug which Ted Gould thinks should be fixed at window manager's level. ====Some other observations===== The problem wont happen 1. if every other app is minimized or 2. Banshee is the only opened app or 3. after opening gnome-terminal, banshee window is closed so that it hides to the SoundMenu and opened again Ubuntu 11.10 beta compiz 1:0.9.5.94+bzr2803-0ubuntu5 unity 4.16.0-0ubuntu1 1. open banshee, start a song in it and minimize 2. open another application lets say gnome-terminal 3. click on the sound menu and select banshee What happens banshee icon in the launcher wiggles and banshee main window is not shown What should happen banshee main window should come to focus This is a long standing bug which Ted Gould thinks should be fixed at window manager's level. ====Some other observations===== The problem wont happen 1. if every other app is minimized or 2. Banshee is the only opened app or 3. after opening gnome-terminal, banshee window is closed so that it hides to the SoundMenu and opened again =====Comment from Ted Gould===== <om26er> tedg, Hi! any thoughts on the long standing bug 627195 ? Its been there before unity so I guess we can conclude unity not to be responsible <tedg> om26er, My thought is that window managers should $%#$ get fixed... though I haven't convinced smspillaz of it yet.
2011-09-19 20:13:57 Omer Akram summary many apps are unfocused when they are raised from MessagingMenu or SoundMenu Apps raised from indicators sometimes dont have the focus
2011-09-20 16:45:34 Sam Spilsbury bug task added compiz-core
2011-09-20 16:46:38 Sam Spilsbury compiz-core: status New Confirmed
2011-09-20 16:46:41 Sam Spilsbury compiz-core: importance Undecided High
2011-09-20 16:46:45 Sam Spilsbury compiz-core: milestone 0.9.5.96
2011-09-20 17:56:43 Pierce Gerhart bug added subscriber Pierce Gerhart
2011-09-22 16:25:49 John Lea ayatana-design: assignee John Lea (johnlea)
2011-09-22 16:25:52 John Lea ayatana-design: status Confirmed Fix Committed
2011-09-22 16:26:08 John Lea tags amd64 apport-bug lucid ubuntu-unity amd64 apport-bug lucid onew ubuntu-unity udo
2011-09-28 16:15:11 John Lea ayatana-design: status Fix Committed Fix Released
2011-10-18 14:47:38 John Lea unity: milestone backlog
2011-10-18 14:47:47 John Lea tags amd64 apport-bug lucid onew ubuntu-unity udo amd64 apport-bug lucid onew ubuntu-unity udo udp
2011-10-18 14:47:59 John Lea ayatana-design: status Fix Released Fix Committed
2011-10-19 15:43:49 John Lea ayatana-design: status Fix Committed Triaged
2011-11-03 15:51:31 John Lea unity: assignee Ted Gould (ted)
2011-11-03 15:51:36 John Lea ayatana-design: status Triaged Fix Committed
2011-11-18 04:55:39 Ben Gamari bug added subscriber Ben Gamari
2011-11-18 04:55:41 Launchpad Janitor unity (Ubuntu): status New Confirmed
2011-11-18 08:25:23 Omer Akram unity (Ubuntu): importance Undecided High
2011-11-21 23:29:27 Yann Dìnendal bug added subscriber Yann Dìnendal
2011-12-16 18:38:00 void bug added subscriber void
2011-12-18 16:34:19 Laryllan bug task added hundredpapercuts
2011-12-19 20:43:53 Chris Wilson bug task deleted hundredpapercuts
2011-12-26 14:03:49 Nikolaus Waxweiler bug added subscriber Nikolaus Waxweiler
2012-01-30 08:02:03 Daniel van Vugt compiz-core: milestone 0.9.5.96
2012-02-05 01:36:45 Jonathan Meek bug added subscriber Jonathan Meek
2012-02-13 13:06:04 Omer Akram compiz-core: status Confirmed Triaged
2012-02-13 13:06:11 Omer Akram unity: status Confirmed Triaged
2012-02-13 13:06:14 Omer Akram compiz (Ubuntu): status Confirmed Triaged
2012-02-13 13:06:16 Omer Akram unity (Ubuntu): status Confirmed Triaged
2012-02-16 15:37:26 John Lea summary Apps raised from indicators sometimes dont have the focus Window management - Apps raised from indicators sometimes dont have the focus
2012-02-20 16:27:32 John Lea ayatana-design: importance High Critical
2012-02-20 16:44:19 Dave Jones bug added subscriber Dave Jones
2012-03-27 12:46:49 DarkRedman bug added subscriber DarkRedman
2012-04-06 12:22:24 TomasHnyk bug added subscriber TomasHnyk
2012-04-19 14:31:40 Simon Butcher bug added subscriber Simon Butcher
2012-05-08 06:22:49 jhfhlkjlj bug added subscriber Chauncellor
2012-05-18 08:16:12 Sam Spilsbury compiz: importance Undecided High
2012-05-18 08:16:12 Sam Spilsbury compiz: status New Triaged
2012-05-30 06:33:36 Sean DS bug added subscriber Sean DS
2012-06-10 19:06:06 Valentin Crone bug added subscriber Valentin Crone
2012-07-04 06:17:09 Brian Rogers bug added subscriber Brian Rogers
2012-07-09 16:58:03 Omer Akram bug task deleted compiz-core
2012-07-09 16:58:12 Omer Akram bug task deleted unity (Ubuntu)
2012-07-09 17:31:19 pd5rm bug added subscriber pd5rm
2012-07-09 17:31:23 pd5rm removed subscriber pd5rm
2012-07-22 12:54:37 Kai Webber bug added subscriber Kay
2012-07-26 22:09:58 Launchpad Janitor unity (Ubuntu): status New Confirmed
2012-09-13 03:52:34 Edward Donovan bug added subscriber Edward Donovan
2012-09-13 19:27:49 Ted Gould unity: assignee Ted Gould (ted)
2012-09-14 02:30:16 Tim Penhey unity: milestone backlog
2012-09-14 02:51:28 Pierce Gerhart removed subscriber Pierce Gerhart
2012-09-14 07:46:06 Tim Penhey tags amd64 apport-bug lucid onew ubuntu-unity udo udp amd64 apport-bug exbacklog lucid onew ubuntu-unity udo udp
2012-09-14 08:25:26 lekksi bug added subscriber lekksi
2012-09-14 13:10:38 Pierce Gerhart bug added subscriber Pierce Gerhart
2012-10-10 15:50:17 John Lea unity (Ubuntu): status Confirmed Triaged
2012-10-10 15:50:20 John Lea unity (Ubuntu): importance Undecided High
2012-10-12 07:24:00 DarkRedman removed subscriber DarkRedman
2012-10-31 19:04:56 Pierce Gerhart removed subscriber Pierce Gerhart
2012-11-21 14:23:54 Thibaut Brandscheid bug added subscriber Thibaut Brandscheid
2012-12-01 09:34:15 LoreViviani bug added subscriber LoreViviani
2013-02-01 20:45:20 Grzegorz Szukowski bug added subscriber Grzegorz Szukowski
2013-02-03 03:35:51 Pierce Gerhart bug added subscriber Pierce Gerhart
2013-03-29 22:02:01 Marco Trevisan (Treviño) bug task added indicator-sound
2013-03-29 22:02:25 Marco Trevisan (Treviño) indicator-sound: importance Undecided High
2013-03-29 22:02:30 Marco Trevisan (Treviño) indicator-sound: status New Triaged
2013-03-29 22:02:44 Marco Trevisan (Treviño) compiz: status Triaged Invalid
2013-03-29 22:02:50 Marco Trevisan (Treviño) unity: status Triaged Won't Fix
2013-03-29 22:02:59 Marco Trevisan (Treviño) unity: status Won't Fix Invalid
2013-03-29 23:24:05 Marco Trevisan (Treviño) bug watch added https://bugs.freedesktop.org/show_bug.cgi?id=62917
2013-03-29 23:24:05 Marco Trevisan (Treviño) bug task added mpris
2013-03-29 23:26:37 Marco Trevisan (Treviño) bug watch added https://bugzilla.gnome.org/show_bug.cgi?id=688830
2013-03-29 23:27:41 Marco Trevisan (Treviño) bug added subscriber Marco Trevisan (Treviño)
2013-03-29 23:31:19 Marco Trevisan (Treviño) description Ubuntu 11.10 beta compiz 1:0.9.5.94+bzr2803-0ubuntu5 unity 4.16.0-0ubuntu1 1. open banshee, start a song in it and minimize 2. open another application lets say gnome-terminal 3. click on the sound menu and select banshee What happens banshee icon in the launcher wiggles and banshee main window is not shown What should happen banshee main window should come to focus This is a long standing bug which Ted Gould thinks should be fixed at window manager's level. ====Some other observations===== The problem wont happen 1. if every other app is minimized or 2. Banshee is the only opened app or 3. after opening gnome-terminal, banshee window is closed so that it hides to the SoundMenu and opened again =====Comment from Ted Gould===== <om26er> tedg, Hi! any thoughts on the long standing bug 627195 ? Its been there before unity so I guess we can conclude unity not to be responsible <tedg> om26er, My thought is that window managers should $%#$ get fixed... though I haven't convinced smspillaz of it yet. Ubuntu 11.10 beta compiz 1:0.9.5.94+bzr2803-0ubuntu5 unity 4.16.0-0ubuntu1 1. open banshee, start a song in it and minimize 2. open another application lets say gnome-terminal 3. click on the sound menu and select banshee What happens banshee icon in the launcher wiggles and banshee main window is not shown What should happen banshee main window should come to focus This is a long standing bug which Ted Gould thinks should be fixed at window manager's level. ====Some other observations===== The problem wont happen 1. if every other app is minimized or 2. Banshee is the only opened app or 3. after opening gnome-terminal, banshee window is closed so that it hides to the SoundMenu and opened again =====Comment from Ted Gould===== <om26er> tedg, Hi! any thoughts on the long standing bug 627195 ? Its been there before unity so I guess we can conclude unity not to be responsible <tedg> om26er, My thought is that window managers should $%#$ get fixed... though I haven't convinced smspillaz of it yet. =====The good rule===== Indicator-session should present the players windows by passing to them the timestamp of the menu item activation event. Unfortunately this is not trival as it sounds, since it needs a change to the MPRIS dbus specification. See comment https://bugs.launchpad.net/ayatana-design/+bug/627195/comments/26 for more informations. Window managers will obey to it.
2013-03-29 23:46:03 Marco Trevisan (Treviño) compiz (Ubuntu): status Triaged Invalid
2013-03-29 23:46:10 Marco Trevisan (Treviño) unity (Ubuntu): status Triaged Invalid
2013-03-29 23:46:20 Marco Trevisan (Treviño) indicator-sound (Ubuntu): status New Confirmed
2013-03-30 19:26:24 Marco Trevisan (Treviño) indicator-sound: assignee Marco Trevisan (Treviño) (3v1n0)
2013-03-30 19:26:35 Marco Trevisan (Treviño) indicator-sound: milestone 13.04.0
2013-03-30 19:26:39 Marco Trevisan (Treviño) indicator-sound: status Triaged In Progress
2013-03-30 19:26:47 Marco Trevisan (Treviño) branch linked lp:~3v1n0/indicator-sound/gtk-application-player-activate
2013-03-31 01:26:23 Bug Watch Updater mpris: status Unknown Confirmed
2013-03-31 01:26:23 Bug Watch Updater mpris: importance Unknown High
2013-04-02 15:55:30 Launchpad Janitor branch linked lp:~3v1n0/indicator-sound/bamf-player-activation
2013-04-02 16:18:08 Marco Trevisan (Treviño) indicator-sound (Ubuntu): assignee Marco Trevisan (Treviño) (3v1n0)
2013-04-02 16:18:11 Marco Trevisan (Treviño) indicator-sound (Ubuntu): status Confirmed In Progress
2013-04-02 20:14:19 Marco Trevisan (Treviño) bug task added indicator-messages
2013-04-02 20:14:35 Marco Trevisan (Treviño) indicator-messages: assignee Marco Trevisan (Treviño) (3v1n0)
2013-04-02 20:14:38 Marco Trevisan (Treviño) indicator-messages: importance Undecided High
2013-04-02 20:14:43 Marco Trevisan (Treviño) indicator-messages: status New In Progress
2013-04-03 15:07:20 TomasHnyk bug watch added https://bugzilla.gnome.org/show_bug.cgi?id=693815
2013-04-03 15:43:35 Marco Trevisan (Treviño) bug task added empathy (Ubuntu)
2013-04-03 15:43:53 Marco Trevisan (Treviño) empathy (Ubuntu): assignee Marco Trevisan (Treviño) (3v1n0)
2013-04-03 15:44:08 Marco Trevisan (Treviño) empathy (Ubuntu): status New In Progress
2013-04-03 15:44:23 Marco Trevisan (Treviño) branch linked lp:~3v1n0/indicator-messages/launch-app-with-timestamp
2013-04-03 16:27:59 Launchpad Janitor branch linked lp:~3v1n0/empathy/empathy-activate-with-platform-data
2013-04-03 17:23:11 Marco Trevisan (Treviño) nominated for series indicator-sound/13.04
2013-04-03 17:23:11 Marco Trevisan (Treviño) bug task added indicator-sound/13.04
2013-04-03 17:23:35 Marco Trevisan (Treviño) indicator-sound/13.04: importance Undecided High
2013-04-03 17:23:35 Marco Trevisan (Treviño) indicator-sound/13.04: status New In Progress
2013-04-03 17:23:35 Marco Trevisan (Treviño) indicator-sound/13.04: milestone 13.04.0
2013-04-03 17:23:35 Marco Trevisan (Treviño) indicator-sound/13.04: assignee Marco Trevisan (Treviño) (3v1n0)
2013-04-03 17:24:08 Marco Trevisan (Treviño) indicator-sound: milestone 13.04.0
2013-04-03 17:24:33 Marco Trevisan (Treviño) indicator-sound: status In Progress Triaged
2013-04-03 17:24:33 Marco Trevisan (Treviño) indicator-sound: assignee Marco Trevisan (Treviño) (3v1n0)
2013-04-03 17:25:13 Marco Trevisan (Treviño) indicator-messages: status In Progress Triaged
2013-04-03 17:25:13 Marco Trevisan (Treviño) indicator-messages: assignee Marco Trevisan (Treviño) (3v1n0)
2013-04-03 17:25:27 Marco Trevisan (Treviño) nominated for series indicator-messages/13.04
2013-04-03 17:25:27 Marco Trevisan (Treviño) bug task added indicator-messages/13.04
2013-04-03 17:25:50 Marco Trevisan (Treviño) indicator-messages/13.04: importance Undecided High
2013-04-03 17:25:50 Marco Trevisan (Treviño) indicator-messages/13.04: status New In Progress
2013-04-03 17:25:50 Marco Trevisan (Treviño) indicator-messages/13.04: milestone 13.04.0
2013-04-03 17:25:50 Marco Trevisan (Treviño) indicator-messages/13.04: assignee Marco Trevisan (Treviño) (3v1n0)
2013-04-03 17:56:01 Marco Trevisan (Treviño) indicator-messages (Ubuntu): status New In Progress
2013-04-03 17:56:01 Marco Trevisan (Treviño) indicator-messages (Ubuntu): assignee Marco Trevisan (Treviño) (3v1n0)
2013-04-03 18:08:41 Marco Trevisan (Treviño) description Ubuntu 11.10 beta compiz 1:0.9.5.94+bzr2803-0ubuntu5 unity 4.16.0-0ubuntu1 1. open banshee, start a song in it and minimize 2. open another application lets say gnome-terminal 3. click on the sound menu and select banshee What happens banshee icon in the launcher wiggles and banshee main window is not shown What should happen banshee main window should come to focus This is a long standing bug which Ted Gould thinks should be fixed at window manager's level. ====Some other observations===== The problem wont happen 1. if every other app is minimized or 2. Banshee is the only opened app or 3. after opening gnome-terminal, banshee window is closed so that it hides to the SoundMenu and opened again =====Comment from Ted Gould===== <om26er> tedg, Hi! any thoughts on the long standing bug 627195 ? Its been there before unity so I guess we can conclude unity not to be responsible <tedg> om26er, My thought is that window managers should $%#$ get fixed... though I haven't convinced smspillaz of it yet. =====The good rule===== Indicator-session should present the players windows by passing to them the timestamp of the menu item activation event. Unfortunately this is not trival as it sounds, since it needs a change to the MPRIS dbus specification. See comment https://bugs.launchpad.net/ayatana-design/+bug/627195/comments/26 for more informations. Window managers will obey to it. Ubuntu 11.10 beta compiz 1:0.9.5.94+bzr2803-0ubuntu5 unity 4.16.0-0ubuntu1 1. open banshee, start a song in it and minimize 2. open another application lets say gnome-terminal 3. click on the sound menu and select banshee What happens banshee icon in the launcher wiggles and banshee main window is not shown What should happen banshee main window should come to focus This is a long standing bug which Ted Gould thinks should be fixed at window manager's level. ====Some other observations===== The problem wont happen 1. if every other app is minimized or 2. Banshee is the only opened app or 3. after opening gnome-terminal, banshee window is closed so that it hides to the SoundMenu and opened again =====Comment from Ted Gould===== <om26er> tedg, Hi! any thoughts on the long standing bug 627195 ? Its been there before unity so I guess we can conclude unity not to be responsible <tedg> om26er, My thought is that window managers should $%#$ get fixed... though I haven't convinced smspillaz of it yet. =====The good rule===== Indicators should present the application windows by passing to them the timestamp of the menu item activation event. Unfortunately for indicator-sound, this is not trival as it sounds, since it needs a change to the MPRIS dbus specification. See comment https://bugs.launchpad.net/ayatana-design/+bug/627195/comments/26 for more informations. Window managers will obey to it.
2013-04-04 05:29:21 PS Jenkins bot indicator-messages: status Triaged Fix Committed
2013-04-04 08:39:50 Marco Trevisan (Treviño) indicator-messages: status Fix Committed Triaged
2013-04-04 08:40:20 Marco Trevisan (Treviño) indicator-messages/13.04: status In Progress Fix Committed
2013-04-04 08:41:02 Marco Trevisan (Treviño) indicator-messages (Ubuntu): status In Progress Fix Committed
2013-04-05 10:00:00 PS Jenkins bot indicator-sound: status Triaged Fix Committed
2013-04-05 13:28:27 Marco Trevisan (Treviño) indicator-sound: status Fix Committed Triaged
2013-04-05 13:28:46 Marco Trevisan (Treviño) indicator-sound/13.04: status In Progress Fix Committed
2013-04-05 13:51:55 Marco Trevisan (Treviño) indicator-sound: status Triaged In Progress
2013-04-05 13:51:55 Marco Trevisan (Treviño) indicator-sound: assignee Marco Trevisan (Treviño) (3v1n0)
2013-04-05 13:52:45 Marco Trevisan (Treviño) indicator-messages: status Triaged In Progress
2013-04-05 13:52:45 Marco Trevisan (Treviño) indicator-messages: assignee Marco Trevisan (Treviño) (3v1n0)
2013-04-05 14:15:50 PS Jenkins bot indicator-messages: status In Progress Fix Committed
2013-04-05 14:29:19 PS Jenkins bot indicator-sound: status In Progress Fix Committed
2013-04-05 15:01:36 Marco Trevisan (Treviño) empathy (Ubuntu): status In Progress Fix Committed
2013-04-05 18:00:02 Launchpad Janitor branch linked lp:ubuntu/raring-proposed/empathy
2013-04-05 18:31:19 Launchpad Janitor empathy (Ubuntu): status Fix Committed Fix Released
2013-04-05 19:06:12 Brains bug added subscriber Joris V.
2013-04-05 19:07:03 Brains removed subscriber Joris V.
2013-04-05 21:18:15 Marco Trevisan (Treviño) indicator-sound (Ubuntu): status In Progress Fix Committed
2013-04-09 08:40:22 Launchpad Janitor indicator-messages (Ubuntu): status Fix Committed Fix Released
2013-04-09 08:40:34 Launchpad Janitor indicator-sound (Ubuntu): status Fix Committed Fix Released
2013-04-11 11:21:55 Marco Trevisan (Treviño) indicator-messages: milestone 13.10.1
2013-04-11 22:09:33 Marco Trevisan (Treviño) bug task added ubuntuone-client
2013-04-11 22:10:00 Marco Trevisan (Treviño) ubuntuone-client: status New In Progress
2013-04-11 22:10:00 Marco Trevisan (Treviño) ubuntuone-client: assignee Marco Trevisan (Treviño) (3v1n0)
2013-04-11 22:16:14 Launchpad Janitor branch linked lp:~3v1n0/ubuntuone-client/sync-menu-use-gappinfo-launch
2013-04-12 12:14:03 Marco Trevisan (Treviño) bug task added libdbusmenu
2013-04-12 12:14:50 Marco Trevisan (Treviño) libdbusmenu: importance Undecided Medium
2013-04-12 12:14:50 Marco Trevisan (Treviño) libdbusmenu: status New Triaged
2013-04-12 12:23:20 Marco Trevisan (Treviño) description Ubuntu 11.10 beta compiz 1:0.9.5.94+bzr2803-0ubuntu5 unity 4.16.0-0ubuntu1 1. open banshee, start a song in it and minimize 2. open another application lets say gnome-terminal 3. click on the sound menu and select banshee What happens banshee icon in the launcher wiggles and banshee main window is not shown What should happen banshee main window should come to focus This is a long standing bug which Ted Gould thinks should be fixed at window manager's level. ====Some other observations===== The problem wont happen 1. if every other app is minimized or 2. Banshee is the only opened app or 3. after opening gnome-terminal, banshee window is closed so that it hides to the SoundMenu and opened again =====Comment from Ted Gould===== <om26er> tedg, Hi! any thoughts on the long standing bug 627195 ? Its been there before unity so I guess we can conclude unity not to be responsible <tedg> om26er, My thought is that window managers should $%#$ get fixed... though I haven't convinced smspillaz of it yet. =====The good rule===== Indicators should present the application windows by passing to them the timestamp of the menu item activation event. Unfortunately for indicator-sound, this is not trival as it sounds, since it needs a change to the MPRIS dbus specification. See comment https://bugs.launchpad.net/ayatana-design/+bug/627195/comments/26 for more informations. Window managers will obey to it. Ubuntu 11.10 beta compiz 1:0.9.5.94+bzr2803-0ubuntu5 unity 4.16.0-0ubuntu1 1. open banshee, start a song in it and minimize 2. open another application lets say gnome-terminal 3. click on the sound menu and select banshee What happens banshee icon in the launcher wiggles and banshee main window is not shown What should happen banshee main window should come to focus This is a long standing bug which Ted Gould thinks should be fixed at window manager's level. ====Some other observations===== The problem wont happen 1. if every other app is minimized or 2. Banshee is the only opened app or 3. after opening gnome-terminal, banshee window is closed so that it hides to the SoundMenu and opened again =====Comment from Ted Gould===== <om26er> tedg, Hi! any thoughts on the long standing bug 627195 ? Its been there before unity so I guess we can conclude unity not to be responsible <tedg> om26er, My thought is that window managers should $%#$ get fixed... though I haven't convinced smspillaz of it yet. =====The good rule===== 3v1n0: Indicators should present the application windows by passing to them the timestamp of the menu item activation event. Unfortunately for indicator-sound, this is not trival as it sounds, since it needs a change to the MPRIS dbus specification. See comment https://bugs.launchpad.net/ayatana-design/+bug/627195/comments/26 for more informations. For what concerns libappindicator based indicators (such as the one used by tomboy), since it's not currently possible in libdbusmenu to pass the event during activation (so that clients will be able to get the proper timestamp using gtk_get_current_event_time), there are two "hackish" ways: 1. Use the server time to present a window: https://bugzilla.gnome.org/show_bug.cgi?id=688830 2. Get the event timestamp from the dbus-menu linked to the gtk-menus: http://paste.ubuntu.com/5701235/ Window managers will obey to it.
2013-04-12 12:24:47 Marco Trevisan (Treviño) bug task added tomboy (Ubuntu)
2013-04-12 12:25:15 Marco Trevisan (Treviño) tomboy (Ubuntu): status New Confirmed
2013-04-12 12:25:40 Marco Trevisan (Treviño) ubuntuone-client (Ubuntu): status New In Progress
2013-04-12 12:25:40 Marco Trevisan (Treviño) ubuntuone-client (Ubuntu): assignee Marco Trevisan (Treviño) (3v1n0)
2013-04-12 19:18:08 Kai Webber removed subscriber Kay
2013-04-12 21:26:32 Launchpad Janitor branch linked lp:ubuntu/indicator-sound
2013-04-16 16:11:29 Marco Trevisan (Treviño) branch linked lp:~3v1n0/ubuntuone-client/sync-menu-use-gappinfo-launch-4.2
2013-04-16 16:11:39 Marco Trevisan (Treviño) ubuntuone-client: status In Progress Fix Committed
2013-04-17 12:11:24 Dave Morley tags amd64 apport-bug exbacklog lucid onew ubuntu-unity udo udp amd64 apport-bug exbacklog lucid onew u1-notrack ubuntu-unity udo udp
2013-05-07 03:58:11 Pierce Gerhart removed subscriber Pierce Gerhart
2013-05-23 12:44:21 Marco Trevisan (Treviño) description Ubuntu 11.10 beta compiz 1:0.9.5.94+bzr2803-0ubuntu5 unity 4.16.0-0ubuntu1 1. open banshee, start a song in it and minimize 2. open another application lets say gnome-terminal 3. click on the sound menu and select banshee What happens banshee icon in the launcher wiggles and banshee main window is not shown What should happen banshee main window should come to focus This is a long standing bug which Ted Gould thinks should be fixed at window manager's level. ====Some other observations===== The problem wont happen 1. if every other app is minimized or 2. Banshee is the only opened app or 3. after opening gnome-terminal, banshee window is closed so that it hides to the SoundMenu and opened again =====Comment from Ted Gould===== <om26er> tedg, Hi! any thoughts on the long standing bug 627195 ? Its been there before unity so I guess we can conclude unity not to be responsible <tedg> om26er, My thought is that window managers should $%#$ get fixed... though I haven't convinced smspillaz of it yet. =====The good rule===== 3v1n0: Indicators should present the application windows by passing to them the timestamp of the menu item activation event. Unfortunately for indicator-sound, this is not trival as it sounds, since it needs a change to the MPRIS dbus specification. See comment https://bugs.launchpad.net/ayatana-design/+bug/627195/comments/26 for more informations. For what concerns libappindicator based indicators (such as the one used by tomboy), since it's not currently possible in libdbusmenu to pass the event during activation (so that clients will be able to get the proper timestamp using gtk_get_current_event_time), there are two "hackish" ways: 1. Use the server time to present a window: https://bugzilla.gnome.org/show_bug.cgi?id=688830 2. Get the event timestamp from the dbus-menu linked to the gtk-menus: http://paste.ubuntu.com/5701235/ Window managers will obey to it. Ubuntu 11.10 beta compiz 1:0.9.5.94+bzr2803-0ubuntu5 unity 4.16.0-0ubuntu1 1. open banshee, start a song in it and minimize 2. open another application lets say gnome-terminal 3. click on the sound menu and select banshee What happens banshee icon in the launcher wiggles and banshee main window is not shown What should happen banshee main window should come to focus This is a long standing bug which Ted Gould thinks should be fixed at window manager's level. ====Some other observations===== The problem wont happen 1. if every other app is minimized or 2. Banshee is the only opened app or 3. after opening gnome-terminal, banshee window is closed so that it hides to the SoundMenu and opened again =====Comment from Ted Gould===== <om26er> tedg, Hi! any thoughts on the long standing bug 627195 ? Its been there before unity so I guess we can conclude unity not to be responsible <tedg> om26er, My thought is that window managers should $%#$ get fixed... though I haven't convinced smspillaz of it yet. =====The good rule===== 3v1n0: Indicators should present the application windows by passing to them the timestamp of the menu item activation event. Unfortunately for indicator-sound, this is not trival as it sounds, since it needs a change to the MPRIS dbus specification. See comment https://bugs.launchpad.net/ayatana-design/+bug/627195/comments/26 for more informations. For what concerns libappindicator based indicators (such as the one used by tomboy), since it's not currently possible in libdbusmenu to pass the event during activation (so that clients will be able to get the proper timestamp using gtk_get_current_event_time), there are two "hackish" ways: 1. Use the server time to present a window:    https://bugzilla.gnome.org/show_bug.cgi?id=688830 2. Get the event timestamp from the dbus-menu linked to the gtk-menus:    http://paste.ubuntu.com/5701235/ 3. Qt applications workaround: http://is.gd/WnW9eN Window managers will obey to it.
2013-05-25 16:25:14 sgttynis bug added subscriber sgttynis
2013-05-27 19:27:35 atheck bug added subscriber atheck
2013-08-08 16:10:01 Marco Trevisan (Treviño) ubuntuone-client (Ubuntu): status In Progress Fix Released
2013-10-03 12:52:36 Eduard Hasenleithner bug added subscriber Eduard Hasenleithner
2013-10-04 16:21:15 Ted Gould indicator-messages: status Fix Committed Fix Released
2013-10-04 16:22:05 Ted Gould indicator-messages/13.04: status Fix Committed Fix Released
2013-10-04 16:23:05 Ted Gould indicator-sound: status Fix Committed Fix Released
2013-10-04 16:23:33 Ted Gould indicator-sound/13.04: status Fix Committed Fix Released
2014-05-04 12:35:43 Adolfo Jayme bug task deleted indicator-messages (Ubuntu Raring)
2014-05-04 12:39:31 Adolfo Jayme bug task deleted indicator-sound (Ubuntu Raring)
2015-03-14 22:11:54 Launchpad Janitor libdbusmenu (Ubuntu): status New Confirmed
2015-10-07 03:17:08 Marco Trevisan (Treviño) description Ubuntu 11.10 beta compiz 1:0.9.5.94+bzr2803-0ubuntu5 unity 4.16.0-0ubuntu1 1. open banshee, start a song in it and minimize 2. open another application lets say gnome-terminal 3. click on the sound menu and select banshee What happens banshee icon in the launcher wiggles and banshee main window is not shown What should happen banshee main window should come to focus This is a long standing bug which Ted Gould thinks should be fixed at window manager's level. ====Some other observations===== The problem wont happen 1. if every other app is minimized or 2. Banshee is the only opened app or 3. after opening gnome-terminal, banshee window is closed so that it hides to the SoundMenu and opened again =====Comment from Ted Gould===== <om26er> tedg, Hi! any thoughts on the long standing bug 627195 ? Its been there before unity so I guess we can conclude unity not to be responsible <tedg> om26er, My thought is that window managers should $%#$ get fixed... though I haven't convinced smspillaz of it yet. =====The good rule===== 3v1n0: Indicators should present the application windows by passing to them the timestamp of the menu item activation event. Unfortunately for indicator-sound, this is not trival as it sounds, since it needs a change to the MPRIS dbus specification. See comment https://bugs.launchpad.net/ayatana-design/+bug/627195/comments/26 for more informations. For what concerns libappindicator based indicators (such as the one used by tomboy), since it's not currently possible in libdbusmenu to pass the event during activation (so that clients will be able to get the proper timestamp using gtk_get_current_event_time), there are two "hackish" ways: 1. Use the server time to present a window:    https://bugzilla.gnome.org/show_bug.cgi?id=688830 2. Get the event timestamp from the dbus-menu linked to the gtk-menus:    http://paste.ubuntu.com/5701235/ 3. Qt applications workaround: http://is.gd/WnW9eN Window managers will obey to it. Ubuntu 11.10 beta compiz 1:0.9.5.94+bzr2803-0ubuntu5 unity 4.16.0-0ubuntu1 1. open banshee, start a song in it and minimize 2. open another application lets say gnome-terminal 3. click on the sound menu and select banshee What happens banshee icon in the launcher wiggles and banshee main window is not shown What should happen banshee main window should come to focus This is a long standing bug which Ted Gould thinks should be fixed at window manager's level. ====Some other observations===== The problem wont happen 1. if every other app is minimized or 2. Banshee is the only opened app or 3. after opening gnome-terminal, banshee window is closed so that it hides to the SoundMenu and opened again =====Comment from Ted Gould===== <om26er> tedg, Hi! any thoughts on the long standing bug 627195 ? Its been there before unity so I guess we can conclude unity not to be responsible <tedg> om26er, My thought is that window managers should $%#$ get fixed... though I haven't convinced smspillaz of it yet. =====The good rule===== 3v1n0: Indicators should present the application windows by passing to them the timestamp of the menu item activation event. Unfortunately for indicator-sound, this is not trival as it sounds, since it needs a change to the MPRIS dbus specification. See comment https://bugs.launchpad.net/ayatana-design/+bug/627195/comments/26 for more informations. For what concerns libappindicator based indicators (such as the one used by tomboy), since it's not currently possible in libdbusmenu to pass the event during activation (so that clients will be able to get the proper timestamp using gtk_get_current_event_time), there are two "hackish" ways: 1. Use the server time to present a window:    https://bugzilla.gnome.org/show_bug.cgi?id=688830 2. Get the event timestamp from the dbus-menu linked to the gtk-menus:    https://archive.is/2tLX6 3. Qt applications workaround: http://is.gd/WnW9eN Window managers will obey to it.
2016-11-15 02:07:58 Launchpad Janitor branch linked lp:~3v1n0/sni-qt/x11-usertime-on-activate
2016-11-16 18:12:31 Launchpad Janitor branch linked lp:~3v1n0/appmenu-qt5/x11-usertime-on-activate
2017-02-13 18:32:50 Launchpad Janitor branch linked lp:~3v1n0/appmenu-qt5/xenial-sru2
2017-02-13 18:44:35 Launchpad Janitor branch linked lp:~ci-train-bot/appmenu-qt5/appmenu-qt5-ubuntu-xenial-2467
2017-02-17 00:06:15 Marco Trevisan (Treviño) branch unlinked lp:~3v1n0/appmenu-qt5/xenial-sru2
2017-02-17 01:00:55 Launchpad Janitor branch linked lp:~3v1n0/sni-qt/xenial-sru1
2017-02-17 01:03:49 Launchpad Janitor branch linked lp:~ci-train-bot/sni-qt/sni-qt-ubuntu-zesty-2488
2017-02-17 01:10:38 Launchpad Janitor branch linked lp:~ci-train-bot/sni-qt/sni-qt-ubuntu-xenial-2488.1
2017-02-17 15:39:02 Marco Trevisan (Treviño) bug task added sni-qt (Ubuntu)
2017-02-17 15:39:28 Marco Trevisan (Treviño) nominated for series Ubuntu Xenial
2017-02-17 15:40:01 Timo Aaltonen bug task added tomboy (Ubuntu Xenial)
2017-02-17 15:40:01 Timo Aaltonen bug task added compiz (Ubuntu Xenial)
2017-02-17 15:40:01 Timo Aaltonen bug task added empathy (Ubuntu Xenial)
2017-02-17 15:40:01 Timo Aaltonen bug task added indicator-messages (Ubuntu Xenial)
2017-02-17 15:40:01 Timo Aaltonen bug task added ubuntuone-client (Ubuntu Xenial)
2017-02-17 15:40:01 Timo Aaltonen bug task added libdbusmenu (Ubuntu Xenial)
2017-02-17 15:40:01 Timo Aaltonen bug task added unity (Ubuntu Xenial)
2017-02-17 15:40:01 Timo Aaltonen bug task added indicator-sound (Ubuntu Xenial)
2017-02-17 15:40:01 Timo Aaltonen bug task added sni-qt (Ubuntu Xenial)
2017-02-17 15:59:13 Marco Trevisan (Treviño) description Ubuntu 11.10 beta compiz 1:0.9.5.94+bzr2803-0ubuntu5 unity 4.16.0-0ubuntu1 1. open banshee, start a song in it and minimize 2. open another application lets say gnome-terminal 3. click on the sound menu and select banshee What happens banshee icon in the launcher wiggles and banshee main window is not shown What should happen banshee main window should come to focus This is a long standing bug which Ted Gould thinks should be fixed at window manager's level. ====Some other observations===== The problem wont happen 1. if every other app is minimized or 2. Banshee is the only opened app or 3. after opening gnome-terminal, banshee window is closed so that it hides to the SoundMenu and opened again =====Comment from Ted Gould===== <om26er> tedg, Hi! any thoughts on the long standing bug 627195 ? Its been there before unity so I guess we can conclude unity not to be responsible <tedg> om26er, My thought is that window managers should $%#$ get fixed... though I haven't convinced smspillaz of it yet. =====The good rule===== 3v1n0: Indicators should present the application windows by passing to them the timestamp of the menu item activation event. Unfortunately for indicator-sound, this is not trival as it sounds, since it needs a change to the MPRIS dbus specification. See comment https://bugs.launchpad.net/ayatana-design/+bug/627195/comments/26 for more informations. For what concerns libappindicator based indicators (such as the one used by tomboy), since it's not currently possible in libdbusmenu to pass the event during activation (so that clients will be able to get the proper timestamp using gtk_get_current_event_time), there are two "hackish" ways: 1. Use the server time to present a window:    https://bugzilla.gnome.org/show_bug.cgi?id=688830 2. Get the event timestamp from the dbus-menu linked to the gtk-menus:    https://archive.is/2tLX6 3. Qt applications workaround: http://is.gd/WnW9eN Window managers will obey to it. Ubuntu 11.10 beta compiz 1:0.9.5.94+bzr2803-0ubuntu5 unity 4.16.0-0ubuntu1 1. open banshee, start a song in it and minimize 2. open another application lets say gnome-terminal 3. click on the sound menu and select banshee What happens banshee icon in the launcher wiggles and banshee main window is not shown What should happen banshee main window should come to focus This is a long standing bug which Ted Gould thinks should be fixed at window manager's level. ====Some other observations===== The problem wont happen 1. if every other app is minimized or 2. Banshee is the only opened app or 3. after opening gnome-terminal, banshee window is closed so that it hides to the SoundMenu and opened again =====Comment from Ted Gould===== <om26er> tedg, Hi! any thoughts on the long standing bug 627195 ? Its been there before unity so I guess we can conclude unity not to be responsible <tedg> om26er, My thought is that window managers should $%#$ get fixed... though I haven't convinced smspillaz of it yet. =====The good rule===== 3v1n0: Indicators should present the application windows by passing to them the timestamp of the menu item activation event. Unfortunately for indicator-sound, this is not trival as it sounds, since it needs a change to the MPRIS dbus specification. See comment https://bugs.launchpad.net/ayatana-design/+bug/627195/comments/26 for more informations. For what concerns libappindicator based indicators (such as the one used by tomboy), since it's not currently possible in libdbusmenu to pass the event during activation (so that clients will be able to get the proper timestamp using gtk_get_current_event_time), there are two "hackish" ways: 1. Use the server time to present a window:    https://bugzilla.gnome.org/show_bug.cgi?id=688830 2. Get the event timestamp from the dbus-menu linked to the gtk-menus:    https://archive.is/2tLX6 3. Qt applications workaround: http://is.gd/WnW9eN Window managers will obey to it. =================================== SRU for sni-qt: [Test case] git clone https://github.com/3v1n0/indicators-examples-snaps cd indicators-examples-snaps/qt4-systray qmake-qt4 ./systray Close the app, now try to restore it from in the indicator (after having played with some app writing text on it such as gnome-terminal or gedit). The app should be in foreground now
2017-02-20 06:33:17 Mathew Hodson sni-qt (Ubuntu Xenial): importance Undecided Medium
2017-02-20 06:33:17 Mathew Hodson sni-qt (Ubuntu Xenial): status New Fix Committed
2017-02-20 06:35:39 Mathew Hodson bug task deleted unity (Ubuntu Xenial)
2017-02-20 06:36:02 Mathew Hodson bug task deleted unity (Ubuntu)
2017-02-20 06:36:31 Mathew Hodson bug task deleted compiz (Ubuntu Xenial)
2017-02-20 06:36:52 Mathew Hodson bug task deleted compiz (Ubuntu)
2017-02-20 06:37:50 Mathew Hodson affects compiz ubuntu-translations
2017-02-20 06:38:11 Mathew Hodson bug task deleted ubuntu-translations
2017-02-20 06:39:53 Mathew Hodson affects unity ubuntu-translations
2017-02-20 06:40:09 Mathew Hodson bug task deleted ubuntu-translations
2017-02-20 06:41:56 Mathew Hodson tags amd64 apport-bug exbacklog lucid onew u1-notrack ubuntu-unity udo udp amd64 apport-bug exbacklog lucid onew u1-notrack ubuntu-unity udo udp verification-needed
2017-02-20 14:02:09 void removed subscriber void
2017-02-21 12:19:45 Marco Trevisan (Treviño) tags amd64 apport-bug exbacklog lucid onew u1-notrack ubuntu-unity udo udp verification-needed amd64 apport-bug exbacklog lucid onew u1-notrack ubuntu-unity udo udp verification-done
2017-02-28 23:45:39 Chris Halse Rogers sni-qt (Ubuntu): status New Fix Released
2017-02-28 23:46:47 Launchpad Janitor sni-qt (Ubuntu Xenial): status Fix Committed Fix Released
2018-11-07 19:28:58 Bug Watch Updater mpris: status Confirmed Unknown