[regression] nautilus plugin does not load published file list

Bug #621433 reported by Roman Yepishev on 2010-08-20
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Ubuntu One Client
High
Rodrigo Moya
ubuntuone-client (Ubuntu)
High
Rodrigo Moya
Maverick
High
Rodrigo Moya

Bug Description

Bug not present: 1.3.8-0ubuntu2
Bug present: 1.3.10-0ubuntu1

When nautilus starts it should fetch the list of published files from syncdaemon. This is no longer happening, therefore all published files have "Publish this file via Ubuntu One" link even though they are already published.

For example, http://ubuntuone.com/p/DO2/ shows that a mediocre picture of rubber ducks ( http://ubuntuone.com/p/7yV/ ) is not published. 1.3.8-0ubuntu2 requested the list of public files properly.

Related branches

Roman Yepishev (rye) on 2010-08-20
Changed in ubuntuone-client (Ubuntu):
status: New → Confirmed
importance: Undecided → High
assignee: nobody → Ubuntu One Desktop+ team (ubuntuone-desktop+)
Roman Yepishev (rye) wrote :

Having downgraded to 1.3.8-0ubuntu2 i see that it does not fetch the file list as well, so it looks like there is some kind of external change that broke our package.

Roman Yepishev (rye) wrote :

More info - syncdaemon_publicfiles_interface_init appears to be called only when one tries to publish file through nautilus. This initialization which ties dbus listeners should be called pretty much on extension initialization. Maybe that's what we are now missing?

Roman Yepishev (rye) wrote :

After I added the calls to create dummy interface objects the status-changed handler started to fire up as well as the list of public files was requested from SD.
For now the menu entries are not reflecting the real state still but this at least gives the pointer towards correct way of doing things, i.e. all interface objects should be initialized on startup and probably be stored in some private variables for future usage.

Changed in ubuntuone-client:
assignee: Ubuntu One Desktop+ team (ubuntuone-desktop+) → Rodrigo Moya (rodrigo-moya)
Changed in ubuntuone-client (Ubuntu):
assignee: Ubuntu One Desktop+ team (ubuntuone-desktop+) → Rodrigo Moya (rodrigo-moya)
status: Confirmed → Triaged
Changed in ubuntuone-client:
status: Confirmed → Triaged
Changed in ubuntuone-client (Ubuntu Maverick):
milestone: none → ubuntu-10.10
tags: added: u1-maverick
Roman Yepishev (rye) on 2010-08-31
Changed in ubuntuone-client:
assignee: Rodrigo Moya (rodrigo-moya) → Roman Yepishev (rye)
Changed in ubuntuone-client:
assignee: Roman Yepishev (rye) → Rodrigo Moya (rodrigo-moya)
status: Triaged → In Progress
dobey (dobey) on 2010-08-31
Changed in ubuntuone-client:
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntuone-client - 1.3.99-0ubuntu1

---------------
ubuntuone-client (1.3.99-0ubuntu1) maverick; urgency=low

  * New upstream release:
    - Use spinner and gray out widgets when syncing/unsyncing (Rodrigo Moya)
    - Fixed SSO signals' signatures in u1-prefs (Rodrigo Moya) (LP: #625296)
    - Memory improvements in the AQ queues, markers revisited (Facundo Batista)
    - Get the subinterfaces ASAP so that the signals from them are setup
      (Rodrigo Moya) (LP: #621433)
    - Fix crash in ubuntuone_nautilus_got_public_files (Rodrigo Moya)
      (LP: #627329)
  * debian/control:
    - Depend on ubuntu-sso-client >= 0.99.4
 -- Rodrigo Moya <email address hidden> Tue, 31 Aug 2010 17:11:09 +0200

Changed in ubuntuone-client (Ubuntu Maverick):
status: Triaged → Fix Released
Changed in ubuntuone-client:
status: Fix Committed → Fix Released
dobey (dobey) on 2010-09-03
Changed in ubuntuone-client:
status: Fix Released → Fix Committed
John Lenton (chipaca) on 2010-09-17
Changed in ubuntuone-client:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers