[nightlies] client fails to launch with import error on APP_NAME

Bug #621354 reported by Rick McBride on 2010-08-20
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu One Client
Critical
Natalia Bidart
ubuntuone-client (Ubuntu)
Critical
Ubuntu One Client Engineering team

Bug Description

~$ ubuntuone-launch
Traceback (most recent call last):
  File "/usr/bin/ubuntuone-launch", line 38, in <module>
    from ubuntuone.syncdaemon.tools import SyncDaemonTool, is_running
  File "/usr/lib/python2.6/dist-packages/ubuntuone/syncdaemon/tools.py", line 24, in <module>
    from ubuntuone.syncdaemon.dbus_interface import (
  File "/usr/lib/python2.6/dist-packages/ubuntuone/syncdaemon/dbus_interface.py", line 34, in <module>
    from ubuntuone import APP_NAME, TC_URL, DESCRIPTION
ImportError: cannot import name APP_NAME

Related branches

Rick McBride (rmcbride) wrote :

this started with this mornings' nightlies. Possibly related to a patch that is being stripped by the nightly script.

Facundo Batista (facundo) wrote :

I'm raising this to Critical, as nightlies is completely unusable.

Also, Rick, I'm assigning this to you. Reassign if needed.

Thanks!

Changed in ubuntuone-client:
status: New → Confirmed
importance: Undecided → Critical
assignee: nobody → Rick McBride (rmcbride)
Rick McBride (rmcbride) wrote :

Naty,

Since you're doing the branch to fix the __init__.py in question, assigning to you

Changed in ubuntuone-client:
assignee: Rick McBride (rmcbride) → Naty Bidart (nataliabidart)
Changed in ubuntuone-client (Ubuntu):
importance: Undecided → Critical
status: New → Triaged
assignee: nobody → Ubuntu One Desktop+ team (ubuntuone-desktop+)
Changed in ubuntuone-client:
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntuone-client - 1.3.90-0ubuntu1

---------------
ubuntuone-client (1.3.90-0ubuntu1) maverick; urgency=low

  * New upstream release:
    - Use new SSO authentication DBus service (Natalia Bidart) (LP:#619885)
    - Restored the ability of passing oauth credentials by the command line
      (Natalia Bidart) (LP: #619228)
    - Convert path arguments to absolute paths (Roman Yepishev)
    - Dump metadata to stdout, very useful for debugging (Facundo Batista)
    - LR does not compare full stat anymore, only relevant pieces (Facundo
      Batista)
    - Moving constants to another file to avoid ImportError's (Natalia Bidart)
      (LP: #621354)
    - Add clientdefs dependency to docs build, as dbus_interface.py requires it
      now (Rodney Dawes)
    - The app_name should be the user visible string "Ubuntu One" instead of
      "ubuntu one" (Alejandro J. Cura)
    - Stop storing wrapped functions in every queued command (Facundo Batista)
    - Make ubuntuone-preferences use ubuntu-sso (Rodrigo Moya)
    - Receive app_name in all DBus signals from ubuntu-sso (Rodrigo Moya)
    - Make introspection auto* rules deal better with errors (Rodrigo Moya)
    - Don't show the ribbon on the videos folder (John Lenton) (LP: #623482)
    - Signals from SSO dbus service are correctly processed now (using the
      latest (Natalia Bidart) (LP: #623447)
    - Check that the user has no published files before disabling a UDF
      (Rodrigo Moya) (LP: #603576)

  [ Rodney Dawes ]
  * Use python-support instead of python-central
 -- Rodrigo Moya <email address hidden> Wed, 25 Aug 2010 22:38:57 +0200

Changed in ubuntuone-client (Ubuntu):
status: Triaged → Fix Released
Changed in ubuntuone-client:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers