nautilus hangs while asking for folders

Bug #617656 reported by Lucio Torre on 2010-08-13
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Release Notes for Ubuntu
Undecided
Unassigned
Ubuntu One Client
Medium
Ubuntu One Client Engineering team
ubuntuone-client (Ubuntu)
Medium
Ubuntu One Client Engineering team

Bug Description

i have an UDF on ~/Music. The udf is not currently subscribed to.
If i do $ gnome-open ~/Music
Nautilus shows up and then dies. Subfolders of ~/Music work.
After hanging i see a last log line in syncdaemon.log:

2010-08-13 20:36:43,242 - ubuntuone.SyncDaemon.DBus - DEBUG - get_metadata: dbus.String(u"/home/lucio/Music/0481. Go-Go's - Beauty And The Beat/01 - Our Lips Are Sealed.mp3")
2010-08-13 20:36:46,633 - ubuntuone.SyncDaemon.DBus - DEBUG - get_metadata: dbus.String(u'/home/lucio/Music/0582. I Against I')
2010-08-13 20:36:47,523 - ubuntuone.SyncDaemon.DBus - DEBUG - Folders.get_folders

no relevant exceptions are shown in the log.

Related branches

Lucio Torre (lucio.torre) wrote :
Download full text (33.0 KiB)

lucio@prometeo:~/Music$ sudo gdb nautilus $(ps h -C nautilus -o pid)
[sudo] password for lucio:
GNU gdb (GDB) 7.1-ubuntu
Copyright (C) 2010 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law. Type "show copying"
and "show warranty" for details.
This GDB was configured as "x86_64-linux-gnu".
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>...
Reading symbols from /usr/bin/nautilus...(no debugging symbols found)...done.
Attaching to program: /usr/bin/nautilus, process 9157
Reading symbols from /usr/lib/libSM.so.6...(no debugging symbols found)...done.
Loaded symbols for /usr/lib/libSM.so.6
Reading symbols from /usr/lib/libICE.so.6...(no debugging symbols found)...done.
Loaded symbols for /usr/lib/libICE.so.6
Reading symbols from /usr/lib/libXrender.so.1...(no debugging symbols found)...done.
Loaded symbols for /usr/lib/libXrender.so.1
Reading symbols from /usr/lib/libnautilus-extension.so.1...(no debugging symbols found)...done.
Loaded symbols for /usr/lib/libnautilus-extension.so.1
Reading symbols from /usr/lib/libappindicator.so.0...(no debugging symbols found)...done.
Loaded symbols for /usr/lib/libappindicator.so.0
Reading symbols from /usr/lib/libgnome-desktop-2.so.17...(no debugging symbols found)...done.
Loaded symbols for /usr/lib/libgnome-desktop-2.so.17
Reading symbols from /usr/lib/liblaunchpad-integration.so.1...(no debugging symbols found)...done.
Loaded symbols for /usr/lib/liblaunchpad-integration.so.1
Reading symbols from /usr/lib/libunique-1.0.so.0...(no debugging symbols found)...done.
Loaded symbols for /usr/lib/libunique-1.0.so.0
Reading symbols from /usr/lib/libdbus-glib-1.so.2...(no debugging symbols found)...done.
Loaded symbols for /usr/lib/libdbus-glib-1.so.2
Reading symbols from /lib/libpthread.so.0...Reading symbols from /usr/lib/debug/lib/libpthread-2.12.so...done.
[Thread debugging using libthread_db enabled]
done.
Loaded symbols for /lib/libpthread.so.0
Reading symbols from /usr/lib/libgailutil.so.18...(no debugging symbols found)...done.
Loaded symbols for /usr/lib/libgailutil.so.18
Reading symbols from /usr/lib/libgtk-x11-2.0.so.0...(no debugging symbols found)...done.
Loaded symbols for /usr/lib/libgtk-x11-2.0.so.0
Reading symbols from /usr/lib/libgdk-x11-2.0.so.0...(no debugging symbols found)...done.
Loaded symbols for /usr/lib/libgdk-x11-2.0.so.0
Reading symbols from /usr/lib/libatk-1.0.so.0...(no debugging symbols found)...done.
Loaded symbols for /usr/lib/libatk-1.0.so.0
Reading symbols from /usr/lib/libgio-2.0.so.0...(no debugging symbols found)...done.
Loaded symbols for /usr/lib/libgio-2.0.so.0
Reading symbols from /usr/lib/libgdk_pixbuf-2.0.so.0...(no debugging symbols found)...done.
Loaded symbols for /usr/lib/libgdk_pixbuf-2.0.so.0
Reading symbols from /usr/lib/libcairo.so.2...(no debugging symbols found)...done.
Loaded symbols for /usr/lib/libcairo.so.2
Reading symbols from /usr/lib/libpango-1.0.so.0...(no debugging symbols found)...done.
Loaded symbols for /usr/lib/libpango-1.0.so.0
Read...

John Lenton (chipaca) on 2010-08-14
Changed in ubuntuone-client:
importance: Undecided → Critical
status: New → Triaged
John Lenton (chipaca) wrote :

Hmm... when I do that, I get more useful data. Could you try installing gnome-dbg and seeing if that improves the backtrace any? Otherwise, can you build the client and «sudo cp nautilus/.libs/libnautilus-ubuntuone.{a,la,so} /usr/lib/nautilus/extensions-2.0/ && killall nautilus» and try again?
Rodrigo would know this stuff by heart, but he's on vacation until Tuesday and I'd rather know what's going on before that :)

Rodrigo Moya (rodrigo-moya) wrote :

Yes, the backtrace looks a bit useless, although it seems to be something wrong in libdbus, so Lucio, please do what John said, to get a better backtrace

Lucio Torre (lucio.torre) wrote :

(gdb) bt
#0 0x00007fa5e0937921 in __libc_writev (fd=9, vector=0x7fffe1823b50, count=2)
    at ../sysdeps/unix/sysv/linux/writev.c:56
#1 0x00007fa5deee64d3 in ?? () from /lib/libdbus-1.so.3
#2 0x00007fa5deede29c in ?? () from /lib/libdbus-1.so.3
#3 0x00007fa5deede5a6 in ?? () from /lib/libdbus-1.so.3
#4 0x00007fa5deedc81d in ?? () from /lib/libdbus-1.so.3
#5 0x00007fa5deec8c7e in ?? () from /lib/libdbus-1.so.3
#6 0x00007fa5deec8d58 in ?? () from /lib/libdbus-1.so.3
#7 0x00007fa5deeca2d0 in ?? () from /lib/libdbus-1.so.3
#8 0x00007fa5deeca461 in dbus_connection_send_with_reply ()
   from /lib/libdbus-1.so.3
#9 0x00007fa5df109781 in dbus_g_proxy_begin_call_internal (proxy=0x35b9740,
    method=<value optimized out>, notify=0x7fa5c2a5f060, user_data=0x3771760,
    destroy=0, args=<value optimized out>, timeout=-1) at dbus-gproxy.c:2207
#10 0x00007fa5df10ac82 in dbus_g_proxy_begin_call (proxy=0x35b9740,
    method=<value optimized out>, notify=<value optimized out>,
    user_data=<value optimized out>, destroy=<value optimized out>,
    first_arg_type=56334144) at dbus-gproxy.c:2453
#11 0x00007fa5c2a5f2ee in syncdaemon_filesystem_interface_get_metadata_async ()
   from /usr/lib/libsyncdaemon-1.0.so.1
#12 0x00007fa5c30d1370 in ?? ()
   from /usr/lib/nautilus/extensions-2.0/libnautilus-ubuntuone.so
#13 0x00000000004b7387 in ?? ()
---Type <return> to continue, or q <return> to quit---
#14 0x00000000004b3b36 in ?? ()
#15 0x00000000004b5e19 in ?? ()
#16 0x00007fa5e2f0ee55 in ?? () from /usr/lib/libgio-2.0.so.0
#17 0x00007fa5e2f2c7f8 in ?? () from /usr/lib/libgio-2.0.so.0
#18 0x00007fa5e1c72cb2 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#19 0x00007fa5e1c76c18 in ?? () from /lib/libglib-2.0.so.0
#20 0x00007fa5e1c77125 in g_main_loop_run () from /lib/libglib-2.0.so.0
#21 0x00007fa5e37fea47 in gtk_main () from /usr/lib/libgtk-x11-2.0.so.0
#22 0x0000000000442022 in ?? ()
#23 0x00007fa5e0877d8e in __libc_start_main (main=<value optimized out>,
    argc=<value optimized out>, ubp_av=<value optimized out>,
    init=<value optimized out>, fini=<value optimized out>,
    rtld_fini=<value optimized out>, stack_end=0x7fffe18246c8)
    at libc-start.c:226
#24 0x000000000042f0e9 in ?? ()
#25 0x00007fffe18246c8 in ?? ()
#26 0x000000000000001c in ?? ()
#27 0x0000000000000001 in ?? ()
#28 0x00007fffe1824b1a in ?? ()
#29 0x0000000000000000 in ?? ()
(gdb) q

Changed in ubuntuone-client:
assignee: nobody → Rodrigo Moya (rodrigo-moya)
status: Triaged → In Progress
tags: added: u1-maverick
tags: added: desktop+ nautilus
Changed in ubuntuone-client (Ubuntu Maverick):
status: New → Triaged
importance: Undecided → High
assignee: nobody → Rodrigo Moya (rodrigo-moya)
milestone: none → ubuntu-10.10
Rodrigo Moya (rodrigo-moya) wrote :

I really think this is a bug in libdbus, so Lucio, are you still getting this with latest maverick updates?

Lucio Torre (lucio.torre) wrote :
Download full text (3.5 KiB)

Loaded symbols for /usr/lib/pango/1.6.0/modules/pango-basic-fc.so
0x00007f6e227901e3 in __poll (fds=<value optimized out>,
    nfds=<value optimized out>, timeout=14100)
    at ../sysdeps/unix/sysv/linux/poll.c:87
87 ../sysdeps/unix/sysv/linux/poll.c: No such file or directory.
 in ../sysdeps/unix/sysv/linux/poll.c
(gdb) c
Continuing.
[New Thread 0x7f6dfa7fc710 (LWP 6405)]
[New Thread 0x7f6e1a60d710 (LWP 6406)]
[New Thread 0x7f6dfb7fe710 (LWP 6407)]
[New Thread 0x7f6df9ffb710 (LWP 6408)]

Program received signal SIGPIPE, Broken pipe.
0x00007f6e22794921 in __libc_writev (fd=31, vector=0x7fff2bd57cf0, count=2)
    at ../sysdeps/unix/sysv/linux/writev.c:56
56 ../sysdeps/unix/sysv/linux/writev.c: No such file or directory.
 in ../sysdeps/unix/sysv/linux/writev.c
(gdb) bt
#0 0x00007f6e22794921 in __libc_writev (fd=31, vector=0x7fff2bd57cf0, count=2)
    at ../sysdeps/unix/sysv/linux/writev.c:56
#1 0x00007f6e20d434d3 in ?? () from /lib/libdbus-1.so.3
#2 0x00007f6e20d3b29c in ?? () from /lib/libdbus-1.so.3
#3 0x00007f6e20d3b5a6 in ?? () from /lib/libdbus-1.so.3
#4 0x00007f6e20d3981d in ?? () from /lib/libdbus-1.so.3
#5 0x00007f6e20d25c7e in ?? () from /lib/libdbus-1.so.3
#6 0x00007f6e20d25d58 in ?? () from /lib/libdbus-1.so.3
#7 0x00007f6e20d272d0 in ?? () from /lib/libdbus-1.so.3
#8 0x00007f6e20d27461 in dbus_connection_send_with_reply ()
   from /lib/libdbus-1.so.3
#9 0x00007f6e20f66781 in dbus_g_proxy_begin_call_internal (proxy=0x125bf10,
    method=<value optimized out>, notify=0x7f6e048d5c00 <got_metadata_cb>,
    user_data=0x7f6e14077950, destroy=0, args=<value optimized out>,
    timeout=-1) at dbus-gproxy.c:2207
#10 0x00007f6e20f67c82 in dbus_g_proxy_begin_call (proxy=0x125bf10,
    method=<value optimized out>, notify=<value optimized out>,
    user_data=<value optimized out>, destroy=<value optimized out>,
    first_arg_type=19250960) at dbus-gproxy.c:2453
#11 0x00007f6e048d5e8e in syncdaemon_filesystem_interface_get_metadata_async (
    interface=0x19fa380,
    path=0x7f6e14077970 "/home/lucio/Music/0648. Neneh Cherry - Raw Like Sushi", with_subtree_sync_check=<value optimized out>,
---Type <return> to continue, or q <return> to quit---
    callback=0x7f6e04f45ed0 <ubuntuone_nautilus_update_meta>,
    user_data=0x1231990) at syncdaemon-filesystem-interface.c:170
#12 0x00007f6e04f464a0 in ubuntuone_nautilus_update_file_info (
    provider=<value optimized out>, file=0x7f6df40f3000,
    update_complete=<value optimized out>, handle=<value optimized out>)
    at ubuntuone-nautilus.c:267
#13 0x00000000004b7497 in ?? ()
#14 0x00000000004b3c46 in ?? ()
#15 0x00000000004b5f29 in ?? ()
#16 0x00007f6e24d6f345 in ?? () from /usr/lib/libgio-2.0.so.0
#17 0x00007f6e24d8dbb8 in ?? () from /usr/lib/libgio-2.0.so.0
#18 0x00007f6e23ad37e2 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#19 0x00007f6e23ad7748 in ?? () from /lib/libglib-2.0.so.0
#20 0x00007f6e23ad7c55 in g_main_loop_run () from /lib/libglib-2.0.so.0
#21 0x00007f6e2566da47 in gtk_main () from /usr/lib/libgtk-x11-2.0.so.0
#22 0x0000000000442132 in ?? ()
#23 0x00007f6e226d4d8e in __libc_start_main (main=<value optimized out>,
    argc=<value optimized out>, ubp_a...

Read more...

Changed in ubuntuone-client (Ubuntu Maverick):
status: Triaged → In Progress
Changed in ubuntuone-client (Ubuntu Maverick):
importance: High → Medium
dobey (dobey) on 2010-09-16
Changed in ubuntuone-client:
status: In Progress → Fix Committed
Changed in ubuntuone-client:
status: Fix Committed → In Progress
Kate Stewart (kate.stewart) wrote :

Priority was downgraded to medium by joshuahoover, since they weren't able to find many people affected, and it only seems to be happening in certain specific circumstances.

Changed in ubuntuone-client:
importance: Critical → Medium
Changed in ubuntuone-client (Ubuntu Maverick):
milestone: ubuntu-10.10 → maverick-updates
tags: added: u1-maverick-sru
removed: u1-maverick
Robbie Williamson (robbiew) wrote :

Release Note:

Ubuntu One
In certain specific circumstances, the Nautilus file manager may crash while trying to search folders sync'd by the Ubuntu One sync daemon.

Changed in ubuntu-release-notes:
status: New → Fix Released
Rodrigo Moya (rodrigo-moya) wrote :

Hopefully this should be fixed in trunk, so when possible, Lucio, could you try with trunk?

Changed in ubuntuone-client:
assignee: Rodrigo Moya (rodrigo-moya) → Ubuntu One Desktop+ team (ubuntuone-desktop+)
Changed in ubuntuone-client (Ubuntu):
assignee: Rodrigo Moya (rodrigo-moya) → Ubuntu One Desktop+ team (ubuntuone-desktop+)
Changed in ubuntuone-client (Ubuntu Maverick):
assignee: Rodrigo Moya (rodrigo-moya) → Ubuntu One Desktop+ team (ubuntuone-desktop+)
Natalia Bidart (nataliabidart) wrote :

Assigning to Lucio so he can confirm/deny this.

Changed in ubuntuone-client:
assignee: Ubuntu One Desktop+ team (ubuntuone-desktop+) → Lucio Torre (lucio.torre)
Lucio Torre (lucio.torre) wrote :

$ cd ubuntuone-client/trunk
$ bzr pull
$ make
$ sudo cp nautilus/.libs/libnautilus-ubuntuone.{a,la,so} /usr/lib/nautilus/extensions-2.0/ && killall nautilus
$ gnome-open ~/Music
<CRASH>

Changed in ubuntuone-client:
assignee: Lucio Torre (lucio.torre) → Ubuntu One Desktop+ team (ubuntuone-desktop+)
Changed in ubuntu-release-notes:
assignee: nobody → Pertuisière (pertuisiere-laposte)
assignee: Pertuisière (pertuisiere-laposte) → nobody
Natalia Bidart (nataliabidart) wrote :

Changing status to Confirmed again, since we have no way to reproduce and no clear fix to apply.

Changed in ubuntuone-client:
status: In Progress → Confirmed
Changed in ubuntuone-client (Ubuntu):
status: In Progress → Confirmed
Changed in ubuntuone-client (Ubuntu Maverick):
status: In Progress → Confirmed
Lucio Torre (lucio.torre) wrote :

(gdb) c
Continuing.
[New Thread 0x7f6acf117710 (LWP 8637)]
[New Thread 0x7f6ab3496710 (LWP 8638)]
[New Thread 0x7f6ab2c95710 (LWP 8639)]
[New Thread 0x7f6ab0c91710 (LWP 8640)]
[Thread 0x7f6ab0c91710 (LWP 8640) exited]
[Thread 0x7f6ab2c95710 (LWP 8639) exited]
[Thread 0x7f6ab3496710 (LWP 8638) exited]
[Thread 0x7f6ad016a710 (LWP 8577) exited]
[Thread 0x7f6acf117710 (LWP 8637) exited]

Program exited with code 01.
(gdb) bt
No stack.
(gdb)

briancb (brian-bosomworth) wrote :

This has happened to me when starting Ubuntu One I get multiple stating file manger across bottom panel

briancb (brian-bosomworth) wrote :

Thought you might want to know

Release 10.10
Kernel Linux 2.6.35-26-generic
GNOME 2.32.0

Processor dual core Intel E4600 @2.40GHz
Memory 2.0 Gig

Zburatorul (eugeniu) wrote :

Nautilus hangs for me when asking for folders (but also in other cases), at least on removable drives:

No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 10.10
Release: 10.10
Codename: maverick
Running on a Thinkpad x61 Tablet with an SSD drive, but the same problem existed before on the native HDD.

Adolfo Jayme (fitojb) on 2013-07-06
no longer affects: ubuntuone-client (Ubuntu Maverick)
Changed in ubuntuone-client:
status: Confirmed → Won't Fix
Changed in ubuntuone-client (Ubuntu):
status: Confirmed → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers