make distcheck fails in uninformative way when xutils-dev not installed

Bug #605978 reported by Rick McBride on 2010-07-15
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu One Client
Medium
dobey

Bug Description

when running 'make distcheck' after ./autogen.sh in the client source tree, I get:

make[3]: Entering directory `/home/rmcbride/canonical/ubuntuone-client/review.pf/ubuntuone-client-1.3.4/_build'
if test "x." != "x.."; then \
  /bin/mkdir -p ubuntuone; \
  /bin/mkdir -p tests; \
  (cd ubuntuone && false ../../ubuntuone > /dev/null); \
  (cd tests && false ../../tests > /dev/null); \
 fi
make[3]: *** [ubuntuone] Error 1

This is apparently due to xutils-dev not being installed on the affected system.

per discussion w/ Rodney in IRC, I'm writing this and assigning directly to him as he has thought of a solution to make the issue more obvious and discoverable at an earlier point in the process.

Related branches

Rick McBride (rmcbride) on 2010-07-15
Changed in ubuntuone-client:
assignee: nobody → Rodney Dawes (dobey)
dobey (dobey) on 2010-08-26
Changed in ubuntuone-client:
importance: Undecided → Medium
status: New → In Progress
dobey (dobey) on 2010-08-26
Changed in ubuntuone-client:
status: In Progress → Fix Committed
dobey (dobey) on 2010-09-08
Changed in ubuntuone-client:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers