Ubuntu One Preferences - "Got empty result for devices list."

Bug #576263 reported by Philip Taylor on 2010-05-06
108
This bug affects 17 people
Affects Status Importance Assigned to Milestone
Ubuntu One Client
Status tracked in Trunk
Stable-1-2
Medium
dobey
Trunk
Medium
dobey
ubuntuone-client (Ubuntu)
Medium
dobey
Lucid
Undecided
Unassigned

Bug Description

On launch of the ubuntu one preferences application,from the Me menu, i get the following error in a popup box a few seconds after the preferences is launched. And i cant connect my computer to my ubuntu one account.

"Got empty result for devices list."

------------------

WORK AROUND:
   1. Quit the Ubuntu One client (open a terminal window & run "u1sdtool -q; killall ubuntuone-login" without the quotes)
   2. Open Applications->Accessories->Passwords and Encryption Keys
   3. Click on the plus symbol next to "Passwords: login" to expand the list
   4. Right-click on the Ubuntu One token and select "Delete"
   5. Go to https://one.ubuntu.com/account/machines/
   6. Click on the checkbox next to your computer
   7. Click the "Remove selected computers" button
   8. Open System --> Preferences -->Ubuntu One
   9. a web page should open, prompting you to add your computer to your Ubuntu One account
  10. Add your computer

------------------

TEST CASE:

Need Ubuntu One setup on your computer and then:

1. Open https://one.ubuntu.com/account/machines
2. Select the check box next to your computer and click the "Remove selected computers" button
3. Open System->Preferences->Ubuntu One

Expected result: Ubuntu One Preferences opens and no error messages appear

------------------

Architecture: i386
DistroRelease: Ubuntu 10.04
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release i386 (20091028.5)
Package: ubuntuone-client 1.2.1-0ubuntu2
PackageArchitecture: all
ProcEnviron:
 LANG=en_GB.utf8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-21.32-generic 2.6.32.11+drm33.2
Tags: lucid
UbuntuOneClientConfig:
 [ubuntuone]
 connected = True
 connect = 0
 show_applet = 0
 bookmarked = True
UbuntuOneSyncdaemonExceptionsLog:
 2010-05-06 07:58:00,162 - ubuntuone.SyncDaemon.ActionQueue - ERROR - The request 'oauth_authenticate' failed with the error:

 AUTHENTICATION_FAILED
UbuntuOneUserSyncdaemonConfig:
 [bandwidth_throttling]
 read_limit = 2097152
 write_limit = 2097152
 on = False
Uname: Linux 2.6.32-21-generic i686
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare users

Related branches

apport information

tags: added: apport-collected
description: updated

apport information

apport information

apport information

i get the same "Got empty result for devices list"

If i go to accounts, i can see my computerlist completly empty ("You haven't added any computers or devices to your Ubuntu One account. To get started please visit the installation details.")... (cause i deleted all, cause there where more computers in there then i own...)

i tried adding my comp again by (https://wiki.ubuntu.com/UbuntuOne/FAQ#Account):
u1sdtool -q; killall ubuntuone-login; u1sdtool -c
but that would say it killed the process, but it would then do nothing... (still something is running though... but that didn't do anything for several minutes...)

also if i canceled and resubscribed my subscription... but the problem still remains...

there is also a weird ~/Documents map in there that i cannot delete... (i think i created this map when i shared both: "/home/phonixor/Ubuntu One/Documents" & "/home/phonixor/Documents")

Mitch Towner (kermiac) wrote :

I'm sorry to hear Ubuntu One is not working properly for you. Can you please try the following from a terminal window:

1. mv ~/.cache/desktop-couch/desktop-couchdb.pid ~/.cache/desktop-couch/desktop-couchdb.pid.old
2. killall ubuntuone-login ubuntuone-syncdaemon

Now launch ubuntuone-preferences again. If that does not resolve your issue, please attach your ubuntuone logs to this bug. Please zip your $HOME/.cache/ubuntuone/log/ folder and attach the zip here.

You can attach logs to this bug report by clicking the 'Add Attachment or patch' button at the bottom of the page. Thank you for filing this bug report and helping to make Ubuntu better.

Changed in ubuntuone-client:
status: New → Incomplete
Philip Taylor (scraliontis) wrote :

I tried the above, and as you said, if it doesnt work or i get the same result to post my ubuntu one logs, so thats what i have done.

Philip Taylor (scraliontis) wrote :

Can this bug please come to the attention of the right people. It is a rather large issue, and affects a few people. It has also been marked for expiration, so any more information needed to fix this bug, i am happy to provide.

Mitch Towner (kermiac) wrote :

I'm sorry to hear that did not resolve the issue. Can you try the following and let us know the results?

   1. Quit the Ubuntu One client (open a terminal window & run "u1sdtool -q; killall ubuntuone-login" without the quotes)
   2. Open Applications->Accessories->Passwords and Encryption Keys
   3. Click on the plus symbol next to "Passwords: login" to expand the list
   4. Right-click on the Ubuntu One token and select "Delete"
   5. Go to https://one.ubuntu.com/account/machines/
   6. Click on the checkbox next to your computer
   7. Click the "Remove selected computers" button
   8. Open System --> Preferences -->Ubuntu One
   9. a web page should open, prompting you to add your computer to your Ubuntu One account
  10. Add your computer

Thanks in advance!

Zel (matteo-delbo) wrote :

Yes! Work fine for me, thanks!

phonixor (phonixor) wrote :

mmmh this does allow me to add my computer again...

but it doesn't allow me to share new folders and stuff, and it only started to share files... that are located in my Ubuntu One folder... and not in my other shares....

this is most likely due to a ghost map " My Storage / ~/Documents " on the ubuntu one server :( which i cant remove...

guess i'll make a new bug for that one :(

Philip Taylor (scraliontis) wrote :

that also fixed it here Mitch, :)

Mitch Towner (kermiac) on 2010-05-12
description: updated
Mitch Towner (kermiac) on 2010-05-12
Changed in ubuntuone-client:
status: Incomplete → Confirmed
Mitch Towner (kermiac) on 2010-05-12
summary: - error on ubuntu one preferences launch
+ Ubuntu One Preferences - "Got empty result for devices list."
Changed in ubuntuone-client (Ubuntu):
status: New → Confirmed
Changed in ubuntuone-client:
status: Confirmed → In Progress
importance: Undecided → Medium
Changed in ubuntuone-client (Ubuntu):
importance: Undecided → Medium
assignee: nobody → Rodney Dawes (dobey)
Changed in ubuntuone-client:
assignee: nobody → Rodney Dawes (dobey)
tags: added: desktop+ u1-lucid-sru
Mynk (mr-mynk) wrote :

Faced the issue when I deleted the machine on the web interface hoping it will question me next time automatically. It didn't and there is no easy way to add. The steps on the following link helped -

http://ubuntuforums.org/showthread.php?t=1479755

dobey (dobey) on 2010-05-18
Changed in ubuntuone-client:
status: In Progress → Fix Committed
dobey (dobey) on 2010-05-27
Changed in ubuntuone-client (Ubuntu):
milestone: none → lucid-updates
description: updated

Accepted ubuntuone-client into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in ubuntuone-client (Ubuntu Lucid):
status: New → Fix Committed
tags: added: verification-needed
Joshua Hoover (joshuahoover) wrote :

Test case passed with 1.2.2-0ubuntu2 proposed installed.

Martin Pitt (pitti) wrote :

Since it was fixed in trunk a while ago, I assume that maverick's current version (1.3.2) has the fix as well. Closing all the maverick tasks.

tags: added: verification-done
removed: verification-needed
Changed in ubuntuone-client (Ubuntu):
status: Confirmed → Fix Released
Martin Pitt (pitti) wrote :

ubuntuone-client (1.2.2-0ubuntu1) lucid-proposed; urgency=low

  * New upstream release.
    - Properly handle valid UTF-8 non-ASCII names for UDFs (LP: #557160)
    - Fix nautilus crash when running u1sdtool --subscribe-folder (LP: #570261)
    - Cannot reactivate "File sync" on services tab (LP: #570721)
    - Retry interrupted uploads (LP: #575817)
    - Improve logging at INFO level (LP: #578248)
    - u1sdtool --delete-folder with invalid id hangs (LP: #583412)
    - ubuntuone-syncdaemon crashed with OSError (LP: #452682)
    - ubuntuone-preferences "Got empty result for devices list." (LP: #576263)
  * Rmmove fix-571548.patch and fix-567223.patch; included upstream now.
 -- Rodney Dawes <email address hidden> Wed, 16 Jun 2010 13:42:32 -0400

Changed in ubuntuone-client (Ubuntu Lucid):
status: Fix Committed → Fix Released
tags: added: testcase
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers