"File synchronization" option on "Services" tab can not be re-activated

Bug #570721 reported by Natalia Bidart on 2010-04-27
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Ubuntu One Client
Status tracked in Trunk
Stable-1-2
High
dobey
Trunk
High
dobey
ubuntuone-client (Ubuntu)
High
dobey
Lucid
Undecided
Unassigned

Bug Description

I opened ubuntuone-preferences and went to "Services" tab. There, I unchecked everything.

Last lines of syncdaemon log read (which makes sense):

2010-04-27 10:39:11,084 - ubuntuone.SyncDaemon.DBus - DEBUG - called set_files_sync_enabled 0
2010-04-27 10:39:11,085 - ubuntuone.SyncDaemon.DBus - DEBUG - Quit requested
2010-04-27 10:39:11,085 - ubuntuone.SyncDaemon.DBus - DEBUG - Calling Main.quit
2010-04-27 10:39:11,086 - ubuntuone.SyncDaemon.EQ - DEBUG - push_event: SYS_USER_DISCONNECT, args:(), kw:{}
2010-04-27 10:39:11,086 - ubuntuone.SyncDaemon.StateManager - DEBUG - received event 'SYS_USER_DISCONNECT'
2010-04-27 10:39:11,086 - ubuntuone.SyncDaemon.StateManager - DEBUG - sending event to ConnectionManager
2010-04-27 10:39:11,087 - ubuntuone.SyncDaemon.StateManager - DEBUG - ConnectionManager returned None
2010-04-27 10:39:11,556 - ubuntuone.SyncDaemon.HQ - INFO - HashQueue: _hasher stopped
2010-04-27 10:39:11,556 - ubuntuone.SyncDaemon.ConnectionManager - DEBUG - shutdown
2010-04-27 10:39:11,557 - ubuntuone.SyncDaemon.DBus - INFO - Shuttingdown DBusInterface!

I went back to the u1-preferences app, and clicked (checked) on File Synchronization again, but the app closed. After that, without closing the SD, I reopened the u1-preferences app in a terminal and I couldn't activate the File Synch in any way. The output from the console is:

Unhandled error in Deferred:
Traceback (most recent call last):
Failure: dbus.exceptions.DBusException: org.freedesktop.DBus.Error.NoReply: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

Attached 2 screenshot of what I'm describing.

--------------------------------------------------

TEST CASE:

1. Open System->Preferences->Ubuntu One
2. Click on the "Services" tab
3. Uncheck on all the check boxes
4. Click the "Close" button
5. Open System->Preferences->Ubuntu One
6. Click on the "Services" tab
7. Click on the "File Synchronization" check box

Result: Ubuntu One Preferences closes
Expected result: Ubuntu One Preferences stays open and file sync is enabled

--------------------------------------------------

Related branches

Natalia Bidart (nataliabidart) wrote :
summary: - File synchronization option on "Services" tab can not ne re-activated
+ "File synchronization" option on "Services" tab can not be re-activated
tags: added: desktop+
Natalia Bidart (nataliabidart) wrote :
Natalia Bidart (nataliabidart) wrote :

The trace thrown by ubuntuone-preferences when it crashes is:

nessita@dali:~$ ubuntuone-preferences
Traceback (most recent call last):
  File "/usr/bin/ubuntuone-preferences", line 805, in files_check_toggled
    self.__music_check_toggled(self.music_check)
AttributeError: 'UbuntuOneDialog' object has no attribute '_UbuntuOneDialog__music_check_toggled'
Traceback (most recent call last):
  File "/usr/bin/ubuntuone-preferences", line 805, in files_check_toggled
    self.__music_check_toggled(self.music_check)
AttributeError: 'UbuntuOneDialog' object has no attribute '_UbuntuOneDialog__music_check_toggled'
Traceback (most recent call last):
  File "/usr/bin/ubuntuone-preferences", line 805, in files_check_toggled
    self.__music_check_toggled(self.music_check)
AttributeError: 'UbuntuOneDialog' object has no attribute '_UbuntuOneDialog__music_check_toggled'
nessita@dali:~$

Changed in ubuntuone-client:
status: New → Confirmed
importance: Undecided → Medium
assignee: nobody → Ubuntu One Desktop+ team (ubuntuone-desktop+)
John Lenton (chipaca) on 2010-04-27
Changed in ubuntuone-client:
assignee: Ubuntu One Desktop+ team (ubuntuone-desktop+) → Rodney Dawes (dobey)
importance: Medium → High
status: Confirmed → Triaged
Natalia Bidart (nataliabidart) wrote :

Please note that when file_sync is disabled, ~/.config/ubuntuone/syncdaemon.conf shows:

[__main__]
files_sync_enabled = 0

And the code in ubuntuone/syncdaemon/tools.py set the option to True (instead of 1) when executing enable_files_sync. We should be consistent, I think. Either using 1 and 0 or True and False (not sure which one though).

dobey (dobey) on 2010-04-29
Changed in ubuntuone-client:
status: Triaged → In Progress
tags: added: u1-lucid-sru
dobey (dobey) on 2010-05-03
Changed in ubuntuone-client:
status: In Progress → Fix Committed
Changed in ubuntuone-client (Ubuntu):
status: New → In Progress
assignee: nobody → Rodney Dawes (dobey)
importance: Undecided → High
milestone: none → lucid-updates
status: In Progress → Triaged
description: updated

Accepted ubuntuone-client into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in ubuntuone-client (Ubuntu Lucid):
status: New → Fix Committed
tags: added: verification-needed
Joshua Hoover (joshuahoover) wrote :

Test case passed with 1.2.2-0ubuntu2 proposed installed.

Martin Pitt (pitti) wrote :

Since it was fixed in trunk a while ago, I assume that maverick's current version (1.3.2) has the fix as well. Closing all the maverick tasks.

tags: added: verification-done
removed: verification-needed
Changed in ubuntuone-client (Ubuntu):
status: Triaged → Fix Released
Martin Pitt (pitti) wrote :

ubuntuone-client (1.2.2-0ubuntu1) lucid-proposed; urgency=low

  * New upstream release.
    - Properly handle valid UTF-8 non-ASCII names for UDFs (LP: #557160)
    - Fix nautilus crash when running u1sdtool --subscribe-folder (LP: #570261)
    - Cannot reactivate "File sync" on services tab (LP: #570721)
    - Retry interrupted uploads (LP: #575817)
    - Improve logging at INFO level (LP: #578248)
    - u1sdtool --delete-folder with invalid id hangs (LP: #583412)
    - ubuntuone-syncdaemon crashed with OSError (LP: #452682)
    - ubuntuone-preferences "Got empty result for devices list." (LP: #576263)
  * Rmmove fix-571548.patch and fix-567223.patch; included upstream now.
 -- Rodney Dawes <email address hidden> Wed, 16 Jun 2010 13:42:32 -0400

Changed in ubuntuone-client (Ubuntu Lucid):
status: Fix Committed → Fix Released
tags: added: testcase
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers