Contact Picker - Clicking on a selected contact does not de-select it

Bug #563818 reported by John Lea on 2010-04-15
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu One Client
Undecided
Unassigned

Bug Description

Clicking on a selected contact does not de-select it. The correct behaviour is that if you left click on a selected contact it is de-selected. See variation 14.b in the spec, http://use-case-mapper.canonical.com/specifications/0AU5sFuLRpCpBZGZra2pqY2pfODY1Y2Ridmp6ZHc/use_cases/2_1

Rodrigo Moya (rodrigo-moya) wrote :

Again, this was changed from previous versions of the contacts picker to match the selection behavior in the rest of the desktop, where clicking on a selected item does not unselect it, because the contacts picker looked really out of place with a completely different selection mode.

So closing, as this is not a bug, it would be a bug to have a UI on the desktop behave differently than the rest of the desktop

Changed in ubuntuone-client:
status: New → Invalid
John Lea (johnlea) wrote :

Thanks for the feedback, I have gone back and spent some time reviewing the behaviour with the other interaction architects on the design team.

After consideration, we are all agreed that in this context the specified behaviour is correct. It fits with the other transient interactions that are under development like the dash and is a more intuitive and discoverable solution. However, there is no reason support for 'shift-clicking' cannot be retained and then we have the best of both behaviours ;-)

Summery: This bug is valid and requires resolution

John Lea (johnlea) on 2010-04-22
tags: removed: u1-lucid
Changed in ubuntuone-client:
status: Invalid → Confirmed

can arreter to send me your report of beugs because I registered has this
but I did not think that I reçevrais every day of the report by 100 ène
 you imagine, my reception limps of am full every day
 svp please arreter thank you
 very amicably
 tracking44

2010/4/22 John Lea <email address hidden>

> ** Tags removed: u1-lucid
>
> ** Changed in: ubuntuone-client
> Status: Invalid => Confirmed
>
> --
> Contact Picker - Clicking on a selected contact does not de-select it
> https://bugs.launchpad.net/bugs/563818
> You received this bug notification because you are subscribed to Ubuntu
> One Client.
>
> Status in Ubuntu One Client: Confirmed
>
> Bug description:
> Clicking on a selected contact does not de-select it. The correct
> behaviour is that if you left click on a selected contact it is de-selected.
> See variation 14.b in the spec,
> http://use-case-mapper.canonical.com/specifications/0AU5sFuLRpCpBZGZra2pqY2pfODY1Y2Ridmp6ZHc/use_cases/2_1
>
>
>

--
________________________________________
A Vaincre Sans Péril, On Triomphe Sans Gloire!

tags: added: contacts-picker
tags: added: desktop+
Rodrigo Moya (rodrigo-moya) wrote :

We are not changing the selection behavior for maverick, so closing

Changed in ubuntuone-client:
status: Confirmed → Won't Fix
John Lea (johnlea) on 2010-07-21
Changed in ubuntuone-client:
status: Won't Fix → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints