Contact Picker - Unable to select multiple contacts by clicking with the mouse

Bug #563765 reported by John Lea on 2010-04-15
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu One Client
Undecided
Unassigned

Bug Description

Unable to select multiple contacts by clicking with the mouse. For example if I want to select two contacts, the correct behaviour is to left click on the first contact to select it and then left click on the second contact to select it. Currently left clicking on the second contact deselects the first contact.

See step 12 of the primary scenario.

Rodrigo Moya (rodrigo-moya) wrote :

We agreed on using the same selection mechanism as the rest of the desktop, which is to use left-click for single selection and + shift for range selection, or + ctrl for individual selection of several contacts. That's how the contacts picker works, and making it behave differently than the rest of the desktop would make it look completely out of place. That's why we removed the double-click selection mode the first versions of the contacts picker had.

So closing, as this is not a bug

Changed in ubuntuone-client:
status: New → Invalid
John Lea (johnlea) wrote :

Thanks for the feedback, I have gone back and spent some time reviewing the behaviour with the other interaction architects on the design team.

After consideration, we are all agreed that in this context the specified behaviour is correct. It fits with the other transient interactions that are under development like the dash and is a more intuitive and discoverable solution. However, there is no reason support for 'shift-clicking' cannot be retained and then we have the best of both behaviours ;-)

Summery: This bug is valid and requires resolution

John Lea (johnlea) on 2010-04-22
tags: removed: u1-lucid
Changed in ubuntuone-client:
status: Invalid → Confirmed

stop please!

2010/4/22 John Lea <email address hidden>

> ** Tags removed: u1-lucid
>
> ** Changed in: ubuntuone-client
> Status: Invalid => Confirmed
>
> --
> Contact Picker - Unable to select multiple contacts by clicking with the
> mouse
> https://bugs.launchpad.net/bugs/563765
> You received this bug notification because you are subscribed to Ubuntu
> One Client.
>
> Status in Ubuntu One Client: Confirmed
>
> Bug description:
> Unable to select multiple contacts by clicking with the mouse. For example
> if I want to select two contacts, the correct behaviour is to left click on
> the first contact to select it and then left click on the second contact to
> select it. Currently left clicking on the second contact deselects the
> first contact.
>
> See step 12 of the primary scenario.
>
>
>

--
________________________________________
A Vaincre Sans Péril, On Triomphe Sans Gloire!

tags: added: contacts-picker
tags: added: desktop+
Rodrigo Moya (rodrigo-moya) wrote :

We are not changing the selection behavior for maverick, so closing

Changed in ubuntuone-client:
status: Confirmed → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints