ubuntuone-syncdaemon crashed with ImportError in <module>()

Bug #561447 reported by Facundo Batista on 2010-04-12
24
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Ubuntu One Client
High
Rick McBride

Bug Description

The crash is:

$ /usr/lib/ubuntuone-client/ubuntuone-syncdaemon
Traceback (most recent call last):
  File "/usr/lib/ubuntuone-client/ubuntuone-syncdaemon", line 33, in <module>
    from ubuntuone.syncdaemon import dbus_interface, logger, config
  File "/usr/lib/python2.6/dist-packages/ubuntuone/syncdaemon/logger.py", line 27, in <module>
    from ubuntuone.logger import (
ImportError: No module named logger

And there's no logger module in /usr/lib/python2.6/dist-packages/ubuntuone.

ProblemType: Crash
DistroRelease: Ubuntu 10.04
Package: ubuntuone-client 1.1.91+r479-0ubuntu1~ppa1~lucid
ProcVersionSignature: Ubuntu 2.6.32-19.28-generic-pae 2.6.32.10+drm33.1
Uname: Linux 2.6.32-19-generic-pae i686
NonfreeKernelModules: nvidia
Architecture: i386
CrashDB: ubuntuone
Date: Mon Apr 12 09:39:12 2010
ExecutablePath: /usr/lib/ubuntuone-client/ubuntuone-syncdaemon
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release i386 (20091028.5)
InterpreterPath: /usr/bin/python2.6
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/lib/ubuntuone-client/ubuntuone-syncdaemon
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, user)
 LANG=es_AR.UTF-8
PythonArgs: ['/usr/lib/ubuntuone-client/ubuntuone-syncdaemon']
SourcePackage: ubuntuone-client
ThirdParty: True
Title: ubuntuone-syncdaemon crashed with ImportError in <module>()
UbuntuOneClientConfig:
 [ubuntuone]
 bookmarked = True
 connected = True
 connect = 0
 show_applet = 1
UserGroups: adm admin cdrom dialout libvirtd lpadmin plugdev sambashare

Facundo Batista (facundo) wrote :
visibility: private → public
Rick McBride (rmcbride) wrote :

OK the logger.py in ubuntuone/ is being imported from by the one in ubuntuone/syncdaemon. Problem: this has been added since the lucid trunk was last updated. Since nightlies currently pull the debian/ info from that location, this causes the nightly packages to fail to install the new file.

I'm going to need to confer w/ Rodney regarding the best course of action here. Probably need to do a new branch for packaging for nightlies or something. Should be a simple fix getting the file to install, but the actual implementation is not going to be quick.

Rick McBride (rmcbride) on 2010-04-12
Changed in ubuntuone-client:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers