Sharing using the contacts picker doesn't work

Bug #554269 reported by Joshua Hoover on 2010-04-02
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu One Client
High
Rodrigo Moya
ubuntuone-client (Ubuntu)
High
Ubuntu One Client Engineering team
Lucid
High
Ubuntu One Client Engineering team

Bug Description

Sharing doesn't appear to work on Lucid with all the latest updates as of 2010-04-02 with ubuntuone-client 1.1.90-0ubuntu1. Can select contacts to share with but they never show up in

Steps to reproduce:

  1. Click Places -> Home Folder
  2. Double-click Ubuntu One folder
  3. Right-click Test Share folder and select Share on Ubuntu One
  4. Click on contact to share with
  5. Click Share button
  6. Open Applications -> Internet -> Firefox Web Browser
  7. Enter https://one.ubuntu.com/files in Firefox URL field
  8. In Firefox, click on arrow next to My Files
  9. Click on Test Share
10. Click on the Sharing link

Result: "This Folder is not shared." displays in web UI for folder's "Sharing" info

Expected result: Folder shared with contact selected in step 4

Related branches

John O'Brien (jdobrien) on 2010-04-02
summary: - Sharing doesn't work
+ Sharing using the contacts picker doesn't work
John O'Brien (jdobrien) wrote :

In order for this to work as you're expecting it to, there would have to be some kind of association between your contact and an Ubuntu One user.

BTW, When I try this, the contact picker pops up and then disappears. Maybe because I have 180+ contacts?
There are no log files in ./cache/ubuntuone/logs

Changed in ubuntuone-client:
status: Confirmed → In Progress
tags: added: lucid
Changed in ubuntuone-client (Ubuntu):
status: New → Confirmed
assignee: nobody → Ubuntu One Desktop+ team (ubuntuone-desktop+)
tags: added: package
Changed in ubuntuone-client (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → High
Changed in ubuntuone-client:
status: In Progress → Fix Committed
Changed in ubuntuone-client:
assignee: Ubuntu One Desktop+ team (ubuntuone-desktop+) → Rodrigo Moya (rodrigo-moya)
Changed in ubuntuone-client (Ubuntu):
milestone: none → ubuntu-10.04
Changed in ubuntuone-client:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntuone-client - 1.2.0-0ubuntu1

---------------
ubuntuone-client (1.2.0-0ubuntu1) lucid; urgency=low

  * New upstream release.
    - TypeError: set_files_sync_enabled takes 2 arguments (LP: #555747)
    - Preferences menu icon is broken (LP: #561557)
    - u1sdtool --list-folders doesn't match Nautilus (LP: #547087)
    - AttributeError when receiving ShareChanged message (LP: #553547)
    - Sharing using contacts picker doesn't work (LP: #554269)
    - Silently fails to sync folder outside $HOME (LP: #554522)
    - Need to get public files list at start (LP: #556529)
    - Syncdaemon does local resan on unsubscribed folders (LP: #561713)
    - Start desktopcouch-service when authorizing (LP: #562618)
    - Errors not handled correctly (LP: #476635)
    - Switching sort order in contacts picker clears selection (LP: #551603)
    - Nautilus crashed with SIGSEGV in g_str_hash (LP: #561481)
    - DBus interface not showing full queue (LP: #557670)
    - Client does not handle TRY_AGAIN during Auth (LP: #522604)
  * Include the new logger.py in the python package. (LP: #561447)
  * Require new python-ubuntuone-storageporotocol.

  [Ken VanDine]
  * debian/patches/revert_string_change.patch
    - Revert a string change that landed to late
  * debian/rules
    - include simple-patchsys.mk
 -- Rodney Dawes <email address hidden> Thu, 15 Apr 2010 11:21:17 -0400

Changed in ubuntuone-client (Ubuntu Lucid):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers