ubuntuone-login errors after retrieving valid token

Bug #552124 reported by Joshua Hoover on 2010-03-30
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Ubuntu One Client
Medium
Ubuntu One Client Engineering team

Bug Description

Note: The error of ubuntuone-preferences not opening is fixed in dobey's branch (https://code.edge.launchpad.net/~dobey/ubuntuone-client/devices-remove-local) but there continues to be an error related to ubuntuone-login thinking it didn't receive a valid ubuntuone token.

STEPS TO REPRODUCE:
Running ubuntuone-client 1.1.4-0ubuntu1 or trunk r460 without an ubuntuone token in the keyring

1. Open System->Preferences->Ubuntu One
2. Add this computer when prompted via web page
3. Token received, taken to https://one.ubuntu.com/files
4. Applications->Accessories->Passwords and Encryption Keys shows an ubuntuone token

Result: An error window pops up for less than a second and ~/.cache/ubuntuone/log/oauth-login.log contains the following:

2010-03-30 17:01:40,262:262.506961823 ubuntuone-login Starting Ubuntu One login manager version 1.1.4
2010-03-30 17:02:12,693:693.270921707 UbuntuOne.OAuthDesktop.auth Token was not successfully retrieved: data was 'Invalid request token: XzhpRlC8bz3PQkLJqhJ7'
2010-03-30 17:02:12,696:696.908950806 UbuntuOne.OAuthDesktop.auth Failed to get access token.

Joshua Hoover (joshuahoover) wrote :

Marked invalid since the notes web UI is no longer supported.

Changed in ubuntuone-client:
status: Confirmed → Invalid
Joshua Hoover (joshuahoover) wrote :

Crazy script marked this bug as invalid. Who wrote that thing? Oh wait...

Changed in ubuntuone-client:
status: Invalid → New
Rick McBride (rmcbride) on 2012-03-06
Changed in ubuntuone-client:
status: New → Triaged
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers