Remove "Share Name" and "Allow Modification" fields from the Contact Picker

Bug #551045 reported by John Lea on 2010-03-29
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu One Client
Undecided
Rodrigo Moya

Bug Description

Remove "Share Name" and "Allow Modification" fields from the Contact Picker, see https://docs.google.com/a/canonical.com/Doc?docid=0AU5sFuLRpCpBZGZra2pqY2pfODY1Y2Ridmp6ZHc&hl=en_GB

John Lea (johnlea) on 2010-03-29
tags: added: gloam u1-lucid
Changed in ubuntuone-client:
assignee: nobody → Rodrigo Moya (rodrigo-moya)
John Lenton (chipaca) wrote :

The spec you linked is rather big, and also not public. Could you point to something more specific and available?

Changed in ubuntuone-client:
status: New → Incomplete
assignee: Rodrigo Moya (rodrigo-moya) → nobody
John Lea (johnlea) wrote :

 The spec is available publicly at http://docs.google.com/View?id=dfkkjjcj_260fxp2jmf6. There is no specific use case I can point you to as both "Share Name" and "Allow Modification" fields are not in the spec.

Changed in ubuntuone-client:
status: Incomplete → New
assignee: nobody → Rodrigo Moya (rodrigo-moya)
tags: added: u1-maverick
removed: u1-lucid
Rodrigo Moya (rodrigo-moya) wrote :

I agree on 'Share name', we should just use the same name the folder has, but why remove 'Allow modification'?

John Lenton (chipaca) wrote :

not sure the rationale behind removing 'share name', but it does make things simpler (although the feature is useful). The removal of 'allow modification' is wrong and underspecified.

Changed in ubuntuone-client:
status: New → Invalid
John Lenton (chipaca) on 2010-04-14
Changed in ubuntuone-client:
assignee: Rodrigo Moya (rodrigo-moya) → nobody
John Lea (johnlea) wrote :

Regarding the removal of 'allow modifications' - this function adds un-necessary complexity to the share interaction architecture and should be removed. See the share specification (in particular the introduction), https://docs.google.com/a/canonical.com/Doc?docid=0AU5sFuLRpCpBZGZra2pqY2pfNDIxZjdkZnM5ZGo&hl=en_GB.

The 'share name' field is also superfluous; we can simply take the name of the folder being shared.

Changed in ubuntuone-client:
status: Invalid → Confirmed
John Lea (johnlea) wrote :

Further conformation that this simplification is a good idea: I was just doing some Ubuntu One user testing on Stephanie Murphy and she was completely puzzled as to why she sometimes couldn't create a folder inside a folder that was shared with her. The reason was that it had been shared without 'allow modification' being ticked. This option creates confusion without giving any benefit. If you want to share something with somebody without them being able to edit it you can use the 'publish' which is designed for exactly this purpose.

On Thu, Apr 15, 2010 at 12:07 PM, John Lea <email address hidden> wrote:
> Further conformation that this simplification is a good idea:  I was
> just doing some Ubuntu One user testing on Stephanie Murphy and she was
> completely puzzled as to why she sometimes couldn't create a folder
> inside a folder that was shared with her.  The reason was that it had
> been shared without 'allow modification' being ticked.  This option
> creates confusion without giving any benefit.  If you want to share
> something with somebody without them being able to edit it you can use
> the 'publish' which is designed for exactly this purpose.

Publish does not download those files to their desktop and only works
on files. It's a world of a difference.

tags: added: contacts-picker
tags: added: desktop+
Changed in ubuntuone-client:
assignee: nobody → Rodrigo Moya (rodrigo-moya)
status: Confirmed → In Progress
Rodrigo Moya (rodrigo-moya) wrote :

Available in u1-client 1.3.4

Changed in ubuntuone-client:
status: In Progress → Fix Released
John Lea (johnlea) on 2010-07-20
description: updated
John Lenton (chipaca) wrote :

Until we can publish folders, we need this functionality to be exposed. If and when we have folder publishing we can reopen this discussion.

Joshua Hoover (joshuahoover) wrote :

John Lenton talked to Martin Albisetti about this and they think we should default the checkbox to enable read/write and the web should match this behavior.

Joshua Hoover (joshuahoover) wrote :

Passed in ubuntuone-client 1.3.6+r614-0ubuntu1~ppa1~maverick. The behavior is now to default to allow modification which is what it does.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints