u1sdtool --list-folders list doesn't match Nautilus right-click options

Bug #547087 reported by Matt Griffin on 2010-03-25
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Ubuntu One Client
High
dobey
ubuntuone-client (Ubuntu)
High
dobey
Lucid
High
dobey

Bug Description

u1sdtool --list-folders shows a folder that is set to synchronize. When I right-click on that folder in Nautilus, it still gives me the option to synchronize on Ubuntu One. It eventually changes to be correct (showing stop synchronizing on ubuntu one) but takes a long time.

It seems like it should be working like this:
1. Right-click on a folder to synchronize it
2. Emblem changes to synchronization in progress. Running u1sdtool --list-folders shows added folder.
3. Right-click menu option changed to stop syncing
4. Folder sync completed
5. Emblem changed to sync completed

And changing the emblem and the Nautilus right-click options should take precedence over existing synchronization processes because users need immediate feedback on this action.

Related branches

John Lenton (chipaca) on 2010-03-25
tags: added: desktop+ u1-lucid
Changed in ubuntuone-client:
assignee: nobody → Rodney Dawes (dobey)
importance: Undecided → Medium
description: updated
Tom Haddon (mthaddon) wrote :

How long did it take for this to "eventually" synchronize? I tried to synchronise a folder using the Nautilus right-click option last night, and it's still not showing as pending or synchronising.

John Lenton (chipaca) wrote :

I think this is the same as the #556529. Or another facet of it.

John Lenton (chipaca) wrote :

That is bug 556529.

dobey (dobey) wrote :

These 2 bugs are not duplicates. This is a separate issue, with the UDFs list, which we can get already at start.

John Lenton (chipaca) on 2010-04-07
Changed in ubuntuone-client:
importance: Medium → High
tags: added: package
Changed in ubuntuone-client:
status: New → Confirmed
Changed in ubuntuone-client (Ubuntu):
status: New → Confirmed
importance: Undecided → High
assignee: nobody → Rodney Dawes (dobey)
Changed in ubuntuone-client:
milestone: none → later
milestone: later → lucid-final
Changed in ubuntuone-client:
status: Confirmed → Triaged
Changed in ubuntuone-client (Ubuntu):
status: Confirmed → Triaged
milestone: none → ubuntu-10.04
dobey (dobey) on 2010-04-09
Changed in ubuntuone-client:
status: Triaged → In Progress
Changed in ubuntuone-client (Ubuntu Lucid):
status: Triaged → In Progress
dobey (dobey) on 2010-04-12
Changed in ubuntuone-client:
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntuone-client - 1.2.0-0ubuntu1

---------------
ubuntuone-client (1.2.0-0ubuntu1) lucid; urgency=low

  * New upstream release.
    - TypeError: set_files_sync_enabled takes 2 arguments (LP: #555747)
    - Preferences menu icon is broken (LP: #561557)
    - u1sdtool --list-folders doesn't match Nautilus (LP: #547087)
    - AttributeError when receiving ShareChanged message (LP: #553547)
    - Sharing using contacts picker doesn't work (LP: #554269)
    - Silently fails to sync folder outside $HOME (LP: #554522)
    - Need to get public files list at start (LP: #556529)
    - Syncdaemon does local resan on unsubscribed folders (LP: #561713)
    - Start desktopcouch-service when authorizing (LP: #562618)
    - Errors not handled correctly (LP: #476635)
    - Switching sort order in contacts picker clears selection (LP: #551603)
    - Nautilus crashed with SIGSEGV in g_str_hash (LP: #561481)
    - DBus interface not showing full queue (LP: #557670)
    - Client does not handle TRY_AGAIN during Auth (LP: #522604)
  * Include the new logger.py in the python package. (LP: #561447)
  * Require new python-ubuntuone-storageporotocol.

  [Ken VanDine]
  * debian/patches/revert_string_change.patch
    - Revert a string change that landed to late
  * debian/rules
    - include simple-patchsys.mk
 -- Rodney Dawes <email address hidden> Thu, 15 Apr 2010 11:21:17 -0400

Changed in ubuntuone-client (Ubuntu Lucid):
status: In Progress → Fix Released
dobey (dobey) on 2010-04-19
Changed in ubuntuone-client:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers