[Freeze Exception] ubuntuone-client: Syncdaemon needs to auto-start/connect in Lucid

Bug #534707 reported by Joshua Hoover on 2010-03-08
58
This bug affects 9 people
Affects Status Importance Assigned to Milestone
Ubuntu One Client
High
John Lenton
ubuntuone-client (Ubuntu)
Medium
John Lenton

Bug Description

Prior to the replacement of the ubuntuone-client-applet with ubuntuone-preferences there was functionality for syncdaemon to auto-start/connect. We need to put that functionality back in so that file sync functions properly.

Since syncdaemon does not auto-start features like user defined folders do not work as a user expects when syncdaemon is not started.

TEST CASE

1. Boot/login to Ubuntu
2. Open Places->Home
3. Right-click on the Documents folder and select "Synchronize on Ubuntu One"
4. Open a terminal sesssion and run: u1sdtool --list-folders

Result: ~/Documents is not listed
Expected result: ~/Documents is listed

Related branches

Roman Yepishev (rye) wrote :

I would like to say that the issue is that syncdaemon is not started automatically in Lucid. Manual startup is required via preferences dialog and I can't find how should be handled in Lucid in our wiki.

summary: - Syncdaemon does not auto-connect in Lucid
+ Syncdaemon does not auto-start in Lucid
description: updated
Changed in ubuntuone-client (Ubuntu):
status: New → Confirmed
assignee: nobody → Ubuntu One Desktop+ team (ubuntuone-desktop+)
tags: added: mir
summary: - Syncdaemon does not auto-start in Lucid
+ MIR: Syncdaemon needs to auto-start/connect in Lucid
summary: - MIR: Syncdaemon needs to auto-start/connect in Lucid
+ [MIR] ubuntuone-client: Syncdaemon needs to auto-start/connect in Lucid
description: updated
summary: - [MIR] ubuntuone-client: Syncdaemon needs to auto-start/connect in Lucid
+ [FFE] ubuntuone-client: Syncdaemon needs to auto-start/connect in Lucid
tags: added: ffe
removed: mir
tags: added: freeze-exception
removed: ffe
summary: - [FFE] ubuntuone-client: Syncdaemon needs to auto-start/connect in Lucid
+ [Freeze Exception] ubuntuone-client: Syncdaemon needs to auto-
+ start/connect in Lucid
description: updated
Changed in ubuntuone-client (Ubuntu):
milestone: none → ubuntu-10.04-beta-2
importance: Undecided → Medium
Steve Langasek (vorlon) wrote :

From the description, I would say this is a bugfix and doesn't require an FFe at all. Am I missing something?

John Lenton (chipaca) wrote :

Hi Steve!

Yes, it's a bug, a regression from ubuntuone-client in 9.10. However, the way we need to fix it is *probably* (we aren't working on this issue yet) with a small script that is started at session startup, not a fix to existing binaries. That felt like a FFe-needing feature more than a simple bugfix to us, which is why we're asking for one. If you'd rather wait until we had the code done, so we actually knew whether this is needed, no problem!

tags: added: package
Steve Langasek (vorlon) wrote :

Assuming the script is straightforward, I'm happy to have this go in without needing explicit release team review / exception.

Martin Pitt (pitti) wrote :

What was wrong with the karmic approach of dropping an autostart .desktop file into ~/.config/autostart ?

Martin Pitt (pitti) wrote :

Please also note that the .desktop file should have X-GNOME-Autostart-Delay=30 (or so) to avoid having this solid 15 s CPU block slowing down the desktop start.

Thanks!

Changed in ubuntuone-client:
assignee: Ubuntu One Desktop+ team (ubuntuone-desktop+) → John Lenton (chipaca)
Changed in ubuntuone-client (Ubuntu):
assignee: Ubuntu One Desktop+ team (ubuntuone-desktop+) → John Lenton (chipaca)
Changed in ubuntuone-client:
milestone: none → lucid-beta-2
John Lenton (chipaca) on 2010-03-30
Changed in ubuntuone-client:
status: Confirmed → In Progress
Martin Pitt (pitti) wrote :

So, how do you want to start the service now?

John Lenton (chipaca) wrote :

As soon as the linked branch lands in ubuntuone-client trunk (it's being reviewd now), we'll have a .desktop file that looks like
[Desktop Entry]
Name=Ubuntu One
Exec=ubuntuone-launch
Type=Application
X-GNOME-Autostart-Delay=30

ubuntuone-launch is a python script that has a series of increasingly more expensive tests to decide whether to start and connect the syncdaemon or not. The first test is for the existence of the Ubuntu One directory, which should be bail out early for most users.

Martin Pitt (pitti) wrote :

That .desktop file is installed into ~/.local if you enable U1 the first time? (Please don't introduce a python program into the startup sequence for everyone by shipping it statically in /etc/xdg/autostart)

Or, if you do, please move the directory test into the desktop file itself, instead of firing up python. Like

Exec=/bin/sh -c '[ -d "$HOME/Ubuntu One" ] && ubuntuone-launch'

On Wed, Mar 31, 2010 at 04:45:37PM -0000, Martin Pitt wrote:
> That .desktop file is installed into ~/.local if you enable U1 the first
> time? (Please don't introduce a python program into the startup sequence
> for everyone by shipping it statically in /etc/xdg/autostart)
>
> Or, if you do, please move the directory test into the desktop file
> itself, instead of firing up python. Like
>
> Exec=/bin/sh -c '[ -d "$HOME/Ubuntu One" ] && ubuntuone-launch'

OK, done. The latter, that is.

I'm not sure how much better it is; there already are some python
scripts in the startup, so python itself will be cached in memory, and
if the directory doesn't exist the only modules used (os and sys) will
have been loaded before also. And this is 30 seconds after everything
else has started, with the difference between the sh version and the
python version clocking in at 1ms versus 10ms on my machine. So... not
sure how much better it is, and I could argue that it's worse, but
I've implemented it because I think it's a reasonable middle ground,
and the freeze clock is ticking.

Thank you for your enduring patience and your constructive
suggestions.

dobey (dobey) wrote :

I don't know what the rationale for the 30 second delay is. It's a very long time to wait. And if the initial directory check is moving outside the script to the .desktop file itself, should we even still have the delay? Or at least decrease it to 5 or 10 seconds at most?

John Lenton (chipaca) on 2010-03-31
Changed in ubuntuone-client:
status: In Progress → Fix Committed
Steve Langasek (vorlon) wrote :

With the directory test change, I think Martin's concerns are addressed; FFe granted.

(The 30 second delay is to ensure that ubuntuone doesn't start until the rest of the desktop is fully up, even on machines slower than the hardware we target for 10-second boot.)

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntuone-client - 1.1.90-0ubuntu1

---------------
ubuntuone-client (1.1.90-0ubuntu1) lucid; urgency=low

  * New upstream release.
    - Notify user when approaching and exceeding quota (LP: #540360)
    - Add instructional text to ubuntuone-preferences (LP: #539676)
    - UbuntuOne needs to autostart and connect by defualt (LP: #534707)
    - Impossible to infer status of file synchronization (LP: #526084)
    - Devices and Services tabs functionality and development (LP: #525803)
  * Add debian/source/format.
  * Remove python-httplib2 from the dependencies (LP: #535207)
 -- Rodney Dawes <email address hidden> Wed, 31 Mar 2010 19:47:01 -0400

Changed in ubuntuone-client (Ubuntu):
status: Confirmed → Fix Released
Martin Pitt (pitti) wrote :

Rodney Dawes [2010-03-31 17:59 -0000]:
> I don't know what the rationale for the 30 second delay is. It's a very
> long time to wait

The sync daemon process takes the full CPU for some 20 seconds
usually. If you do this while the desktop is still starting up, the
desktop startup will slow to a crawl.

Sergei Vorobyov (svorobyov) wrote :

Greetings!

Despite all efforts U1 is still incapable of doing anything useful.
When I am trying to connect and syncronize two boxes, with 10.04b2 and 9.10
from within the same LAN behind the firewall (only accepting ssh thru port 22)
9.10 shows the following.

Add this computer to your Ubuntu One account?

Yes

Oops! Firefox could not connect to localhost:42622

Besides,

1. even before I started to sign in the "Sync with Ubuntu One" popup appeared.
    Why? With whose account?

2. the .../files web page does not show the contents of my Ubuntu One directory and
    I cannot be sure whether the files have been uploaded or not

3. I cannot enforce syncing by right-clicking on the "Ubuntu One" folder

4. Nothing (apparently) happens if I do it (syncronize on U1) for another folder

Sergei Vorobyov (svorobyov) wrote :

Tomboy notes do not syncronize neither (from 10.04b2) "you have no notes (yet!)", there's no
apparent way to force the sync.

Sergei Vorobyov (svorobyov) wrote :

Sorry, I did not notice the pop-up (hidden behind another window) saying
"Error connecting :( sorry but something went wrong. Please check and try again
the /home/sergei/.config/tomboy/tomboy.log might be useful too"

The latter file says only:

date [INFO:] Initializing Mono.Addins

Sergei Vorobyov (svorobyov) wrote :

After I have installed 10.04b1 on the 3rd computer (now I have 2 such boxes), I finally succeeded to syncronize
both ~/Ubuntu One and Tomboy Notes. This requires, however, too many adjustments (Connect, Tomboy preferences edit),
and there's no indication that your sync has finished (imagine you want to switch off or disconnect), except
going to the U1 web site.

Right-clicking on a folder and selecting "Sync on U1" makes no effect, contrary to what one expects: the folder does not appear on U1. File uploading through the web interface does not work neither.

Too much ado about nothing: after all, all this U1 amounts to just one rsync put into crontab.
I have much more cloud functionality (and reliability) making syncs with one of my university servers
and/or my home server (now everyone can afford one).

dobey (dobey) wrote :

On Thu, 2010-04-01 at 06:33 +0000, Martin Pitt wrote:
> Rodney Dawes [2010-03-31 17:59 -0000]:
> > I don't know what the rationale for the 30 second delay is. It's a very
> > long time to wait
>
> The sync daemon process takes the full CPU for some 20 seconds
> usually. If you do this while the desktop is still starting up, the
> desktop startup will slow to a crawl.

But it's already taking GNOME 30 seconds to start up?

LGB [Gábor Lénárt] (lgb) wrote :

This wait "30 secs" or wait "X secs" because various reasons reminds me the issue with SysV init which was replaced by upstart. Soon do we need something similar solution for launching desktop components too? With the side goal to try to maximize the disk I/O to a level at some point so users won't get a system which impossible to use because of heavy IO, that's was the purpose of delaying the start of some services afaik, but fixed times to wait with several stuffs hmmmmmmm.

Steve Langasek (vorlon) wrote :

unsubscribing ubuntu-release since the FFe task has been completed - I'm not sure if the upstream task should be considered fixed or not, else I would close it

John Lenton (chipaca) on 2010-04-05
Changed in ubuntuone-client:
status: Fix Committed → Fix Released
Martin Pitt (pitti) wrote :

Rodney Dawes [2010-04-01 19:58 -0000]:
> But it's already taking GNOME 30 seconds to start up?

I have the slowest disk on earth, and GNOME itself starts in 8 seconds
now (in lucid):

http://people.canonical.com/~pitti/bootcharts/tick-lucid-20100329-1.png

On the Dell Mini 10 (with an utterly slow CPU), GNOME takes 10 s:

http://people.canonical.com/~scott/daily-bootcharts/

So 30 s should be more than enough for everything to settle down, and
the user to start opening apps, until ubuntuone,
system-config-printer, etc. start grinding.

Martin
--
Martin Pitt | http://www.piware.de
Ubuntu Developer (www.ubuntu.com) | Debian Developer (www.debian.org)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers