Ubuntu One FATAL ERROR, IndexError: list index out of range

Bug #533277 reported by Damien Willis on 2010-03-06
This bug affects 15 people
Affects Status Importance Assigned to Milestone
Ubuntu One Client
Ubuntu One Client Engineering team
ubuntuone-client (Ubuntu)

Bug Description

Binary package hint: ubuntuone-client

Ubuntu 9.10
ubuntuone-client version: 1.0.3-0ubuntu1
Expected UbuntuOne client to connect.
Received a fatal error and requested to report the bug

Events required to encounter the bug:
1. start Ubuntu One
2. Error message appears

This happens both then Ubuntu One is started at bootup and from the Applications-->Internet-->UbuntuOne menu selection.

ProblemType: Bug
 on = False
 read_limit = 0
 write_limit = 0
 connected = True
 connect = 0
 show_applet = 1
 bookmarked = True
Architecture: amd64
Date: Sat Mar 6 22:59:19 2010
DistroRelease: Ubuntu 9.10
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release amd64 (20091027)
NonfreeKernelModules: fglrx
Package: ubuntuone-client 1.0.3-0ubuntu1
PackageArchitecture: all
ProcVersionSignature: Ubuntu 2.6.31-19.56-generic
SourcePackage: ubuntuone-client
Uname: Linux 2.6.31-19-generic x86_64

Damien Willis (turion-wolfeyes) wrote :

Hi there,

Thanks for helping to make Ubuntu better!

I'm just checking in to see if you were still having this error -- and if it was reproducable? If so, can you details steps which will help in diagnosing the problem?

Changed in ubuntuone-client (Ubuntu):
status: New → Incomplete
Damien Willis (turion-wolfeyes) wrote :

I am still having this error.
It is reproducable. All I hgave to do is start Ubuntu One and the error occurs, (the clous icon appears in the system tray, then it switches to the exclamation mark with arrows around it, and I am told "There was a fatal error in Ubuntu One This may be a bug in the software. Please click on the Ubuntu One icon in your panel to report the bug").
The same error occurs when Ubuntu One is in the startup list and the system boots.
I have tried completely removing Ubuntu One, even removing the association with my Ubuntu One account. When I then reinstall Ubuntu One and associate my Ubuntu One account with the software, the bug reappears.
I hope that helps.

-- Damien

Mekan Guldurdiyev (g-mekan) wrote :

Ubuntu one was connected and when I click "disconnect" it said "fatal crash" detected.

mwibral (michael-wibral) wrote :

I got the error after the system has worked well for ~5 days (with reboots). The error appears after pressing the connect button in the system tray.
Running KDE4.


summary: - Ubuntu One FATAL ERROR
+ Ubuntu One FATAL ERROR, IndexError: list index out of range
Changed in ubuntuone-client (Ubuntu):
status: Incomplete → New
tags: added: client desktop+
Changed in ubuntuone-client:
assignee: nobody → Ubuntu One Desktop+ team (ubuntuone-desktop+)
Rick McBride (rmcbride) on 2011-02-11
Changed in ubuntuone-client:
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntuone-client (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers