Support for maemo (Nokia n900)

Bug #512052 reported by Ketil Wendelbo Aanensen on 2010-01-24
806
This bug affects 177 people
Affects Status Importance Assigned to Milestone
Ubuntu One Client
Wishlist
Ubuntu One Client Engineering team

Bug Description

This is a wishlist item.

I would really like to see a client for Ubuntu One that works on my Nokia N900. Here is a Maemo thread about it: http://talk.maemo.org/showthread.php?p=361813

Here is a brainstorm idea about it: http://brainstorm.ubuntu.com/idea/24894/

Changed in ubuntuone-client:
importance: Undecided → Wishlist
Thonacd (e-germond) wrote :

+1

Akber Choudhry (akberc) wrote :

+1

mishelangelo (mishelangelo) wrote :

+1

Nick Allen (nick-tallguy) wrote :

+1

Pere Quintana Seguí (pere) wrote :

+1

phil4444 (philipp-hoelzl-gmail) wrote :

+1

fretchen (fretchen) wrote :

+1

dougalf (r-launchpad-dougal-nl) wrote :

+1

Kevin Mace (klmace) wrote :

+1

Big-Boogi (t-boockmann) wrote :

+1

+1

xueg0i (j-kleinlankhorst) wrote :

+1

Fiepel (philippe-fiepel) wrote :

+1

VladNistor (vladnistor) wrote :

+1

nol (nol) wrote :

+1

Roman Yepishev (rye) wrote :

Hello,
Thanks for +1, but could you please use "Affects me too" link, since it is neither possible nor reasonable to sort bug reports based on the number of posts.

Thanks!

Stuart (stuart-andrews) wrote :

This affects me too. Having never yet had a phone that syncs properly with Ubuntu, yet I could do this in Windows (when I still had it) a good 8 years ago. I would really like to see a proper phone sync available for the N900, particularly as their OS is a Debian variant. Good luck with the project, I hope this is developed.

Joseph Brower (joseph-brower) wrote :

I would love to see this become available for the n900 as it would open up all sorts of syncing possibilities that would benefit my work.

Jürgen Schumacher (schm) wrote :

+1

Martin Borho (martin-borho) wrote :

+1

Connel Hooley (connelhooley) wrote :

+1,000,000,000,000,000,000,000,000,000,000,000,000,000,000,000,000,000,000,000,000,000,000

Connel Hooley (connelhooley) wrote :

Made a brainstorm entry about this too. Didn't know whether it would help get this bug any extra attention :) It hasn't been accepted yet though as I write this.

http://brainstorm.ubuntu.com/idea/24894/

description: updated
Changed in ubuntuone-client:
status: New → Confirmed
tags: added: desktop+
Changed in ubuntuone-client:
assignee: nobody → Ubuntu One Desktop+ team (ubuntuone-desktop+)
uBuNoAsE (noase) wrote :

+1

Georgius (keller-public) wrote :

Hello,

   I started to use Ubuntu One on my desktop(s) and I would like to sync with my new Nokia N900. Maemo is in fact Debian, but it does not use Nautilus nor Gnome. I downloaded ubuntuone-client-1.2.0 source and tried to compile it in a N900 scratchbox on my 32bit Ubuntu 9.10 32bit (I know I should upgrade ;-) ). The configure script failed on missed dependencies:

--snapshot--
checking for NAUTILUS... configure: error: Package requirements (libnautilus-extension >= 2.6.0 libebook-1.2 gconf-2.0) were not met:

No package 'libnautilus-extension' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables NAUTILUS_CFLAGS
--snapshot--

Libebook and gconf are installed with appropriate versions, so the only real problem is libnautilus-extension >= 2.6.0. If I understood correctly the man page of u1sdtool, it should be able to control the UbuntuOne daemon without gui, just on a command line. Can you help me to compile UbuntuOne without libnautilus dependency ? (compiling of Nautilus just for the sake of UbuntuOne seems to me as an overkill) There are standard Gtk and Qt4 librararies on Maemo 5, so even some simple GUI could be possible in he future (or even a hildon equivalent of nautilus stuff). At the moment there is no Dropbox client for N900 either (and it does not seem to be ready in the near future) so giving out Ubuntu One could do very good job in Ubuntu propagation among geeks in N900 community.

Thank you for any help or comments
George

> UbuntuOne daemon without gui, just on a command line. Can you help me to
> compile UbuntuOne without libnautilus dependency ? (compiling of
> Nautilus just for the sake of UbuntuOne seems to me as an overkill)
> There are standard Gtk and Qt4 librararies on Maemo 5, so even some
> simple GUI could be possible in he future (or even a hildon equivalent
> of nautilus stuff). At the moment there is no Dropbox client for N900
> either (and it does not seem to be ready in the near future) so giving
> out Ubuntu One could do very good job in Ubuntu propagation among geeks
> in N900 community.

Very good idea. I also have an N900 and I'm willing to test the
running U1 on it if you manage to make me binaries to test.

It's true that you should be able to have an U1 folder on N900 that is
synced with the cloud without any Nautilus, indicator etc feedback. Of
course it's not that fancy, but geeks like us are happy to even get it
working.

VladNistor (vladnistor) wrote :

I'm all for testing this as well.

----- Original message -----
> > UbuntuOne daemon without gui, just on a command line. Can you help me
> > to compile UbuntuOne without libnautilus dependency ? (compiling of
> > Nautilus just for the sake of UbuntuOne seems to me as an overkill)
> > There are standard Gtk and Qt4 librararies on Maemo 5, so even some
> > simple GUI could be possible in he future (or even a hildon equivalent
> > of nautilus stuff).  At the moment there is no Dropbox client for N900
> > either (and it does not seem to be ready in the near future) so giving
> > out Ubuntu One could do very good job in Ubuntu propagation among geeks
> > in N900 community.
>
> Very good idea. I also have an N900 and I'm willing to test the
> running U1 on it if you manage to make me binaries to test.
>
> It's true that you should be able to have an U1 folder on N900 that is
> synced with the cloud without any Nautilus, indicator etc feedback. Of
> course it's not that fancy, but geeks like us are happy to even get it
> working.
>
> --
> Support for maemo (Nokia n900)
> https://bugs.launchpad.net/bugs/512052
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in Ubuntu One Client: Confirmed
>
> Bug description:
> This is a wishlist item.
>
> I would really like to see a client for Ubuntu One that works on my
> Nokia N900. Here is a Maemo thread about it:
> http://talk.maemo.org/showthread.php?p=361813
>
> Here is a brainstorm idea about it:
> http://brainstorm.ubuntu.com/idea/24894/
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/ubuntuone-client/+bug/512052/+subscribe

Georgius (keller-public) wrote :

Hi,
 I got in touch with one of the developers yesterday and it seems quite promising - the only Nautilus dependecy is in a Nautilus plugin ;-). Unfortunately we discovered a bug which prevents ubuntuone synchronisation to run on Python 2.5 which is on N900 (Ubuntu 9.10 has 2.6), but fortunately this bug affects Debian stable as well, so there is very big chance to have it fixed soon. So I hope I will have some good new in the near future ...
   George

Rodrigo Moya (rodrigo-moya) wrote :

yes, you can just patch u1-client's configure.ac to not compile the nautilus plugin if libnautilus-extension is not found.

rdesfo (rdesfo) wrote :

+1

Msieur Piero (pierre-blanco) wrote :

+1...
Moreover, somebody tried - and succed in- creating an app syncing the n900 with dropbox...
Maybe it could be a path or a start for other developers.
Hope it can help : http://maemo.org/packages/view/dropn900/

nuovodna (nuovodna) wrote :

+1

Daniel Stoyanov (dankh) wrote :

+1

Duane Hinnen (duanedesign) wrote :

Hello,
Thanks for all the +1, but could you please use "Affects me too" link at the top of the page. This will be much more effective since report severities are based on number of people affected not number of comments on a bug.

Thanks!

Carlos (camedp) wrote :

+1 (did the affects me too also :) )

malacosteus (c-a-cammann) wrote :

+1

JanMalte (janmalte) wrote :

+1

Daniel M (danielpublic) wrote :

+1

KaMMed (mohamed-kamouni) wrote :

+1

Mikko Kortelainen (kortsi) wrote :

+1

Marktrix (markgerlach) wrote :

I am not a Developer and no Part of Canonical. But I think, the focus is iOS and Android, Maemo go out of date
and Canonical needs cost-effectiveness. So first the Bigplayers and than maybe (hopefully) Meego.I wrote this,
because is just a "Wishlist"...

quixote (commer-greenglim) wrote :

Another "affects me too" added. To the amateur (me) it seems like it should be trivially simple to make a linux phone like the n900 sync with linux systems. First shame is on Nokia for making a linux phone apparently for Windows users! I hope Canonical can get that fixed soon. Nokia seems to be too deep in the weeds to keep their eye on the ball....

Mr.Gosh (mr-gosh) wrote :

+1

Duane Hinnen (duanedesign) wrote :

Please use the 'This Bug Affect Me' link at the top of the page instead of adding '+1' or 'me too' comments.
Thank you,
duanedesign

Dimi77 (dimitrikarel) wrote :

+1

Colan Schwartz (colan) wrote :

PLEASE STOP POSTING "+1"s!!! The only point of this is to spam all subscribers. It DOES NOT give anyone a useful indication of who's interested in this. Use the "This bug affects..." link to increase the number of affected parties. This is the only meaningful indicator.

juandp77 (juandp77) wrote :

+1

Thomas (moonmaker) wrote :

+1

Mehul J. Rajput (mehulrajput) wrote :

+1

Gabu (gbsalvador) wrote :

+1

Tobias Bjälevik (nexxtep) wrote :

+1

+1

Tobias Bradtke (webwurst) wrote :

New Ubuntu One development strategy:
http://voices.canonical.com/ubuntuone/?p=943

inkognito (vogue) wrote :

+1

mkiol (mkiol) wrote :

New app that might help:
package: http://maemo.org/packages/view/ubi
web: http://ubi.garage.maemo.org
"Ubi: An unofficial Ubuntu One app for Maemo 5 and other Qt-enabled platforms"

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers