Maximum upload speed does not save consistently in client GUI

Bug #509740 reported by Joshua Hoover on 2010-01-19
138
This bug affects 20 people
Affects Status Importance Assigned to Milestone
Ubuntu One Client
Medium
dobey
ubuntuone-client (Ubuntu)
Medium
Ubuntu One Client Engineering team

Bug Description

Update: This seems to be a problem in ubuntuone-preferences on Lucid and the latest PPA version. The problem is actually that the values only save when focus is taken off the input field. So, if you click outside of each input field after changing the value, it will save the values. Otherwise, the input field that didn't have focused removed will not save.

Running 1.1.0+r306-0ubuntu1~ppa1~karmic on 32-bit Karmic the bandwidth usage/throttling settings are not saved properly every time. In particular, the upload (write_limit) setting does not get saved properly after attempting to change and save the value a couple of times. In some cases, users see the settings saved to "0", which doesn't allow the client to connect any longer and will produce the following syncdaemon-exceptions.log entry, when the read_limit is at 0 and the write_limit is greater than 0:

File "/usr/lib/python2.6/dist-packages/ubuntuone/storageprotocol/client.py", line 1462, in checkReadBandwidth
    throttle_time = (float(self.readThisSecond) / self.readLimit) - 1.0
exceptions.ZeroDivisionError: float division

----------------------------------------------------------

WORK AROUND

1. Quit the Ubuntu One client
2. Delete the file: ~/.config/ubuntuone/syncdaemon.conf
    (If using Nautilus, make sure you do a Ctrl-H to view hidden files when in your home directory)
3. Start the Ubuntu One client

You can try resetting the bandwidth usage preferences but if you continue to run into problems, follow the steps above and don't turn the limit bandwidth usage on for the time being.

----------------------------------------------------------

STEPS TO REPRODUCE

1. Right-click Ubuntu One client applet and select "Preferences"
2. Click on "Limit Bandwidth Usage" checkbox
3. Set Maximum upload and download speed inputs to: 3000
4. Click "Close" button

Result: ~/.config/ubuntuone/syncdaemon.conf set to:
[bandwidth_throttling]
read_limit = 3072000
write_limit = 3072000
on = True

5. Right-click Ubuntu One client applet and select "Preferences"
6. Set Maximum upload speed input to: 1000
   Leave Maximum download at: 3000
7. Click "Close" button

Result:
~/.config/ubuntuone/syncdaemon.conf set to:
[bandwidth_throttling]
read_limit = 3072000
write_limit = 3072000
on = True

And Ubuntu One Client preferences show 3000 for upload & download

---

Expected Result:
~/.config/ubuntuone/syncdaemon.conf set to:
[bandwidth_throttling]
read_limit = 3072000
write_limit = 1024000
on = True

And Ubuntu One Client preferences show 1000 for upload & 3000 for download

Related branches

Changed in ubuntuone-client (Ubuntu):
status: New → Won't Fix
status: Won't Fix → Confirmed
importance: Undecided → Medium
description: updated
description: updated
Rick McBride (rmcbride) wrote :

Hi Jamie,

Would you mind having a look at this? it looks like it may be related to the save/retrieve config info. Probably an easy fix for you.

Changed in ubuntuone-client:
assignee: nobody → James Tatum (jtatum)
Changed in ubuntuone-client:
status: Confirmed → Triaged
Changed in ubuntuone-client (Ubuntu):
status: Confirmed → Triaged
Changed in ubuntuone-client:
status: Triaged → Confirmed
importance: Medium → Undecided
Changed in ubuntuone-client (Ubuntu):
importance: Medium → Undecided
status: Triaged → Confirmed
Changed in ubuntuone-client:
assignee: James Tatum (jtatum) → Ubuntu One Desktop+ team (uone-desktop)
Changed in ubuntuone-client (Ubuntu):
assignee: nobody → Ubuntu One Desktop+ team (uone-desktop)
Roman Yepishev (rye) wrote :

Useful info from bug #465030:

Joshua Hoover:
Tested proposed update on a fresh Karmic install with all standard updates & proposed updates for ubuntuone-client & dependent packages. Ran steps to reproduce and got the following unexpected result: "Maximum upload speed" set to 128 & "Maximum download speed" set to 0 - FAIL.

Roman found that the fields only appear to save when focus is removed from the input field. So, if you set the upload and download inputs and take focus (mouse off) the fields after changing the value, they should save properly. This is not proper behavior but at least gives us an idea of what is really going on. It's not that one field saves properly and another does not.

Roman Yepishev (rye) on 2010-02-12
tags: added: bandwidth-throttling
description: updated
Changed in ubuntuone-client:
importance: Undecided → Medium
Changed in ubuntuone-client (Ubuntu):
importance: Undecided → Medium
tags: added: package u1-lucid
dobey (dobey) on 2010-03-31
Changed in ubuntuone-client:
assignee: Ubuntu One Desktop+ team (ubuntuone-desktop+) → Rodney Dawes (dobey)
status: Confirmed → In Progress
dobey (dobey) on 2010-03-31
Changed in ubuntuone-client:
status: In Progress → Fix Committed
dobey (dobey) on 2010-04-05
Changed in ubuntuone-client:
status: Fix Committed → Fix Released
Changed in ubuntuone-client (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers