KeyError: 'ROUND_CEiLiNG' when using turkish locale

Bug #467397 reported by Celal ERGÜN on 2009-10-31
108
This bug affects 16 people
Affects Status Importance Assigned to Milestone
Python
Fix Released
Unknown
Ubuntu One Client
Medium
Ubuntu One Client Engineering team
Ubuntu One Control Panel
Medium
Ubuntu One Client Engineering team
Ubuntu Single Sign On Client
Status tracked in Trunk
Stable-1-0
Medium
Ubuntu One Client Engineering team
Trunk
Medium
Ubuntu One Client Engineering team
python2.6 (Ubuntu)
Undecided
Unassigned

Bug Description

NOTE: A possible workaround is to run the application having the issue with a different locale, e.g:
$ LANG=en_US.UTF-8 /usr/bin/ubuntuone-client-applet

-----

Original description:

Hi there,
Its been two days I'm working on it but there is no hope left so I decided to report the situation.

Ubuntu One client doesn't do anything on clicking "Connect". I didn't see any "this is my computer" page either. It just sits tight on the bar with a red cross on it. Even "report a problem" menu isn't working.

I did "tail -f .cache/ubuntuone/log/syncdaemon.log" to get some hint. I'm pasting it here for you to see. I see no "token" or password thing in Passwords And Keys menu under Accessories (Name can be different since I'm using Ubuntu in Turkish)

The bad thing is I've been talking about Ubuntu One around and I couldn't show it to anybody :)

Here is my syncdaemon.log dump:

2009-10-31 22:30:14,499 - ubuntuone.SyncDaemon.Main - INFO - hash queue empty. We are ready!
2009-10-31 22:30:24,124 - ubuntuone.SyncDaemon.DBus - ERROR - Can't get the auth token
Traceback (most recent call last):
  File "/usr/lib/python2.6/dist-packages/ubuntuone/syncdaemon/dbus_interface.py", line 1073, in connect
    access_token = self.main.get_access_token()
  File "/usr/lib/python2.6/dist-packages/ubuntuone/syncdaemon/main.py", line 299, in get_access_token
    return self.oauth_client.get_access_token()
  File "/usr/lib/python2.6/dist-packages/ubuntuone/syncdaemon/main.py", line 339, in get_access_token
    raise NoAccessToken("No access token found.")
NoAccessToken: No access token found.
2009-10-31 22:32:14,468 - ubuntuone.SyncDaemon.Main - NOTE - ---- MARK (state: READY_WITH_NETWORK; queues: metadata: 0; content: 0; hash: 0, fsm-cache: hit=4 miss=1) ----

Thanks in advance guys.

Related branches

Celal ERGÜN (celalergun) wrote :

By the way I'm using Jaunty on that PC. I forgot to mention.

Matt Griffin (mattgriffin) wrote :

Sorry you're having problems. I assume you're using the beta PPA. What version of the client are you using? The most current revision number is 273.

Changed in ubuntuone-client:
status: New → Incomplete
Celal ERGÜN (celalergun) wrote :

Hi Matt,
Yes, it says 273 is installed in synaptic and I'm using beta PPA. Since "report a problem" menu doesn't work too, (and I'm reading forums almost regularly for this bug) I think there is some problem with Firefox launching code. Can you suggest me anything to create some system reports about it?

Guillermo Gonzalez (verterok) wrote :

Hi Celal,

please attach this log file to the bug: ~/.cache/ubuntuonelog/oauth-login.log

Thanks

Celal ERGÜN (celalergun) wrote :
Guillermo Gonzalez (verterok) wrote :

Hi,

This bug is caused by python+turkish locale.

So, this bug is in python itself see: http://bugs.python.org/issue1813

A possible workaround is to run syncdaemon with a different locale, e.g:
$> LANG=en_US.UTF-8 /usr/lib/ubuntuone-client/ubuntuon-syncdaemon

Guillermo Gonzalez (verterok) wrote :

I'll mark this bug as invalid in uubuntuone-client as there isn't much we can do about it

Changed in ubuntuone-client:
status: Incomplete → Invalid
status: Invalid → Triaged
summary: - Clicking on connect doesn't do anything
+ KeyError: 'ROUND_CEiLiNG' when using turkish locale
Roman Yepishev (rye) wrote :

As far as I was able to test this bug, the locale change is required for ubuntuone-client-applet (OAuth module), not syncdaemon.
Syncdaemon is able to sync files with tr_TR locale.

Open gnome-session-properties, select "Ubuntu One" entry, Edit it and prefix the available command with env LC_ALL=en_US.UTF-8, so that Command (Komut) is
env LC_ALL=en_US.UTF-8 ubuntuone-client-applet

The client will be started with English/USA locale on next login. This is still a workaround but at least it will not require manual syncdaemon/applet startup with en_US locale.

Celal ERGÜN (celalergun) wrote :

Hey it worked like charm. I copy-pasted your "env LC_ALL=en_US.UTF-8 ubuntuone-client-applet" code into gnome-terminal and Ubuntu One client sync-ed my files in no time.
Thank you for your help.

description: updated
Roman Yepishev (rye) on 2009-12-22
description: updated
description: updated
Rick McBride (rmcbride) on 2010-01-05
Changed in ubuntuone-client:
status: Triaged → Confirmed
Rick McBride (rmcbride) on 2010-01-13
Changed in ubuntuone-client:
importance: Undecided → Medium
tags: added: desktop+
Changed in ubuntuone-client:
assignee: nobody → Ubuntu One Desktop+ team (uone-desktop)
importance: Medium → Undecided
Changed in ubuntuone-client:
importance: Undecided → Medium
Roman Yepishev (rye) on 2010-02-17
tags: added: rye-diag
Changed in python2.6 (Ubuntu):
status: New → Confirmed
Changed in python:
status: Unknown → New
Roman Yepishev (rye) on 2010-05-20
tags: added: current-trouble
tags: removed: current-trouble
Changed in ubuntu-sso-client:
status: New → Confirmed
importance: Undecided → Medium
assignee: nobody → Ubuntu One Desktop+ team (ubuntuone-desktop+)
dobey (dobey) on 2010-10-01
Changed in ubuntu-sso-client:
status: Confirmed → Fix Committed
Changed in ubuntuone-control-panel:
assignee: nobody → Naty Bidart (nataliabidart)
importance: Undecided → Medium
status: New → Confirmed
Changed in ubuntuone-control-panel:
status: Confirmed → Triaged
Roman Yepishev (rye) on 2011-04-11
description: updated
Changed in ubuntuone-control-panel:
assignee: Naty Bidart (nataliabidart) → Ubuntu One Desktop+ team (ubuntuone-desktop+)
Changed in python:
status: New → Fix Released
Changed in python:
status: Fix Released → Fix Committed
Roman Yepishev (rye) wrote :

ubuntuone-launch is failing on Natty with tr_TR.UTF-8 locale:

rtg@napkin:~$ /usr/bin/ubuntuone-launch
/usr/lib/pymodules/python2.7/gtk-2.0/gtk/__init__.py:57: GtkWarning: could not open display
  warnings.warn(str(e), _gtk.Warning)
Traceback (most recent call last):
  File "/usr/bin/ubuntuone-launch", line 57, in <module>
    from ubuntuone.platform.tools import SyncDaemonTool, is_running
  File "/usr/lib/pymodules/python2.7/ubuntuone-client/ubuntuone/platform/linux/tools.py", line 24, in <module>
    from ubuntuone.platform.linux.dbus_interface import (
  File "/usr/lib/pymodules/python2.7/ubuntuone-client/ubuntuone/platform/linux/dbus_interface.py", line 32, in <module>
    from ubuntuone.syncdaemon.interaction_interfaces import (
  File "/usr/lib/pymodules/python2.7/ubuntuone-client/ubuntuone/syncdaemon/interaction_interfaces.py", line 24, in <module>
    from ubuntuone.syncdaemon.action_queue import Download, Upload
  File "/usr/lib/pymodules/python2.7/ubuntuone-client/ubuntuone/syncdaemon/action_queue.py", line 29, in <module>
    import simplejson
  File "/usr/lib/python2.7/dist-packages/simplejson/__init__.py", line 109, in <module>
    from decimal import Decimal
  File "/usr/lib/python2.7/decimal.py", line 3715, in <module>
    val = globals()[globalname]
KeyError: 'ROUND_CEiLiNG'

Changed in python:
status: Fix Committed → Fix Released
Roberto Alsina (ralsina) on 2012-06-04
Changed in ubuntuone-client:
status: Confirmed → Fix Released
Changed in ubuntuone-control-panel:
status: Triaged → Fix Released
Changed in ubuntuone-client:
status: Fix Released → Confirmed
Roberto Alsina (ralsina) wrote :

As far as we know, this bug is fixed in all current releases of ubuntuone-client and ubuntuone-control-panel in all supported Ubuntu versions.

If that's not the case, please reopen.

Changed in ubuntuone-client:
status: Confirmed → Fix Released
dino99 (9d9) wrote :

Support for this version has ended

Changed in python2.6 (Ubuntu):
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.