"Protocol version error" - when bandwidth throttling is enabled with the default values

Bug #455544 reported by John O'Brien on 2009-10-19
This bug affects 583 people
Affects Status Importance Assigned to Milestone
Ubuntu One Client
High
Guillermo Gonzalez
ubuntuone-client (Ubuntu)
High
dobey
Karmic
Undecided
Unassigned

Bug Description

I am always getting "Protocol version error" when I start this client.
* After updating everything
* After removing and reinstalling everything
* After removing and making sure nothing shows up in /usr with find | grep ubuntuone (except some image files) and then installing everything again

Bug is triggered when bandwidth throttling is enabled with the default values.

The workaround is to either remove or rename: ~/.config/ubuntuone/syncdaemon.conf

This will reset the syncdaemon.conf file. For the time being, don't set the bandwidth usage preference.

Related branches

John O'Brien (jdobrien) wrote :
description: updated
John O'Brien (jdobrien) wrote :
John O'Brien (jdobrien) wrote :
Joshua Hoover (joshuahoover) wrote :

Hi John, I'm assigning this to Lucio to look at further. Is this on a Karmic install? Thanks, Joshua

Changed in ubuntuone-client:
status: New → Triaged
tags: added: foundations+
Changed in ubuntuone-client:
importance: Undecided → High
assignee: nobody → Lucio Torre (lucio.torre)
ziggystar (ziggystar-gmx) wrote :

I'm having this issue with an ubuntuone install on Ubuntu 9.04 (amd64). I've installed it some days ago. It worked for one day. Then the following day, I couldn't connect. I manually checked for updates and found an ubuntuone update, that I did install. It didn't fix the problem of not being able to connect, though.

I'm attaching a zip file containing all files from my log directory. I think the main error is:

2009-10-29 12:37:26,102 - ubuntuone.SyncDaemon.ActionQueue - ERROR - Protocol version error
2009-10-29 12:37:26,110 - twisted - ERROR - Unhandled error in Deferred:
2009-10-29 12:37:26,111 - twisted - ERROR - Unhandled Error
Traceback (most recent call last):
Failure: twisted.internet.error.ConnectionLost: Connection to the other side was lost in a non-clean fashion: Connection lost.

John O'Brien (jdobrien) wrote :

Deleting the ~/.config/ubuntuone folder corrected this problem

Natalia Bidart (nataliabidart) wrote :

I removed the .config/ubuntuone folder and it worked. Attaching this directory before removal for debug.

John O'Brien (jdobrien) wrote :

There is a bug in ubuntuone.syncdaemon.config:

def throttling_limit_parser(value):
    """parser for throttling limit values, if value < 0 returns None"""
    if value < 0:
        return None
    else:
        return int(value)

The value comes in as a string so value < 0 is always False.

Changed in ubuntuone-client:
assignee: Lucio Torre (lucio.torre) → Guillermo Gonzalez (verterok)
status: Triaged → In Progress
Niels Egberts (nielsegberts) wrote :

I'm having the same issue. Bugs #462261 and #461496 seem duplicates so I'm marking them as such.

John O'Brien (jdobrien) on 2009-11-03
Changed in ubuntuone-client:
status: In Progress → Fix Released
Changed in ubuntuone-client (Ubuntu):
status: New → Confirmed
assignee: nobody → John Lenton (chipaca)
Changed in ubuntuone-client:
status: Fix Released → Fix Committed
description: updated
tags: added: ubuntuone-sru
summary: - I am always getting "Protocol version error"
+ "Protocol version error" - when bandwidth throttling is enabled with the
+ default values
MoLE (moleonthehill) wrote :

Confirming that bug #472094 is indeed a duplicate of this bug. Deleting the .config/ubuntuone directory as a workaround has fixed the issue.

description: updated
tags: added: common
txapelgorri (ibon) wrote :

Same behavior here:
 - Ubuntu 9.04 32bits
 - Package version: 1.1+r276-0ubuntu1~ppa1~jaunty

Removing "~/.config/ubuntuone/" solves the issue.

Ibon.

tags: added: chicharra-lucid-problems
Nathaniel Schwartz (gnat79) wrote :

I was able to fix whatever problems I had by deleting all the files in ~/.config/Ubuntu One (I think) and then restart Ubuntu One. I was then able to log in with no issues, and it's been working fine since. Anyone else try this?

I had deleted the file /home/user/.config/ubuntuone/syncadaemon.conf and it seems to be working ok

merl15 (lewstherin0105) wrote :

Thanks Joshua, removing the syncdaemon.conf file as the above poster did does the job indeed.

Carlo Capocasa (carlotheman) wrote :

What's up, Joshua... coming from duplicate bug #473054 and the fix works just fine. Thanks! And thanks for telling me about it over at the duplicate... Have a good one, Carlo

Steve Petersen (spetey) wrote :

I originally was on a bug marked as a duplicate about being unable to connect. I erased all my .config/ubuntuone files and I still can't connect. In both the task tray and nautilus, it comes on as unconnected, and when I ask it to connect it just sits trying. After erasing the files, starting the client, and trying to connect, in the ubuntuone directory I have just ubuntuone-client.conf, which reads like this:

show_applet = 1
connected = True
connect = 0
bookmarked = True

Thanks for any help,
Steve

piou13 (mihelakis-nikitas) wrote :

after deleting the syncdaemon.conf everything works fine without changing the bandwidth limit after every restart

thanks for the help

after deleting the syncdaemon.conf everything works fine.million thanks for your kind help.

Steve Petersen (spetey) wrote :

Follow up to my comment <a href="https://bugs.launchpad.net/ubuntuone-client/+bug/455544/comments/17">#17</a>: deleting the ubuntuone directory <i>and</i> reinstalling worked fine. Thanks.

Changed in ubuntuone-client (Ubuntu):
assignee: John Lenton (chipaca) → Rodney Dawes (dobey)
kyrato (kyrato) wrote :

for UNR karmic

i simply upped the bandwidth, it connected, went back to restore to default setting and it was already done.

wierd, but it worked.

Page at https://wiki.edubuntu.org/UbuntuOne/Bugs mentions how this will also be indicated with -1 values in syncdaemon.conf, yet I've had it with on = True and read_limit and write_limit set to 0. The same fix of removing the file helped me :)

Nick (npatentalakis) wrote :

Hallo everyone,

I just followed instructions from Joshua, without deleting the deamon. I just changed the bandwidth to lower, and IT WORKS!

Thanks Joshua!

dobey (dobey) on 2009-12-09
Changed in ubuntuone-client (Ubuntu):
status: Confirmed → In Progress
importance: Undecided → High
Chris (christian-kropfberger) wrote :

Removing ~/.config/ubuntuone/syncdaemon.conf did the trick for me (but having only tried this one). Thanks!

Accepted ubuntuone-client into karmic-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in ubuntuone-client (Ubuntu Karmic):
status: New → Fix Committed
tags: added: verification-needed
tags: added: u1-lucid
towerlexa (towerlexa) wrote :

Thank you very much for your answer. I will try your hint and give feedback later

"If you delete
~/.config/ubuntuone/syncdaemon.conf and restart the Ubuntu One client,
you should be able to connect. Thank you, Joshua"

I wish all a nice and peaceful christmas time

towerlexa (towerlexa) wrote :

Hi Joshua,

after i followed your hint:
"~/.config/ubuntuone/syncdaemon.conf and restart the Ubuntu One client"
the synchronization is working fine!

Thank you very much!
best regards Axel

suniyo (suniyo) wrote :

I did the same but it is not working for me and strange of all my client shows connected and the folder button on the right side says ubuntuone is disconnected. unable to sync. doesn't even work after restart is applied. filed bug 2 times but marked as duplicated of 455544, strange.

On Wed, 2010-01-20 at 17:07 +0000, suniyo wrote:
> I did the same but it is not working for me and strange of all my client
> shows connected and the folder button on the right side says ubuntuone
> is disconnected. unable to sync. doesn't even work after restart is
> applied. filed bug 2 times but marked as duplicated of 455544, strange.

Can you please try the procedure which Martin described in comment #25,
and enable the "Proposed updates" source in your software sources, and
upgrade ubuntuone-client-gnome to 1.0.3 from the karmic-proposed
repository, and then comment if you still see this problem? Thanks!

Vyoma (vyoma) wrote :

I am coming over from Bug 515891 - I closed the Ubuntu One client, cleared all files in ~/.config/ubuntuone and restarted it. The syncing of files worked without any issue. Thanks!

Thanks Vyoma! it works fine!

Juande

2010/2/2 Vyoma <email address hidden>

> I am coming over from Bug 515891 - I closed the Ubuntu One client,
> cleared all files in ~/.config/ubuntuone and restarted it. The syncing
> of files worked without any issue. Thanks!
>
> --
> "Protocol version error" - when bandwidth throttling is enabled with the
> default values
> https://bugs.launchpad.net/bugs/455544
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>
> Status in Ubuntu One Client: Fix Committed
> Status in “ubuntuone-client” package in Ubuntu: In Progress
> Status in “ubuntuone-client” source package in Karmic: Fix Committed
>
> Bug description:
> I am always getting "Protocol version error" when I start this client.
> * After updating everything
> * After removing and reinstalling everything
> * After removing and making sure nothing shows up in /usr with find | grep
> ubuntuone (except some image files) and then installing everything again
>
> Bug is triggered when bandwidth throttling is enabled with the default
> values.
>
> The workaround is to either remove or rename:
> ~/.config/ubuntuone/syncdaemon.conf
>
> This will reset the syncdaemon.conf file. For the time being, don't set the
> bandwidth usage preference.
>
>
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/ubuntuone-client/+bug/455544/+subscribe
>

Jmadero (jmadero) wrote :

seems like the steps in #25 fix the problem, when will the new package be in the main repo so users won't have to do a bunch of steps to get the client working? I'm uploading at 100 kb/s for the first time since ubuntuone was released :):)

Jmadero (jmadero) wrote :

Still not perfect, I've noticed several things still:

1. If you manually disconnect, I cannot reconnect, I push the button in nautilus and it quickly disconnects again

2. It's telling me that files are up to date when I've only uploaded about 20 megs (of about 120 megs)

3. Now it's uploading at about 2.67 kb/s again, it's telling me that the files are up to date (I removed everything from ubuntuone and recopied over the folders that I wanted backed up),

4. Inside of nautilus it's telling me that it's currently disconnected, but the cloud on the top (the icon) is telling me that I'm connected and that my files are up to date (they definitely aren't)

Roman Yepishev (rye) wrote :
Download full text (3.3 KiB)

Syncdaemon is still unusable with default values.

ubuntuone-client-preferences sets 0 (zero) as the default value for both read limit and write limit. When syncdaemon encounters zero it:

2010-02-04 22:23:40,799 - ubuntuone.SyncDaemon.EQ - DEBUG - push_event: SYS_CONNECT, args:(<oauth.oauth.OAuthToken object at 0xa34374c>,), kw:{}
2010-02-04 22:23:40,800 - ubuntuone.SyncDaemon.State - DEBUG - Setting up timeout watchdog
2010-02-04 22:23:40,808 - ubuntuone.SyncDaemon.State - DEBUG - READY_WITH_NETWORK_WITH_BOTHQ --[SYS_CONNECT]--> START_CONNECTING_WITH_BOTHQ
2010-02-04 22:23:40,809 - ubuntuone.SyncDaemon.EQ - DEBUG - push_event: SYS_STATE_CHANGED, args:(), kw:{'state': <SyncDaemonState START_CONNECTING_WITH_BOTHQ>}
2010-02-04 22:23:40,823 - ubuntuone.SyncDaemon.ActionQueue - DEBUG - SRV lookup done, choosing a server
2010-02-04 22:23:40,824 - ubuntuone.SyncDaemon.ActionQueue - DEBUG - Using record: <RR name=_https._tcp.fs.ubuntuone.com type=SRV class=IN ttl=517s auth=False>
2010-02-04 22:23:40,971 - ubuntuone.SyncDaemon.ActionQueue - DEBUG - connection made
2010-02-04 22:23:40,972 - ubuntuone.SyncDaemon.EQ - DEBUG - push_event: SYS_CONNECTION_MADE, args:(), kw:{}
2010-02-04 22:23:40,973 - ubuntuone.SyncDaemon.State - DEBUG - Event arrived: cancelling timeout watchdog
2010-02-04 22:23:40,973 - ubuntuone.SyncDaemon.State - DEBUG - Setting up timeout watchdog
2010-02-04 22:23:40,977 - ubuntuone.SyncDaemon.ActionQueue - ERROR - Protocol version error
2010-02-04 22:23:40,986 - ubuntuone.SyncDaemon.ActionQueue - DEBUG - traceback follows:

Traceback (most recent call last):
  File "/usr/lib/python2.6/dist-packages/ubuntuone/syncdaemon/action_queue.py", line 917, in check_version
    yield client.protocol_version()
  File "/usr/lib/python2.6/dist-packages/ubuntuone/storageprotocol/client.py", line 68, in protocol_version
    p.start()
  File "/usr/lib/python2.6/dist-packages/ubuntuone/storageprotocol/request.py", line 375, in start
    return self._start()
  File "/usr/lib/python2.6/dist-packages/ubuntuone/storageprotocol/client.py", line 1217, in _start
    self.sendMessage(message)
  File "/usr/lib/python2.6/dist-packages/ubuntuone/storageprotocol/request.py", line 403, in sendMessage
    self.protocol.sendMessage(message)
  File "/usr/lib/python2.6/dist-packages/ubuntuone/syncdaemon/action_queue.py", line 175, in sendMessage
    result = ThrottlingStorageClient.sendMessage(self, message)
  File "/usr/lib/python2.6/dist-packages/ubuntuone/storageprotocol/request.py", line 270, in sendMessage
    self.write(struct.pack(SIZE_FMT, len(m)))
  File "/usr/lib/python2.6/dist-packages/ubuntuone/storageprotocol/client.py", line 1375, in write
    self.factory.registerWritten(len(data))
  File "/usr/lib/python2.6/dist-packages/ubuntuone/syncdaemon/action_queue.py", line 685, in registerWritten
    ThrottlingStorageClientFactory.registerWritten(self, length)
  File "/usr/lib/python2.6/dist-packages/ubuntuone/storageprotocol/client.py", line 1449, in registerWritten
    self.checkWriteBandwidth()
  File "/usr/lib/python2.6/dist-packages/ubuntuone/storageprotocol/client.py", line 1474, in checkWriteBandwidth
    throttle_time = (float(self.writtenThisSecond) /...

Read more...

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntuone-client - 1.0.3-0ubuntu1

---------------
ubuntuone-client (1.0.3-0ubuntu1) karmic-proposed; urgency=high

  * New upstream release
    - Remove patch files now in upstream for #462828
    - Require python-ubuntuone-storageprotocol >= 1.0.1
    - BadTransition: SYS_CONNECTION_MADE (LP: #457147)
    - ValueError: invalid literal for int() with base 10: 'None' (LP: #476777)
    - Protocol version error with bw throttling enabled (LP: #455544)
    - Folder deletion from other machines results in conflicts (LP: #462003)
    - Syncdaemon doesn't disable throttling (LP: #483592)
    - Syncdaemon crashes with NoAccessToken (LP: #488413)
    - Error creating share from Nautilus: callback() (LP: #492100)
    - Work without NetworkManager installed (LP: #357395)
    - Create a POT during the build (LP: #455527)
    - Bring back timestamps in oauth-login.log (LP: #459175)
    - Applet starts syncdaemon without a token (LP: #491573)
    - Prefs changes don't take immediate affect (LP: #457564)
    - BW limit settings don't appear to be saved (LP: #465030)
    - Distinguish auth errors from other errors (LP: #450633)
    - Fix for running on python < 2.6.3 (LP: #451670)
 -- Rodney Dawes <email address hidden> Fri, 11 Dec 2009 15:45:52 -0500

Changed in ubuntuone-client (Ubuntu Karmic):
status: Fix Committed → Fix Released
Roman Yepishev (rye) on 2010-02-12
tags: added: bandwidth-throttling
tags: added: chicharra
Roman Yepishev (rye) wrote :

Ok, how would one set an unlimited upload/download rate?

<burn> rye: it didn't work at all
<burn> did just a fresh install on my karmic machine
<rye> burn, ok, then we'll definitely need ~/.cache/ubuntuone/log/syncdaemon.log - it should not be this way.
<burn> rye: http://paste.ubuntu.com/378374/
<rye> burn, great
<rye> burn, could you please open client preferences from the applet and see whether you have bandwidth limits set?
<burn> rye: yeah I did
<burn> 64KB
<burn> upload
<rye> burn, i believe the download is 0
<burn> yeah, unlimited
<burn> not?
<rye> burn, not quite, this is the bad thing about the preferences window - 0 means literally 0 download rate.
<rye> i.e. no download possible.
<burn> you can't be serious
<rye> additionally it breaks the software

On Wed, 2010-02-17 at 14:50 +0000, Roman Yepishev wrote:
> Ok, how would one set an unlimited upload/download rate?

You specify an arbitrarily high value. The default is 2MB/s, which is
more than fast enough for the majority of the world. Or disable the
throttling all together. I don't see why on a very high bandwidth
connection, you would want to set one value to 'unlimited' and another
to 'very low' rather than 'not at all.' Is there a compelling use case
for doing so? And why is it being discussed in this report, rather than
a new one?

dobey (dobey) on 2010-02-18
Changed in ubuntuone-client (Ubuntu):
status: In Progress → Fix Released
Changed in ubuntuone-client:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers