Problem with computer verification in Ubuntu One.

Bug #450633 reported by Lars Magne on 2009-10-13
218
This bug affects 43 people
Affects Status Importance Assigned to Milestone
Ubuntu One Client
Critical
Facundo Batista
Ubuntu One storage protocol
Critical
Facundo Batista
ubuntuone-client (Ubuntu)
Critical
dobey
Nominated for Dapper by r12056
Nominated for Hardy by r12056
Nominated for Intrepid by r12056
Nominated for Jaunty by r12056
Karmic
Undecided
Unassigned
Lucid
Critical
dobey
ubuntuone-storage-protocol (Ubuntu)
Critical
dobey
Nominated for Dapper by r12056
Nominated for Hardy by r12056
Nominated for Intrepid by r12056
Nominated for Jaunty by r12056
Karmic
Undecided
Unassigned
Lucid
Critical
dobey

Bug Description

After update on october 13th (Karmic Beta): Ubuntu One asks me to verify my computer everytime I boot or wake it up from sleep.

Related branches

John O'Brien (jdobrien) wrote :

Every time I start the client I am asked to confirm computer access.

This is with 1.0.0+r255-0ubuntu1~ppa1~karmic

Changed in ubuntuone-client:
status: New → Triaged
importance: Undecided → Critical
assignee: nobody → Rodney Dawes (dobey)
John O'Brien (jdobrien) wrote :

Here's what is in my oauth-login.log

Starting Ubuntu One client version 1.0.0
Quit Error: Method "quit" with signature "" on interface "com.ubuntuone.SyncDaemon.SyncDaemon" doesn't exist

dobey (dobey) wrote :

This is actually an issue with the server. There is a problem with the primary storage server, causing authentication to fail for everyone, every time, which is currently being looked into. Chipaca said this should be assigned to you Facundo. Thanks.

affects: ubuntuone-client → ubuntuone-servers
Changed in ubuntuone-servers:
assignee: Rodney Dawes (dobey) → Facundo Batista (facundo)
Guillermo Gonzalez (verterok) wrote :

John, could you attach syncdaemon-exceptions.log or syncdaemon.log?

Thanks!

Changed in ubuntuone-servers:
status: Triaged → In Progress
Facundo Batista (facundo) wrote :

The main issue here is that the client.py, from storageprotocol, confuses both errors, so ActionQueue can not distinguish them.

I'm thinking a solution along this way: client.py will separate the errors, and AQ will trigger unknown error in case of server internal error, and auth error in case of auth error only. The applet could still behave like now, but the token dropping will not be triggered by timeouts in the server.

Changed in ubuntuone-servers:
status: In Progress → Fix Committed
Changed in ubuntuone-servers:
status: Fix Committed → Fix Released
dobey (dobey) on 2009-12-10
affects: ubuntuone-servers → ubuntuone-client
dobey (dobey) on 2009-12-10
Changed in ubuntuone-storage-protocol:
status: New → Fix Released
importance: Undecided → Critical
assignee: nobody → Facundo Batista (facundo)
Changed in ubuntuone-client (Ubuntu):
status: New → In Progress
assignee: nobody → Rodney Dawes (dobey)
importance: Undecided → Critical
Changed in ubuntuone-storage-protocol (Ubuntu):
assignee: nobody → Rodney Dawes (dobey)
importance: Undecided → Critical
status: New → In Progress
dobey (dobey) on 2009-12-11
tags: added: ubuntuone-sru

Accepted ubuntuone-storage-protocol into karmic-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in ubuntuone-storage-protocol (Ubuntu Karmic):
status: New → Fix Committed
tags: added: verification-needed
Martin Pitt (pitti) wrote :

Accepted ubuntuone-client into karmic-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in ubuntuone-client (Ubuntu Karmic):
status: New → Fix Committed
thanasis (thanasis-) on 2010-01-03
Changed in ubuntuone-client:
status: Fix Released → Fix Committed
Changed in ubuntuone-storage-protocol:
status: Fix Released → Fix Committed
Changed in ubuntuone-client (Ubuntu Karmic):
status: Fix Committed → Fix Released
Changed in ubuntuone-storage-protocol (Ubuntu):
status: In Progress → Fix Committed
Changed in ubuntuone-storage-protocol (Ubuntu Karmic):
status: Fix Committed → Confirmed
Martin Pitt (pitti) wrote :

thanasis, this isn't helpful. Please don't wildly change bug states without explanation, it's a lot of work to restore all those properly.

Changed in ubuntuone-storage-protocol (Ubuntu):
status: Fix Committed → In Progress
Changed in ubuntuone-storage-protocol (Ubuntu Karmic):
status: Confirmed → Fix Committed
Changed in ubuntuone-client:
status: Fix Committed → Fix Released
Changed in ubuntuone-storage-protocol:
status: Fix Committed → Fix Released
Changed in ubuntuone-client (Ubuntu Karmic):
status: Fix Released → Fix Committed
Changed in ubuntuone-client (Ubuntu):
status: In Progress → Fix Committed
Simon Benichou (simon.benichou) wrote :

Hello,

I am facing the same problem here (bug duplicate Ubuntu One starts an authentication loop when starting the client - https://bugs.launchpad.net/bugs/507969)

This is the ~/.cache/ubuntuone/log/oauth-login.log output on such a sequence :

2010-01-16 01:40:25,404:404.347896576 UbuntuOne.Client.Applet Starting Ubuntu One client version 1.0.3
2010-01-16 01:40:46,041:41.1128997803 UbuntuOne.Client.Applet Quit Error: Method "quit" with signature "" on interface "com.ubuntuone.SyncDaemon.SyncDaemon" doesn't exist

2010-01-16 01:41:02,483:483.6769104 UbuntuOne.Client.Applet Quit Error: Method "quit" with signature "" on interface "com.ubuntuone.SyncDaemon.SyncDaemon" doesn't exist
________________

And this is the ~/.cache/ubuntuone/log/syncdaemon-exceptions.log :

2010-01-16 01:41:03,287 - ubuntuone.SyncDaemon.fsm - INFO - loading updated metadata
2010-01-16 01:41:03,322 - ubuntuone.SyncDaemon.fsm - INFO - initialized: idx_path: 2, idx_node_id: 0, shares: 1
2010-01-16 01:41:03,326 - ubuntuone.SyncDaemon.HQ - INFO - HashQueue: _hasher started
2010-01-16 01:41:05,176 - ubuntuone.SyncDaemon.DBus - INFO - DBusInterface initialized.
2010-01-16 01:41:05,176 - ubuntuone.SyncDaemon.Main - INFO - Using /home/simon/Ubuntu One as root dir
2010-01-16 01:41:05,177 - ubuntuone.SyncDaemon.Main - INFO - Using /home/simon/.local/share/ubuntuone/syncdaemon as data dir
2010-01-16 01:41:05,177 - ubuntuone.SyncDaemon.Main - INFO - Using /home/simon/.local/share/ubuntuone/shares as shares root dir
2010-01-16 01:41:05,178 - ubuntuone.SyncDaemon.Main - NOTE - ---- MARK (state: INIT; queues: metadata: 0; content: 0; hash: 0, fsm-cache: hit=1 miss=2) ----
2010-01-16 01:41:05,180 - ubuntuone.SyncDaemon.Main - NOTE - Local rescan starting...
2010-01-16 01:41:05,180 - ubuntuone.SyncDaemon.local_rescan - INFO - start scan all shares
2010-01-16 01:41:05,191 - ubuntuone.SyncDaemon.sync - INFO - T:NONE:F 496a5644-cc28-4d49-97b9-25483fb39aa1 [root:496a5644-cc28-4d49-97b9-25483fb39aa1] ''Ubuntu One/Ubuntu.cbz'' | Called new_local_file (In: F:NA:NA)
2010-01-16 01:41:05,196 - ubuntuone.SyncDaemon.sync - INFO - T:NONE:F 496a5644-cc28-4d49-97b9-25483fb39aa1 [root:496a5644-cc28-4d49-97b9-25483fb39aa1] ''Ubuntu One/Ubuntu.cbz'' | Called calculate_hash (In: T:NONE:F)
2010-01-16 01:41:05,196 - ubuntuone.SyncDaemon.local_rescan - INFO - processing trash
2010-01-16 01:41:05,198 - ubuntuone.SyncDaemon.Main - NOTE - Local rescan finished!
2010-01-16 01:41:05,198 - ubuntuone.SyncDaemon.Main - INFO - hash queue pending. Waiting for it...
2010-01-16 01:41:05,265 - ubuntuone.SyncDaemon.HQ - INFO - HashQueue: _hasher stopped
2010-01-16 01:41:05,266 - ubuntuone.SyncDaemon.DBus - INFO - Shuttingdown DBusInterface!
2010-01-16 01:41:05,300 - ubuntuone.SyncDaemon.Main - INFO - hash queue pending. Waiting for it...

warm (esinevgeny) on 2010-01-21
Changed in ubuntuone-client:
status: Fix Released → Fix Committed
status: Fix Committed → Confirmed
Changed in ubuntuone-client (Ubuntu):
status: Fix Committed → Fix Released

On Thu, 2010-01-21 at 17:24 +0000, warm wrote:
> ** Changed in: ubuntuone-client
> Status: Fix Released => Fix Committed
>
> ** Changed in: ubuntuone-client
> Status: Fix Committed => Confirmed
>
> ** Changed in: ubuntuone-client (Ubuntu)
> Status: Fix Committed => Fix Released
>

Please don't go around changing bug status without warning. Thanks.

Changed in ubuntuone-client:
status: Confirmed → Fix Released
Changed in ubuntuone-client (Ubuntu):
status: Fix Released → Fix Committed
Tonnerre LOMBARD (tonnerre) wrote :

I'm afraid that even with the proposed-updates version this bug still persists. And concerning the servers «not working correctly all of the time», I have never seen UbuntuOne actually work. (And this is the second netbook I'm trying it on.)

erlguta (gonzalomarcote) wrote :

This bug still persists with last updates in Karmic (ubuntuone-client 1.0.2-0ubuntu2) and is very annoying. Every time i reboot or i resume from suspend, Ubuntu One request me to sign in and add PC again and again and again...Even if i add mi laptop, in the same session, it interrupts my work opening one new tab in my browser.
It is so annoying that i opted to completely disable ubuntu one.

PD: One clarification: this happens only in my netbook. I have a pc at work and one in my room where this does not happens.

erlguta (gonzalomarcote) wrote :

I have enabled propossed and with ubuntuone-client version: 1.0.3-0ubuntu1 it seems to be fixed for me.

Martin Pitt (pitti) on 2010-02-04
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntuone-client - 1.0.3-0ubuntu1

---------------
ubuntuone-client (1.0.3-0ubuntu1) karmic-proposed; urgency=high

  * New upstream release
    - Remove patch files now in upstream for #462828
    - Require python-ubuntuone-storageprotocol >= 1.0.1
    - BadTransition: SYS_CONNECTION_MADE (LP: #457147)
    - ValueError: invalid literal for int() with base 10: 'None' (LP: #476777)
    - Protocol version error with bw throttling enabled (LP: #455544)
    - Folder deletion from other machines results in conflicts (LP: #462003)
    - Syncdaemon doesn't disable throttling (LP: #483592)
    - Syncdaemon crashes with NoAccessToken (LP: #488413)
    - Error creating share from Nautilus: callback() (LP: #492100)
    - Work without NetworkManager installed (LP: #357395)
    - Create a POT during the build (LP: #455527)
    - Bring back timestamps in oauth-login.log (LP: #459175)
    - Applet starts syncdaemon without a token (LP: #491573)
    - Prefs changes don't take immediate affect (LP: #457564)
    - BW limit settings don't appear to be saved (LP: #465030)
    - Distinguish auth errors from other errors (LP: #450633)
    - Fix for running on python < 2.6.3 (LP: #451670)
 -- Rodney Dawes <email address hidden> Fri, 11 Dec 2009 15:45:52 -0500

Changed in ubuntuone-client (Ubuntu Karmic):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntuone-storage-protocol - 1.0.1-0ubuntu1

---------------
ubuntuone-storage-protocol (1.0.1-0ubuntu1) karmic-proposed; urgency=low

  * New upstream release
    - Avoid extra throttling and bytes message calls (LP: #479204)
    - Correctly raise StorageRequestError on ERROR (LP: #450633)
    - Avoid double connection factory confusion (LP: #457147)
 -- Rodney Dawes <email address hidden> Fri, 11 Dec 2009 14:30:00 -0500

Changed in ubuntuone-storage-protocol (Ubuntu Karmic):
status: Fix Committed → Fix Released
dobey (dobey) on 2010-02-18
Changed in ubuntuone-client (Ubuntu Lucid):
status: Fix Committed → Fix Released
Changed in ubuntuone-storage-protocol (Ubuntu Lucid):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers