Conflict when file is changed with gedit in other machine

Bug #449605 reported by Mariano Draghi on 2009-10-12
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu One Client
Critical
Facundo Batista
ubuntuone-client (Ubuntu)
Critical
dobey
Nominated for Karmic by dobey

Bug Description

I have a text file synced with U1, originally created in mi laptop, and synchronized in mi desktop:
 ~/Ubuntu One/u1-test/u1-test.txt

I edited the file in the desktop with gedit, and saved it. When the file got synced again in the laptop, I got a conflict. The original file, u1-test.txt, was lost. A new file appeared:
 ~/Ubuntu One/u1-test/u1-test.txt~.u1conflict

That file didn't include the last edition on the PC, so my last changes get lost.

I'm attaching my laptop's syncdaemon.log where the conflict arises: syncdaemon.log.2009-10-12_09-41-43

ProblemType: Bug
.home.mariano..cache.ubuntuone.log.syncdaemon.exceptions.log:

Architecture: i386
CrashDB: ubuntuone
DistroRelease: Ubuntu 9.04
Package: ubuntuone-client 0.96.0+r231-0ubuntu1~ppa1~jaunty
PackageArchitecture: all
ProcEnviron:
 LANG=es_AR.UTF-8
 SHELL=/bin/bash
SourcePackage: ubuntuone-client
ThirdParty: True
Uname: Linux 2.6.28-15-generic i686
UnreportableReason: Este no es un paquete Ubuntu genuino

Related branches

Mariano Draghi (chaghi) wrote :
Facundo Batista (facundo) wrote :

The problem is here: merge_directory generates this two events:

2009-10-12 00:47:49,726 - ubuntuone.SyncDaemon.EQ - DEBUG - push_event: SV_MOVED, args:(), kw:{'new_name': 'u1-test.txt~', 'new_share_id': '', 'share_id': '', 'new_parent_id': 'd3b01d84-82df-41db-9353-c5cf047e09b5', 'node_id': 'e70f7a96-861f-43d7-b504-180e66791d50'}

2009-10-12 00:47:49,733 - ubuntuone.SyncDaemon.EQ - DEBUG - push_event: SV_FILE_NEW, args:(), kw:{'parent_id': 'd3b01d84-82df-41db-9353-c5cf047e09b5', 'node_id': '2fb41532-2866-4aac-a252-d4a820cd7152', 'share_id': '', 'name': 'u1-test.txt'}

Which are ok, btw, because that's what really happened.

But then, the file is moved in the disk ('u1-test.txt' to 'u1-test.txt~'), and a new 'u1-test.txt' file is created, and then a FS_FILE_MOVE arrives (because of first change), and Sync confuses the origin of the movement as being the newly created node.

Changed in ubuntuone-client:
assignee: nobody → Facundo Batista (facundo)
importance: Undecided → High
status: New → Triaged
Elliot Murphy (statik) on 2009-10-13
tags: added: ubuntuone-karmic
Changed in ubuntuone-client:
importance: High → Critical
Changed in ubuntuone-client:
status: Triaged → In Progress
Facundo Batista (facundo) wrote :

I have a branch almost ready for this, that needs to be tested again and proposed to review.

dobey (dobey) on 2009-10-15
Changed in ubuntuone-client (Ubuntu):
importance: Undecided → Critical
assignee: nobody → Rodney Dawes (dobey)
Changed in ubuntuone-client:
status: In Progress → Fix Committed
dobey (dobey) on 2009-10-16
Changed in ubuntuone-client (Ubuntu):
status: New → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntuone-client - 1.0.2-0ubuntu1

---------------
ubuntuone-client (1.0.2-0ubuntu1) karmic; urgency=low

  * New upstream release.
    - Avoid conflicts due to bouncing FS events (LP: #449605)
    - Don't try to authorize if connect on start is never (LP: #451154)

 -- Rodney Dawes <email address hidden> Fri, 16 Oct 2009 13:35:00 -0400

Changed in ubuntuone-client (Ubuntu):
status: In Progress → Fix Released
Changed in ubuntuone-client:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers