ubuntuone silently fails on connection problem error

Bug #411029 reported by Kye Lewis on 2009-08-09
66
This bug affects 13 people
Affects Status Importance Assigned to Milestone
Ubuntu One Client
High
Stuart Langridge

Bug Description

On connection failure, ubuntuone 0.91.1+r125-0ubuntu1~ppa1~jaunty did not give any visual clue of a connection
problem.

Steps to reproduce:
1. In this case, set system HTTP or HTTPS proxy to an unreachable destination
2. Start ubuntuone-client-applet
3. Client attempts to connect to oAuth for ~3 minutes, then gives up
4. Client still creates and opens Ubuntu One folder in home directory, despite connection failure
5. oauth-login.log states:

2009-08-09 23:48:10,015:15.2680873871 UbuntuOne.OAuthDesktop.auth Making a token request
2009-08-09 23:51:19,065:65.4630661011 UbuntuOne.OAuthDesktop.auth There was some unknown login error '(7, "couldn't connect to host")'

Expected:
1. A notification of the problem or error
2. ubuntuone-client-applet should not go ahead in creating and displaying Ubuntu One folder

Joshua Hoover (joshuahoover) wrote :

Thank you for the detailed bug report Kye. I was able to reproduce this bug following the steps you gave. I'm assigning this to the appropriate person to look into the issue further and consider how to best handle these connection errors.

Changed in ubuntuone-client:
status: New → Triaged
assignee: nobody → Rodney Dawes (dobey)
tags: added: desktop+
bingo1912 (travis-wenks) wrote :

also on my computer when this happens the client disappears from the notification area and the daemon and client still appear in the system monitor

as i watch about 1 time a minute the icon pops on with the red x and falls off after about 20 seconds

Changed in ubuntuone-client:
importance: Undecided → High
dobey (dobey) wrote :

Stuart is looking at the UnknownLoginError issue, in order to make the errors more known (to the user), since we can actually know what the error from pycurl is.

Changed in ubuntuone-client:
assignee: Rodney Dawes (dobey) → Stuart Langridge (sil)
summary: - ubuntuone silently fails on connection problem
+ ubuntuone silently fails on connection problem error
Stuart Langridge (sil) wrote :

The error will now not be wrapped up as UnknownLoginError but raised all the way to the top level as an IOError. I'm not sure what should happen after that. dobey?

dobey (dobey) wrote :

I think this is already solved with your branch that I just landed. The self.callback_error(str(e)) call propagates the error message string to the applet which pops up a dialog which migh tsay "No route to host." for example, similar to the error dialog for failing to launch the browser.

Changed in ubuntuone-client:
status: Triaged → Fix Committed
milestone: none → w25-karmic-finalfreeze
dobey (dobey) on 2009-12-03
Changed in ubuntuone-client:
status: Fix Committed → Fix Released
Jim Park (jimpark31) on 2010-06-07
Changed in ubuntuone-client:
status: Fix Released → Fix Committed
status: Fix Committed → New
status: New → Incomplete
Mitch Towner (kermiac) wrote :

@Jim Park: Please do not change the status of a bug report without an explaining why it was changed. Thanks in advance!

Changed in ubuntuone-client:
status: Incomplete → Fix Released
Jim Park (jimpark31) wrote :

Apologies all, I just setup an account. I think I may have been a bit too click happy finding my way about. Didn't realise I'd managed to change the status 3 times!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers