The add PPA .deb doesn't work

Reported by David Stansby on 2009-06-19
26
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Ubuntu One Client
High
Rodney Dawes

Bug Description

Clicking on the "Add PPA" button on https://ubuntuone.com/support/installation/ doesn't work for me. It downloads the .deb, opens gedbi and starts installing, but then the error "dpkg: unable to read filedescriptor flags for<package status and progress file descriptor>: Bad file descriptor" I think this may be to do with the fact that I am running karmic, whereas the .deb is trying to install a Jaunty ppa.

plun (plun) wrote :

I can confirm this for Karmic.

Changed in ubuntuone-client:
status: New → Confirmed
plun (plun) wrote :

"Walk around" and adding the ppa manually, credits "whiprush"

http://ubuntuforums.org/showthread.php?t=1191708

"Up and running"... ;)

Rick McBride (rmcbride) on 2009-06-19
Changed in ubuntuone-client:
assignee: nobody → Rodney Dawes (dobey)
importance: Undecided → High
status: Confirmed → Triaged
David Stansby (dstansby) wrote :

If the workaround is to put the correct sources lines in, does that not mean that this is a dupe of https://bugs.edge.launchpad.net/ubuntuone-client/+bug/383966 ?

Rodney Dawes (dobey) wrote :

It is not a dup. Rather this seems to be an issue in gdebi (or something related). If after the failure, I simply run "dpkg -i /tmp/ubuntuone-jaunty-ppa.deb" the package installs just fine. Does a similar error occur if you browse to http://launchpad.net/~ubuntuone/+archive/beta and attempt to install the ubuntuone-ppa-beta.deb from the list? (You can see it by expanding the ubuntuone-ppa package to see its packages and information.)

Thanks for the answer, I followed your hint and now it works !

Best regards.

On Wed, 2009-06-24 at 15:02 +0000, Rodney Dawes wrote:
> It is not a dup. Rather this seems to be an issue in gdebi (or something
> related). If after the failure, I simply run "dpkg -i /tmp/ubuntuone-
> jaunty-ppa.deb" the package installs just fine. Does a similar error
> occur if you browse to http://launchpad.net/~ubuntuone/+archive/beta and
> attempt to install the ubuntuone-ppa-beta.deb from the list? (You can
> see it by expanding the ubuntuone-ppa package to see its packages and
> information.)
>

This is a fresh install of 9.04 Karmic (last 3 hours) with only system updates applied; Firefox run once to access newly received Ubuntuone invitation, nothing else. Please advise as to whether to wait for a fix in this instance, or whether to implement the suggested workarounds here?

Note: The error message was the same when I initially forgot to sign into launchpad.

Elliot Murphy (statik) on 2009-07-07
tags: added: ubuntuone-love
David Stansby (dstansby) wrote :

Is this bug really relevant now that Ubuntu-one is installed by default in Ubuntu?

John O'Dwyer (johnrory-odwyer) wrote :

I agree with David's comments in post #7. I updated from Jaunty to Karmic using the update manager which did not remove the ppa. I had problems with ubuntuone in Karmic in that it was not updating my files. I removed all the ubuntuone packages including the ppa and reinstalled without the ppa. All works fine now. I confirm that the ppa is not required in Karmic. Please correct me if I am wrong.

David Stansby (dstansby) wrote :

If that's the case then please could someone with relevant privileges marks this as wont fix?

Rodney Dawes (dobey) wrote :

On Mon, 2009-10-26 at 17:27 +0000, David Stansby wrote:
> If that's the case then please could someone with relevant privileges
> marks this as wont fix?
>

Well, we will still be providing PPAs for the development release, as we
continue to develop after Karmic is released. Though, if this was an
issue with gdebi or dpkg, and it's been fixed, I am happy to mark this
bug as invalid or fixed. Can you confirm that this is indeed the case?
Thanks.

John O'Dwyer (johnrory-odwyer) wrote :

On Mon, 2009-10-26 at 18:41 +0000, Rodney Dawes wrote:
> Well, we will still be providing PPAs for the development release, as we
> continue to develop after Karmic is released. Though, if this was an
> issue with gdebi or dpkg, and it's been fixed, I am happy to mark this
> bug as invalid or fixed. Can you confirm that this is indeed the case?
> Thanks.

I have installed the PPA successfully with GDebi and ubuntuone is updating my files.

David Stansby (dstansby) wrote :

There appears to be no add .ppa deb on the website now

Changed in ubuntuone-client:
status: Triaged → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers