Cross platform Ubuntu One! Need client for Win (Mac and other Linux distributions).

Bug #375349 reported by Michael Kanis on 2009-05-12
176
This bug affects 36 people
Affects Status Importance Assigned to Milestone
Ubuntu One Client
Wishlist
Ubuntu One Client Engineering team
Declined for Trunk by dobey

Bug Description

Similar services like Dropbox are far superior because there are clients for Win, Mac + Linux (also not only debs for Ubuntu!). I can not use this with my friends, so it's not of much use. Your user base will probably be very small.

NOTE: this bug was too general so its been broken out into more specific bugs by platform:
See Bug #601218 Ubuntu One for Windows [DONE]
See Bug #385696 Ubuntu One for Mac OS X [DONE]
See Bug #375145 Ubuntu One for KDE/Kubuntu
See Bug #412424 Ubuntu One client for Debian
See Bug #1212361 Ubuntu One client for Windows Phone

There is a unofficial Fedora client here: http://www.maxiberta.com.ar/blog/ubuntuone-packages-fedora
For arch it's in the community repo: http://www.archlinux.org/packages/?q=ubuntuone

~dobey: We do make tarball releases of all the client software, and anyone is free to package it on their favorite Linux distro. There are some users who are already using it on Fedora, Arch, and Gentoo.

There are some pieces of software which do depend on python-apt, aptdaemon, etc… however, and may not immediately be usable on all other distros which are not Debian based.

Paul Tagliamonte (paultag) wrote :

First Off, I am just a user, not a developer of Ubuntu One.

From what I can see, this is largely python based. In theory, this can run on Windows ( Euch! ) Mac and other Distros. I will try to run this first in Debian W/ GNOME ( If nothing else can run this, it will be Debian ). If this looks promising ( and I think it should ) it should be portable across the other distros with light hacking.

On Tue, May 12, 2009 at 01:44:32PM -0000, Paul Tagliamonte wrote:
> First Off, I am just a user, not a developer of Ubuntu One.
>
> >From what I can see, this is largely python based. In theory, this can
> run on Windows ( Euch! ) Mac and other Distros. I will try to run this
> first in Debian W/ GNOME ( If nothing else can run this, it will be
> Debian ). If this looks promising ( and I think it should ) it should be
> portable across the other distros with light hacking.
>

yes. For running on things other than gnome, the only blocker is the
gnome keyring (there isn't yet a cross-desktop keychain thing).

For running on legacy operating systems you'd need to replace the
inotify bits with the equivalent on the operating system of
choice.

Note that, as the needed pieces are being freed as open source, *anybody* could create clients for KDE, Windows, Mac, VMS, or whatever...

Rick McBride (rmcbride) wrote :

Also, we do have the Web interface, which can be used to download/upload files with any OS that has javascript support in a webbrowser.

Changed in ubuntuone-client:
importance: Undecided → Wishlist
status: New → Triaged
Bruno Areal (bruno-areal) wrote :

I currently use an iMac with MacOS X as a desktop at home, and use an (imposed) windows at my new work.
Since then, i left my ubuntu laptop in my bag, and rarely use it...

Nevertheless, i'm an open source "fan" and, i would be grateful to help cannonical contributing as a "client" of ubuntuOne. But obviously that required that i could use it.

Being currently working as an software analyst and java developer, and just finished my graduation, i'm really available to try to figure out some kind of client. This could simply autenticate an mac or an windows box, and synchronize a predefined folder...
(basically, i'm thinking: "hey, open-source is 'nothing' if your not available to contribute!").

Unfortunately, i'm used to develop in a more "high level", and neither participated in some kind of "open source project", so this task seams more than i can afford....

Is there anyone out there available for some help and some guidance?
I couldn't spend more than 2 hours a week working on this... But it's better than nothing....

Elliot Murphy (statik) wrote :

Bruno, thanks for your offer to help. Stop by #ubuntuone on Freenode IRC or contact us on the mailing list https://launchpad.net/~ubuntuone-users/ and we'll help you get started contributing to the project.

Joshua Blount (jblount) on 2009-07-10
tags: added: dropbox
tlois (tlois3) wrote :

It can be used to access your documents from Windows, which is all I care about, as I use Ubuntu on 5 computers and only one Windows machine by force at work (although I have snuck Ubuntu on to one Windows machine at work too- hee hee- don't tell the IT folks).

Have never used drop box, usually use gdocs in order to access all my docs from anywhere, but there are work forms that don't translate there. I really like UbuntuOne.

So that was just to say that although you may not be able to place docs, etc. into UbuntuOne from a Windows machine, you can definitely access and open them from one by logging into your account.

uncleho (singerhmk) wrote :

This is really a question. Why does it not work on mac or windows?

Changed in ubuntuone-client:
status: Triaged → Invalid
Ludovic Claude (ludovicc) wrote :

Ubuntu One could provide a WebDAV file share, it's slower than having your files locally but this can provide an easy way of integration with Windows, authentication included (use Https + basic authentication)

Matt Griffin (mattgriffin) wrote :

Ludovic - For progress on WebDAV support (current in the wishlist), follow bug #396725.

westurner (westurner) wrote :

Need a windows and mac os x client.

Nico Feiertag (nicofeiertag) wrote :

I agree with Luidovic that a WebDAV interface would help for cross-OS integration, but if you get to have a large amount of data (which 10GB is) you surely want an automatic synchronization -> So I would also vote for a windows sync client.

nUboon2Age (nuboon2age) wrote :

This is both a question and a wishlist item so for some launchpad functions to work correctly it needs to be a bug.

nUboon2Age (nuboon2age) on 2010-07-03
Changed in ubuntuone-client:
status: Invalid → Confirmed
nUboon2Age (nuboon2age) wrote :

See also Bug #601218 (winbuntuone) which has been accepted and is being worked on.

nUboon2Age (nuboon2age) wrote :

Note that according to the Squeeze (next version of Debian) Release goals http://wiki.debian.org/ReleaseGoals/Python2.6 , Python 2.6 is to be the standard.

See also Bug #412424 (specific to Debian so I think it should remain its own separate bug instead of being marked as a duplicate.

nUboon2Age (nuboon2age) wrote :

See also Bug #385696, Ubuntu One for Mac OS X

nUboon2Age (nuboon2age) on 2010-07-19
summary: - No clients for Win, Mac and other Linux distributions.
+ Cross platform Ubuntu One! No clients for Win, Mac and other Linux
+ distributions.

There is a beta coming soon.

Changed in ubuntuone-client:
status: Confirmed → In Progress
papukaija (papukaija) wrote :

(for MS Windows).

nUboon2Age (nuboon2age) on 2010-11-13
summary: - Cross platform Ubuntu One! No clients for Win, Mac and other Linux
- distributions.
+ Cross platform Ubuntu One! Need client for Win (Mac and other Linux
+ distributions).
description: updated
nUboon2Age (nuboon2age) on 2010-11-13
description: updated
Changed in ubuntuone-client:
assignee: nobody → Ubuntu One Desktop+ team (ubuntuone-desktop+)
Leo Arias (elopio) on 2012-06-04
description: updated
papukaija (papukaija) on 2012-06-04
description: updated
tags: removed: dropbox
RobinJ (robinj) wrote :

Any progress in a client for other Linux distributions?

Roberto Alsina (ralsina) wrote :

@RobinJ the client is written, and has nothing ubuntu-specific in it. It's not packaged for some distros because we don't have the expertise to do it. However, we are happy to help anyone trying to package for any distro, and make any needed changes, within reason.

Masoud Abkenar (mabkenar) wrote :

I use Ubuntu on my personal computers. But at my work, I have no choice but CentOS. I am eagerly waiting for someone who can package U1 client for CentOS.

papukaija (papukaija) wrote :

A beta is available at https://one.ubuntu.com/downloads/mac/ for Mac OS X 10.6 and higher.

description: updated
papukaija (papukaija) wrote :

The Mac OS X client is now official. Please see http://voices.canonical.com/ubuntuone/2012/12/19/official-mac-os-x-client-for-ubuntu-one/ for more information. Thanks.

description: updated
papukaija (papukaija) on 2013-08-14
description: updated
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related questions