Comment 114 for bug 375145

Marco Parillo (marco-parillo) wrote :

It seems to work on Kubuntu 12.04 Beta 1 with all updates applied:
1. I opened a Konsole window
2. I typed: sudo apt-get install ubuntuone-control-panel-qt
3: I gave it my password.
4: I was warned about extra packages (see bottom), and was given the option: Do you want to continue [Y/n]?
5: I hit return
6: I got my shell prompt back, and typed exit
7: I started the Kickoff Application Launcher and typed Ubuntu in the seach box, and Ubuntu One was listed.
8: I selected Ubuntu One
9: The Ubuntu One application came up, and it looked to my untrained eyes like a normal KDE app.
10: I signed in with my existing U1 account
11: A message indicator looking like an envelope appeared saying One application running
12: I opened Dolphin, and could see my Ubuntu One folder with my files appearing

P.S. It seemed to have installed a whole lot of dependencies. Are libglib and libgtk indicators that I now have installed parts of Gnome on my vanilla KDE Kubuntu virtual machine?

The following extra packages will be installed: aptdaemon aptdaemon-data gir1.2-atk-1.0 gir1.2-dbusmenu-glib-0.4 gir1.2-dee-1.0 gir1.2-freedesktop gir1.2-gdkpixbuf-2.0 gir1.2-gtk-3.0 gir1.2-indicate-0.7 gir1.2-javascriptcoregtk-3.0 gir1.2-notify-0.7 gir1.2-pango-1.0 gir1.2-soup-2.4 gir1.2-unity-5.0 gir1.2-vte-2.90 gir1.2-webkit-3.0 gnome-keyring indicator-messages indicator-status-provider-mc5 libcap2-bin libdee-1.0-4 libgail-3-0 libgck-1-0 libgcr-3-1 libgcr-3-common libgee2 libgeoclue0 libglib2.0-bin libglib2.0-data libgtk-3-0 libgtk-3-bin libgtk-3-common libindicator-messages-status-provider1 libindicator3-7 libjavascriptcoregtk-3.0-0 libnotify4 libpam-cap libpam-gnome-keyring libprotobuf7 libprotoc7 librsvg2-common libunity9 libvte-2.90-9 libvte-2.90-common libwebkitgtk-3.0-0 libwebkitgtk-3.0-common protobuf-compiler python-aptdaemon python-aptdaemon.gtk3widgets python-configglue python-defer python-dirspec python-pam python-protobuf python-pyinotify python-serial python-twisted-bin python-twisted-core python-twisted-names python-twisted-web python-ubuntu-sso-client python-ubuntuone-client python-ubuntuone-control-panel python-ubuntuone-storageprotocol python-zeitgeist ubuntu-sso-client ubuntu-sso-client-gtk ubuntu-sso-client-qt ubuntuone-client ubuntuone-control-panel ubuntuone-control-panel-common ubuntuone-installer zeitgeist-core Suggested packages: libcap-dev geoclue gvfs python-pam-dbg python-pyinotify-doc python-wxgtk2.8 python-wxgtk2.6 python-wxgtk python-twisted-bin-dbg python-tk python-gtk2 python-glade2 python-qt3 ubuntuone-client-dbg ubuntuone-client-proxy ubuntuone-control-panel-gui zeitgeist-datahub Recommended packages: ubuntu-sso-client-gui The following NEW packages will be installed: aptdaemon aptdaemon-data gir1.2-atk-1.0 gir1.2-dbusmenu-glib-0.4 gir1.2-dee-1.0 gir1.2-freedesktop gir1.2-gdkpixbuf-2.0 gir1.2-gtk-3.0 gir1.2-indicate-0.7 gir1.2-javascriptcoregtk-3.0 gir1.2-notify-0.7 gir1.2-pango-1.0 gir1.2-soup-2.4 gir1.2-unity-5.0 gir1.2-vte-2.90 gir1.2-webkit-3.0 gnome-keyring indicator-messages indicator-status-provider-mc5 libcap2-bin libdee-1.0-4 libgail-3-0 libgck-1-0 libgcr-3-1 libgcr-3-common libgee2 libgeoclue0 libglib2.0-bin libglib2.0-data libgtk-3-0 libgtk-3-bin libgtk-3-common libindicator-messages-status-provider1 libindicator3-7 libjavascriptcoregtk-3.0-0 libnotify4 libpam-cap libpam-gnome-keyring libprotobuf7 libprotoc7 librsvg2-common libunity9 libvte-2.90-9 libvte-2.90-common libwebkitgtk-3.0-0 libwebkitgtk-3.0-common protobuf-compiler python-aptdaemon python-aptdaemon.gtk3widgets python-configglue python-defer python-dirspec python-pam python-protobuf python-pyinotify python-serial python-twisted-bin python-twisted-core python-twisted-names python-twisted-web python-ubuntu-sso-client python-ubuntuone-client python-ubuntuone-control-panel python-ubuntuone-storageprotocol python-zeitgeist ubuntu-sso-client ubuntu-sso-client-gtk ubuntu-sso-client-qt ubuntuone-client ubuntuone-control-panel ubuntuone-control-panel-common ubuntuone-control-panel-qt ubuntuone-installer zeitgeist-core 0 upgraded, 74 newly installed, 0 to remove and 0 not upgraded. Need to get 20.2 MB of archives. After this operation, 75.8 MB of additional disk space will be used. Do you want to continue [Y/n]?