Use of Zeitgeist is Not Useful

Bug #1115324 reported by dobey on 2013-02-04
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Ubuntu One Client
Status tracked in Trunk
Packaging-dailies
Undecided
dobey
Stable-4-2
Undecided
dobey
Trunk
Undecided
dobey
ubuntuone-client (Ubuntu)
Undecided
dobey
Raring
Undecided
dobey

Bug Description

There is currently code in ubuntuone-syncdaemon to log certain things into zeitgeist. This was done as a hopeful measure for doing a visual display of activity in the future. However, no UI has been developed for viewing such activity, and we cannot use zeitgeist for this on Windows or OSX; for which we would need to re-implement this logging in some other manner.

I think it's best for us to remove this code for now, as we aren't really using it as it was intended, and to avoid needing to deal with the extra maintenance work for it, should any problems arise there.

Related branches

dobey (dobey) on 2013-02-04
Changed in ubuntuone-client (Ubuntu Raring):
status: New → Triaged
assignee: nobody → Rodney Dawes (dobey)
Julien Funk (jaboing) on 2013-02-06
tags: added: u1-notrack
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntuone-client - 4.1.91-0ubuntu1

---------------
ubuntuone-client (4.1.91-0ubuntu1) raring; urgency=low

  * New upstream release.
    - Remove unnecessary use of zeitgeist. (LP: #1115324)
    - Switch from python-oauth to python-oauthlib. (LP: #1077089)
  * debian/control:
    - Switch python-oauth dependency to python-oauthlib.
    - Drop syncmenu gir from build-depends to enable building on 12.04.
    - Drop zeitgeist dependencies.
    - Update other dependencies to be more correct.
  * debian/copyright:
    - Update to remove CC-By-SA license as no icons are included now.
  * debian/docs:
    - Remove the COPYING.icons that no longer exists.
  * debian/patches/00_apport_py3.patch:
    - Removed patch that is merged upstream.
  * debian/python-ubuntuone-client.install:
    - Remove the zeitgeist related files from install.
 -- Rodney Dawes <email address hidden> Thu, 21 Feb 2013 11:38:31 -0500

Changed in ubuntuone-client (Ubuntu Raring):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers