kylin-display-switch crashed with PermissionError and TypeError

Bug #1766491 reported by kyt on 2018-04-24
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu Kylin
Undecided
Shine Huang
kylin-display-switch (Ubuntu)
Undecided
Unassigned
Nominated for Bionic by handsome_feng

Bug Description

[Impact]
when switch user:
kylin_display_switch.py crashed with PermissionError in check_singleton():[Errno 13]权限不够:/tmp/instance_kds.lock';
kylin_display_switch.py crashed with TypeError in slot_tip_numlock():'>' not supported between instances of 'bultin_function_or_method' and 'int'

[Test Case]
1. Login
2. Switch User
Expected Result:Passed
Actual Result:
1. kylin_display_switch.py crashed with TypeError
2. kylin_display_switch.py crashed with PermissionError

[Regression Potential]
Low, The first change is to allow all user to access the instance_kds.lock, and the second change is add the missing parentheses.

Xu Jianhong (jianhong) wrote :

This bug was not fixed in bionic-final 0425 version

kyt (952456204-6) on 2018-04-28
Changed in ubuntukylin:
milestone: none → bionic-final
kyt (952456204-6) on 2018-04-28
Changed in ubuntukylin:
status: New → Fix Released
handsome_feng (feng-kylin) wrote :

Reopen since it appear in 18.10 beta.

Changed in ubuntukylin:
status: Fix Released → Fix Committed
milestone: bionic-final → none
handsome_feng (feng-kylin) wrote :
Changed in kylin-display-switch (Ubuntu):
status: New → Fix Released
Changed in ubuntukylin:
status: Fix Committed → Fix Released
summary: - [Kylin Display Switch]kylin_display_switch.py crashed
+ kylin-display-switch crashed with permission error
summary: - kylin-display-switch crashed with permission error
+ kylin-display-switch crashed with PermissionError and TypeError
description: updated
description: updated
tags: added: verification-needed verification-needed-bionic
removed: bionic-beta2
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers