[error-report]error occurs when reading /etc/profile

Bug #1722427 reported by qiu on 2017-10-10
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu Kylin
Critical
Unassigned
im-config (Ubuntu)
High
Gunnar Hjalmarsson

Bug Description

system:artful-1008-64bit

process:
1.start the system
2.put in password
3.after the log in screen, an error message shows up, check the attached file

expectation:
no error message shows up after log in

qiu (qiu) wrote :
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1722427

tags: added: iso-testing
Changed in ubuntukylin:
status: New → Confirmed
importance: Undecided → Critical
Gunnar Hjalmarsson (gunnarhj) wrote :

Thanks for your report.

I can reproduce this sometimes on Unity with LightDM and the Fcitx packages for Simplified Chinese. When it happens, ~/.xsession-errors looks like the attached file.

The explanation is a temporary file in /etc/profile.d for configuring input methods (see bug #1720250). LightDM checks for errors when sourcing that file, and apparently the launch of Fcitx results in messages written to STDERR (sometimes...). I have submitted a LightDM merge proposal to disable that error check for now.

@Iain: Can you please look at this. I suppose that there is no LightDM release planned before release, so we should probably make an Ubuntu only upload with this one change.

qiu (qiu) wrote :

if i uninstall fcitx or remove /etc/profile.d/input-method-config.sh, this error would not appear.

Gunnar Hjalmarsson (gunnarhj) wrote :

This is the .xsession-errors file I mentioned.

Changed in lightdm (Ubuntu):
assignee: nobody → Gunnar Hjalmarsson (gunnarhj)
importance: Undecided → High
milestone: none → ubuntu-17.10
status: New → In Progress
Gunnar Hjalmarsson (gunnarhj) wrote :

Attached a debdiff corresponding to the merge proposal.

This will hopefully be handled on Monday.

tags: added: patch
Gunnar Hjalmarsson (gunnarhj) wrote :

I have found another way to fix this issue, which I think is better. Fcitx is launched at login from the /usr/share/im-config/data/22_fcitx.rc file. Changing line #6 in that file from

/usr/bin/fcitx &

to

/usr/bin/fcitx 2>/dev/null &

makes the 'noise' from launching Fcitx disappear so it won't trigger the error dialog. This keeps the fix within the im-config package without involving lightdm.

At least this worked for me on Unity. It would be great if some Kylin users could test it on Ubuntu Kylin.

handsome_feng (feng-kylin) wrote :

Hi, Gunnar, I have modified the 22_fcitx.rc in ubuntu kylin as you mentioned, and It worked, Thank you!

Gunnar Hjalmarsson (gunnarhj) wrote :

@Laney / release team: To gain time, and since I hope there is still time for this to make it to the ISO, I have uploaded an im-config change to the unapproved queue, even if there was no preceding approval from the release-team. Hope this is considered ok.

Changed in im-config (Ubuntu):
assignee: nobody → Gunnar Hjalmarsson (gunnarhj)
importance: Undecided → High
milestone: none → ubuntu-17.10
status: New → In Progress
no longer affects: fcitx (Ubuntu)
no longer affects: lightdm (Ubuntu)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package im-config - 0.32-1ubuntu3

---------------
im-config (0.32-1ubuntu3) artful; urgency=high

  * debian/patches/discard-fcitx-launch-errors.patch:
    - Discard STDERR messages when launching Fcitx to prevent that the
      DMs' error dialog is shown gratuitously at login (LP: #1722427).

 -- Gunnar Hjalmarsson <email address hidden> Sun, 15 Oct 2017 11:21:00 +0200

Changed in im-config (Ubuntu):
status: In Progress → Fix Released
Changed in ubuntukylin:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers