The command "who -m" doesn't work

Bug #1564695 reported by Eason on 2016-04-01
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
GNOME Terminal
Fix Released
Wishlist
Ubuntu Kylin
Undecided
zhangchao
coreutils (Ubuntu)
High
Unassigned
gnome-terminal (Ubuntu)
High
Unassigned
vte2.91 (Ubuntu)
High
Unassigned

Bug Description

The command "who -m" doesn't work.

ps: This bug also exists in ubuntu 16.04 x64 Daily build 20160329

who -m只能没有作用,执行没有任何输出

Steps:
1. Install the Ubuntu Kylin 16.04 x64 Daily build 20160329
2. Boot the system
3. Open terminal, run the command "who -m"
--Failed. It doesn't work after run the command. It should show the hostname and user asociated with stdin.

Configuration:
PC: Dell Vostor
OS: Ubuntu Kylin 16.04 x64 Daily build 20160329

Paul White (paulw2u) on 2016-04-26
affects: ubuntu → coreutils (Ubuntu)
zhangchao (zctgbhu) on 2016-05-14
Changed in ubuntukylin:
milestone: xenial-finalrelease → yakkety-alpha1
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1564695

tags: added: iso-testing
Changed in ubuntukylin:
milestone: yakkety-alpha1 → yakkety-beta1
Changed in ubuntukylin:
milestone: yakkety-beta1 → yakkety-beta2
Changed in ubuntukylin:
milestone: yakkety-beta2 → yakkety-finalrelease
Brian Murray (brian-murray) wrote :

I was unable to recreate this on an Ubuntu system running either 16.04 and 16.10.

Changed in coreutils (Ubuntu):
status: New → Incomplete
Mikma (mikma) wrote :

The source of the problem is gnome-terminal in 16.04 which doesn't update wtmp. It broke a script of mine.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-terminal (Ubuntu):
status: New → Confirmed
Changed in vte2.91 (Ubuntu):
status: New → Confirmed
tags: added: xenial

If you are still experiencing this bug please set status back to "confirmed".

Changed in ubuntukylin:
status: New → Confirmed
status: Confirmed → Incomplete
Changed in gnome-terminal (Ubuntu):
status: Confirmed → Incomplete
Changed in vte2.91 (Ubuntu):
status: Confirmed → Incomplete
importance: Undecided → Medium
Changed in gnome-terminal (Ubuntu):
importance: Undecided → Medium
Changed in coreutils (Ubuntu):
importance: Undecided → Medium
importance: Medium → High
Changed in gnome-terminal (Ubuntu):
importance: Medium → High
Changed in vte2.91 (Ubuntu):
importance: Medium → High
C de-Avillez (hggdh2) wrote :

Setting the coreutils task to invalid. 'who' reports based on wtmp. If wtmp is not being updated by the applications, this is not a coreutils issue.

Changed in coreutils (Ubuntu):
status: Incomplete → Invalid
Changed in gnome-terminal:
importance: Unknown → Wishlist
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.