The compress function works abnormal for trash, disk and so on

Bug #1403377 reported by Eason on 2014-12-17
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
File Roller
Confirmed
Medium
Ubuntu Kylin
Medium
lenky0401
file-roller (Ubuntu)
Low
Unassigned

Bug Description

The compress function works abnormal for trash, disk and so on.

右键点击回收站、磁盘等,选择压缩,点击确认提示压缩成功,实际上未生成压缩文件

Steps:
1. Login system
2. Right click for trash or disk
3. Chose compress
4. Click "OK" button
5. After compress successfully, check the gz file
-->Failed. There is no gz file found.

Configuration:
OS: Vivid x32 Daily Build 20141214

Eason (qulei) wrote :
Changed in ubuntukylin:
milestone: none → vivid-alpha2
importance: Undecided → High
Eason (qulei) on 2014-12-18
Changed in ubuntukylin:
assignee: zhangchao (zctgbhu) → nobody
assignee: nobody → Ubuntu Kylin Members (ubuntukylin-members)
Jack Yu (jackyu) wrote :

应该是Nautilus的Bug,分配给Lenky.

Changed in ubuntukylin:
assignee: Ubuntu Kylin Members (ubuntukylin-members) → lenky0401 (lenky0401)
Changed in ubuntukylin:
milestone: vivid-alpha2 → vivid-beta1
lenky0401 (lenky0401) wrote :

nautilus的压缩插件file-roller没有处理中间过程的相关信息,没有等待压缩结束后做再做结果判定和提示,而caja的压缩插件engrampa就有处理,所以在caja里,压缩回收站会提示错误:

engrampa是从file-roller上fork修改而来,改动较大,要修这个问题,对应的改动也会比较大,就是相当于要新增事件,然后处理事件,然后给出弹窗错误信息等。

lenky0401 (lenky0401) wrote :
lenky0401 (lenky0401) wrote :

没有采用caja那么复杂的方法,直接在右键菜单里进行判断,如果选中的文件有以x-nautilus-desktop开头,就不显示压缩选项。

会以x-nautilus-desktop开头的文件满足两个规则:
1,在桌面上。
2,主文件夹、回收站、网络设置、各种移动U盘在桌面上的显示盘符文件,本地磁盘挂载后在桌面上显示的盘符文件,等。

ps:桌面上的其他普通文件会以file:开头,所以能够正常显示压缩选项。

lenky0401 (lenky0401) wrote :

附件是patch。

tags: added: patch
Jack Yu (jackyu) on 2015-02-04
Changed in ubuntukylin:
status: New → In Progress

The attachment "1403377.patch" seems to be a patch. If it isn't, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are a member of the ~ubuntu-reviewers, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issues please contact him.]

Anthony Wong (anthonywong) wrote :

Lenky, can you file a bug upstream and submit your patch to them?

Anthony Wong (anthonywong) wrote :
Changed in file-roller:
importance: Undecided → Unknown
status: New → Unknown
Changed in ubuntukylin:
milestone: vivid-beta1 → vivid-beta2
Changed in file-roller:
importance: Unknown → Medium
status: Unknown → Confirmed
Changed in file-roller (Ubuntu):
importance: Undecided → Low
status: New → Triaged
Iain Lane (laney) wrote :

Thanks! I'd like to wait for upstream review if that's okay. Could you set back to 'New' once we should review again, please?

Changed in file-roller (Ubuntu):
status: Triaged → Incomplete
Changed in ubuntukylin:
importance: High → Medium
Iain Lane (laney) on 2015-03-03
Changed in file-roller (Ubuntu):
status: Incomplete → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package file-roller - 3.14.2-0ubuntu5

---------------
file-roller (3.14.2-0ubuntu5) vivid; urgency=medium

  * 0001-fixed-Compress-command-visible-for-trash-and-disk-dr.patch: Fix
    non-functional "compress" appearing in the context menu for drives and
    trash. (LP: #1403377)
 -- Iain Lane <email address hidden> Tue, 03 Mar 2015 11:12:16 +0000

Changed in file-roller (Ubuntu):
status: Fix Committed → Fix Released
Anthony Wong (anthonywong) wrote :

Thank you :)

Changed in ubuntukylin:
status: In Progress → Fix Released
jiaowen520li (jiaowen520li) wrote :

This bug has been fixed in UK15.04-0311-Daily-amd64.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.