In UEFI mode, default langauge in Ubiquity language chooser is not Simplified Chinese

Bug #1380981 reported by shijing on 2014-10-14
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu CD Images
Undecided
Unassigned
Ubuntu Kylin
Critical
FanJun Kong - ( BH1SCW )
Trusty
Undecided
Unassigned

Bug Description

In UEFI mode, default langauge in Ubiquity language chooser is not Simplified Chinese.
and non-UEFI mode is correct.

Related branches

shijing (shijing) wrote :

this bug also exist in trusty.

Changed in ubuntukylin:
importance: Undecided → Medium
Jack Yu (jackyu) on 2014-10-15
Changed in ubuntukylin:
assignee: nobody → zhangchao (zctgbhu)
milestone: none → utopic-rc
zhangchao (zctgbhu) on 2014-10-15
Changed in ubuntukylin:
assignee: zhangchao (zctgbhu) → Anthony Wong (anthonywong)
Anthony Wong (anthonywong) wrote :

@zhangchao
Because this bug exists since previous releases, can you investigate if you can fix it with a patch?

Changed in ubuntukylin:
milestone: utopic-rc → vivid-beta1
assignee: Anthony Wong (anthonywong) → zhangchao (zctgbhu)
zhangchao (zctgbhu) wrote :

@Anthony Wong
OK,I'll see what I can do.

Changed in ubuntukylin:
importance: Medium → High
importance: High → Critical
zhangchao (zctgbhu) on 2015-01-30
Changed in ubuntukylin:
milestone: vivid-beta1 → vivid-beta2
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1380981

tags: added: iso-testing
jiaowen520li (jiaowen520li) wrote :

This bug still exists in UK15.04-0311-Daily-amd64.

zhangchao (zctgbhu) wrote :

@Anthony Wong
This bug can be fixed by manually
Increase the “locale=zh_CN” in iso image file: boot/grub/grub.cfg
For example:
menuentry "Try Ubuntu Kylin without installing" {
 set gfxpayload=keep
 linux /casper/vmlinuz.efi file=/cdrom/preseed/ubuntu.seed boot=casper locale=zh_CN quiet splash --
 initrd /casper/initrd.lz
}

Aron Xu (happyaron) on 2015-03-27
Changed in ubuntukylin:
milestone: vivid-beta2 → vivid-rc
jiaowen520li (jiaowen520li) wrote :

This bug still exists in UK15.04-0408-Daily-amd64&i386.

Jack Yu (jackyu) on 2015-04-10
Changed in ubuntukylin:
assignee: zhangchao (zctgbhu) → F.J Kong (fjkong)
jiaowen520li (jiaowen520li) wrote :

This bug still exists in UK15.04-0412-Daily-amd64&i386.

jiaowen520li (jiaowen520li) wrote :

This bug still exists in UK15.04-0421-Daily-amd64.

jiaowen520li (jiaowen520li) wrote :

This bug still exists in UK15.04-0422-Daily-amd64.

Unfortunately, the merge proposal I did for debian-cd didn't get reviewed let, so it was not used to generate the final CD for UbuntuKylin.

I've linked the merge proposal to this bug now so it can be tracked.

For now, you can manually set "locale=zh_CN" in the command-line when booting in UEFI mode, by hit the 'e' key and adding locale=zh_CN to the end of the "kernel" line, after the ---.

Adam Conrad (adconrad) wrote :

This appears to be fixed for wily, with a pending merge proposal to fix it for trusty.

Changed in ubuntukylin:
status: New → Fix Released
jiaowen520li (jiaowen520li) wrote :

This bug is fixed in UK14.04.3-0806-Daily-amd64.

Adam Conrad (adconrad) on 2015-08-06
Changed in ubuntu-cdimage:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers