There is "Restart" item in startup menu after power on/restart/log in system, the item will disappear in a few minutes

Bug #1365208 reported by Eason on 2014-09-04
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Ubuntu Kylin
Medium
FanJun Kong - ( BH1SCW )
indicator-session (Ubuntu)
Low
Marco Trevisan (Treviño)

Bug Description

There is "Restart" item in startup menu after power on/restart/log in system, the item will disappear in a few minutes.

Steps:
1. Power on/Restart/Log in system
2. Click the start up menu at the top right of screen
3. Check the item in start up menu--->There is "Restart" item exists.
4. Wait for a few minutes, open the start up menu to check the item again.
-->Failed. The "Restart" item disappear

Configuration:
PC: Dell Vostro
OS: Ubuntu Kylin Utopic 14.10 Beta1

Related branches

Jack Yu (jackyu) on 2014-09-12
Changed in ubuntukylin:
assignee: Huan Peng (penghuanmail) → Joey Zheng (jzheng)
importance: Undecided → Wishlist
Joey Zheng (jzheng) wrote :

@Fanjun
Please help on this bug, and see if this issue is in Ubuntu 14.10, or only in Ubuntu Kylin.

Changed in ubuntukylin:
assignee: Joey Zheng (jzheng) → F.J Kong (fjkong)
importance: Wishlist → Medium

@joey
I test ubuntu kylin and ubuntu both download from 14.10 daily build version,
result:
I can reproduce on uk, restart button will disappear in a few seconds
ubuntu 14.10 is uniy8, it is different from uk about menu item

any more test?

update:

I jsut tested ubuntu 14.10, it will disappear too, I think this is a bug on both of that.

Changed in ubuntukylin:
status: New → Confirmed
Sebastien Bacher (seb128) wrote :

that's an indicator-session issue and has been mentioned in the past in e.g https://bugs.launchpad.net/ubuntu/+source/indicator-session/+bug/1203355/comments/25

Sebastien Bacher (seb128) wrote :

Looking at the code it's supposed to be disabled under Unity since restart/shutdown trigger the same dialog there, it seems it just takes a bit to the code to get the information that it's under Unity and toggle the item, maybe we should change the default since Unity is the main user of that indicator?

no longer affects: indicator-session
Changed in indicator-session (Ubuntu):
importance: Undecided → Low
status: New → Confirmed
Changed in indicator-session (Ubuntu):
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
status: Confirmed → In Progress
Amr Ibrahim (amribrahim1987) wrote :

Restart also disappears after some time in Trusty.

tags: added: trusty
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-session - 12.10.5+16.04.20160412-0ubuntu1

---------------
indicator-session (12.10.5+16.04.20160412-0ubuntu1) xenial; urgency=medium

  * Ensure we request the UI to verify restart availability on unity
    state changes (LP: #1365208)

 -- Marco Trevisan (Treviño) <mail@3v1n0.net> Tue, 12 Apr 2016 11:58:30 +0000

Changed in indicator-session (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers