In Ubuntu Kylin, default langauge in Ubiquity language chooser is not Simplified Chinese, isolinux/lang not honoured

Bug #1330416 reported by shijing on 2014-06-16
20
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Ubuntu CD Images
Critical
Colin Watson
Ubuntu Kylin
Critical
Anthony Wong

Bug Description

In Ubuntu Kylin image, isolinux/lang is zh_CN, but the default language in Ubiquity language chooser is still English.

In /proc/cmdline, there is no "debian-installer/language" nor "locale".

---

Original description:

系 统:UK 14.10 dailybuild 32 位 6-15
机器型号:vritualbox
现 象: 欢迎界面语言默认不是简体中文。如图welcome.png

shijing (shijing) wrote :
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1330416

tags: added: iso-testing
Jack Yu (jackyu) on 2014-09-03
Changed in ubuntukylin:
importance: Undecided → High
assignee: nobody → Huan Peng (penghuanmail)
milestone: none → utopic-beta2
Jack Yu (jackyu) on 2014-09-12
Changed in ubuntukylin:
importance: High → Critical
assignee: Huan Peng (penghuanmail) → nobody
assignee: nobody → Anthony Wong (anthonywong)
zhangchao (zctgbhu) on 2014-09-15
Changed in ubuntukylin:
status: New → Confirmed
summary: - 欢迎界面语言默认不是简体中文
+ isolinux/lang is not honoured 欢迎界面语言默认不是简体中文
summary: - isolinux/lang is not honoured 欢迎界面语言默认不是简体中文
+ In Ubuntu Kylin, default langauge in Ubiquity language chooser is not
+ Simplified Chinese, isolinux/lang not honoured
description: updated
Anthony Wong (anthonywong) wrote :

Pinged cjwatson on irc last Friday and notify him this bug, but he was too occupied at that time.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gfxboot-theme-ubuntu (Ubuntu):
status: New → Confirmed
Changed in ubuntukylin:
milestone: utopic-beta2 → utopic-final
Colin Watson (cjwatson) wrote :

revno: 1899
fixes bug: https://launchpad.net/bugs/1330416
committer: Colin Watson <email address hidden>
branch nick: debian-cd
timestamp: Mon 2014-10-06 16:37:47 +0100
message:
  Copy isolinux/lang into the bootlogo archive if it exists.

affects: gfxboot-theme-ubuntu (Ubuntu) → ubuntu-cdimage
Changed in ubuntu-cdimage:
importance: Undecided → Critical
assignee: nobody → Colin Watson (cjwatson)
assignee: Colin Watson (cjwatson) → nobody
status: Confirmed → Fix Released
assignee: nobody → Colin Watson (cjwatson)
shijing (shijing) wrote :

this bug in ubuntukylin 10.10 dailybuild iso had been fixed.

Changed in ubuntukylin:
status: Confirmed → Fix Released
shijing (shijing) on 2014-10-13
Changed in ubuntukylin:
status: Fix Released → Confirmed
shijing (shijing) wrote :

In BIOS, I choose usb hard drive (UEFI)--Generic Flash Disk options,the default langauge in Ubiquity language chooser is not Simplified Chinese, when I choose the option without UEFI (usb hard drive--Generic Flash Disk), the default langauge is Simplified Chinese. so, I reopen this bug.

Anthony Wong (anthonywong) wrote :

Shijing, could you file a new bug for the UEFI problem? The original problem has already been fixed, but since isolinux/lang is not used in UEFI so we need a new bug.

Changed in ubuntukylin:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Bug attachments