“sudo apt-get update” reports no public key error (apt-get update报没有公钥的错误)

Bug #1306868 reported by jiaowen520li on 2014-04-12
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu Kylin
High
Jack Yu
ubuntukylin-keyring (Ubuntu)
High
Steve Langasek

Bug Description

系统版本:UK14.04-Daily-0411.1-i386
使用“sudo apt-get update”命令,有报错信息:“W: GPG 错误:http://archive.ubuntukylin.com:10006 trusty Release: 由于没有公钥,无法验证下列签名: NO_PUBKEY 0319EDBA198BF247”。

jiaowen520li (jiaowen520li) wrote :
tags: added: trusty
Ma Jun (maclin.jun) on 2014-04-12
summary: - 使用“sudo apt-get update”命令,有报错信息。
+ 使用“sudo apt-get update”命令,报没有公钥

需要使用新的签名。

Changed in ubuntukylin:
importance: Undecided → High
milestone: none → trusty-final-freeze
assignee: nobody → shijing (shijing)
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1306868

tags: added: iso-testing
Dimitri John Ledkov (xnox) wrote :

This is not the bug with ubuntukylin-keyring, but rather archive.ubuntukylin.com:10006
As the key in ubuntukylin-keyring is the correct key 4096R/6CE3 5A4E BAB6 7609 4476 BE7C D259 B755 5E1D 3C58
Yet the archive.ubuntukylin.com:10006 is 4096R/05E5 9D00 DAFD 8474 E9A7 BE19 0319 EDBA 198B F247

Changed in ubuntukylin:
status: New → Confirmed
Dimitri John Ledkov (xnox) wrote :

I believe slangasek was involved in setting this up correctly, thus i'll assign this bug to him to coordinate.

Changed in ubuntukylin:
assignee: shijing (shijing) → Steve Langasek (vorlon)
Changed in ubuntukylin-keyring (Ubuntu):
assignee: nobody → Steve Langasek (vorlon)
status: New → Confirmed
importance: Undecided → High
Changed in ubuntukylin:
assignee: Steve Langasek (vorlon) → shijing (shijing)
Steve Langasek (vorlon) wrote :

As you say, it's not a bug in the keyring package. We are still in the process of bringing up the archive properly with the correct key.

Changed in ubuntukylin-keyring (Ubuntu):
status: Confirmed → Invalid
Jack Yu (jackyu) wrote :

Yep, we are doing it.

Changed in ubuntukylin:
status: Confirmed → In Progress
assignee: shijing (shijing) → Jack Yu (jackyu)
Ma Jun (maclin.jun) on 2014-04-17
summary: - 使用“sudo apt-get update”命令,报没有公钥
+ “sudo apt-get update” reports no public key error (apt-get
+ update报没有公钥的错误)
Jack Yu (jackyu) on 2014-04-17
Changed in ubuntukylin:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers